summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorGard Spreemann <gspr@nonempty.org>2019-09-25 15:09:43 +0200
committerGard Spreemann <gspr@nonempty.org>2019-09-25 15:09:43 +0200
commit3d092293bab8b5d9e866ac51283d95927f41c337 (patch)
tree31385442d5fb7984662385baee85cb5b73ed2f01 /debian
parent1fa3227fab8b27a397952c44cb6ed9d2ee71eb42 (diff)
Prepare for refreshed patches.
Diffstat (limited to 'debian')
-rw-r--r--debian/patches/0001-Disable-Sphinx-test-since-we-re-not-currently-buildi.patch24
-rw-r--r--debian/patches/0002-Disable-tests-that-use-DFSG-deleted-data-files.patch121
-rw-r--r--debian/patches/0003-Use-system-MathJax.patch21
-rw-r--r--debian/patches/0004-Don-t-set-runtime-library-dirs-for-Python-extensions.patch21
-rw-r--r--debian/patches/0005-Force-linking-of-Python-module-with-CGAL.patch21
-rw-r--r--debian/patches/0006-Force-linking-against-libatomic-for-parts-that-use-T.patch21
-rw-r--r--debian/patches/0007-Offline-header-for-docs.patch21
-rw-r--r--debian/patches/0008-Propagate-CXXFLAGS-when-building-Python-modules.patch24
-rw-r--r--debian/patches/series8
9 files changed, 0 insertions, 282 deletions
diff --git a/debian/patches/0001-Disable-Sphinx-test-since-we-re-not-currently-buildi.patch b/debian/patches/0001-Disable-Sphinx-test-since-we-re-not-currently-buildi.patch
deleted file mode 100644
index d8bca9da..00000000
--- a/debian/patches/0001-Disable-Sphinx-test-since-we-re-not-currently-buildi.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-From: Gard Spreemann <gspreemann@gmail.com>
-Date: Mon, 10 Sep 2018 05:16:45 +0200
-Subject: Disable Sphinx test since we're not currently building the Sphinx
- docs.
-
----
- cython/CMakeLists.txt | 5 -----
- 1 file changed, 5 deletions(-)
-
-diff --git a/cython/CMakeLists.txt b/cython/CMakeLists.txt
-index 09ea28f..829d53b 100644
---- a/cython/CMakeLists.txt
-+++ b/cython/CMakeLists.txt
-@@ -396,10 +396,5 @@ if(CYTHON_FOUND)
- DEPENDS "${CMAKE_CURRENT_BINARY_DIR}/gudhi.so"
- COMMENT "${GUDHI_SPHINX_MESSAGE}" VERBATIM)
-
-- add_test(NAME sphinx_py_test
-- WORKING_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR}
-- COMMAND ${CMAKE_COMMAND} -E env "PYTHONPATH=${CMAKE_CURRENT_BINARY_DIR}"
-- ${SPHINX_PATH} -b doctest ${CMAKE_CURRENT_SOURCE_DIR}/doc ${CMAKE_CURRENT_BINARY_DIR}/doctest)
--
- endif()
- endif(CYTHON_FOUND)
diff --git a/debian/patches/0002-Disable-tests-that-use-DFSG-deleted-data-files.patch b/debian/patches/0002-Disable-tests-that-use-DFSG-deleted-data-files.patch
deleted file mode 100644
index e59a4f8b..00000000
--- a/debian/patches/0002-Disable-tests-that-use-DFSG-deleted-data-files.patch
+++ /dev/null
@@ -1,121 +0,0 @@
-From: Gard Spreemann <gspreemann@gmail.com>
-Date: Mon, 10 Sep 2018 05:17:29 +0200
-Subject: Disable tests that use DFSG-deleted data files.
-
----
- cython/CMakeLists.txt | 30 ----------------------------
- example/Nerve_GIC/CMakeLists.txt | 6 ------
- example/Persistent_cohomology/CMakeLists.txt | 4 ----
- example/Simplex_tree/CMakeLists.txt | 2 --
- utilities/Nerve_GIC/CMakeLists.txt | 8 --------
- 5 files changed, 50 deletions(-)
-
-diff --git a/cython/CMakeLists.txt b/cython/CMakeLists.txt
-index 829d53b..219b99e 100644
---- a/cython/CMakeLists.txt
-+++ b/cython/CMakeLists.txt
-@@ -265,36 +265,6 @@ if(CYTHON_FOUND)
-
- add_gudhi_py_test(test_bottleneck_distance)
-
-- # Cover complex
-- file(COPY ${CMAKE_SOURCE_DIR}/data/points/human.off DESTINATION ${CMAKE_CURRENT_BINARY_DIR}/)
-- file(COPY ${CMAKE_SOURCE_DIR}/data/points/COIL_database/lucky_cat.off DESTINATION ${CMAKE_CURRENT_BINARY_DIR}/)
-- file(COPY ${CMAKE_SOURCE_DIR}/data/points/COIL_database/lucky_cat_PCA1 DESTINATION ${CMAKE_CURRENT_BINARY_DIR}/)
-- add_test(NAME cover_complex_nerve_example_py_test
-- WORKING_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR}
-- COMMAND ${CMAKE_COMMAND} -E env "PYTHONPATH=${CMAKE_CURRENT_BINARY_DIR}"
-- ${PYTHON_EXECUTABLE} "${CMAKE_CURRENT_SOURCE_DIR}/example/nerve_of_a_covering.py"
-- -f human.off -c 2 -r 10 -g 0.3)
--
-- add_test(NAME cover_complex_coordinate_gic_example_py_test
-- WORKING_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR}
-- COMMAND ${CMAKE_COMMAND} -E env "PYTHONPATH=${CMAKE_CURRENT_BINARY_DIR}"
-- ${PYTHON_EXECUTABLE} "${CMAKE_CURRENT_SOURCE_DIR}/example/coordinate_graph_induced_complex.py"
-- -f human.off -c 0 -v)
--
-- add_test(NAME cover_complex_functional_gic_example_py_test
-- WORKING_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR}
-- COMMAND ${CMAKE_COMMAND} -E env "PYTHONPATH=${CMAKE_CURRENT_BINARY_DIR}"
-- ${PYTHON_EXECUTABLE} "${CMAKE_CURRENT_SOURCE_DIR}/example/functional_graph_induced_complex.py"
-- -o lucky_cat.off
-- -f lucky_cat_PCA1 -v)
--
-- add_test(NAME cover_complex_voronoi_gic_example_py_test
-- WORKING_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR}
-- COMMAND ${CMAKE_COMMAND} -E env "PYTHONPATH=${CMAKE_CURRENT_BINARY_DIR}"
-- ${PYTHON_EXECUTABLE} "${CMAKE_CURRENT_SOURCE_DIR}/example/voronoi_graph_induced_complex.py"
-- -f human.off -n 700 -v)
--
-- add_gudhi_py_test(test_cover_complex)
- endif (NOT CGAL_VERSION VERSION_LESS 4.8.1)
-
- if (NOT CGAL_WITH_EIGEN3_VERSION VERSION_LESS 4.7.0)
-diff --git a/example/Nerve_GIC/CMakeLists.txt b/example/Nerve_GIC/CMakeLists.txt
-index fdecf86..f63e08e 100644
---- a/example/Nerve_GIC/CMakeLists.txt
-+++ b/example/Nerve_GIC/CMakeLists.txt
-@@ -12,16 +12,10 @@ if (NOT CGAL_VERSION VERSION_LESS 4.8.1)
-
- # Copy files for not to pollute sources when testing
- file(COPY "${CMAKE_SOURCE_DIR}/data/points/tore3D_1307.off" DESTINATION ${CMAKE_CURRENT_BINARY_DIR}/)
-- file(COPY "${CMAKE_SOURCE_DIR}/data/points/COIL_database/lucky_cat.off" DESTINATION ${CMAKE_CURRENT_BINARY_DIR}/)
-- file(COPY "${CMAKE_SOURCE_DIR}/data/points/COIL_database/lucky_cat_PCA1" DESTINATION ${CMAKE_CURRENT_BINARY_DIR}/)
-
- add_test(NAME Nerve_GIC_example_CoordGIC COMMAND $<TARGET_FILE:CoordGIC>
- "${CMAKE_CURRENT_BINARY_DIR}/tore3D_1307.off" "0")
-
-- add_test(NAME Nerve_GIC_example_FuncGIC COMMAND $<TARGET_FILE:FuncGIC>
-- "${CMAKE_CURRENT_BINARY_DIR}/lucky_cat.off"
-- "${CMAKE_CURRENT_BINARY_DIR}/lucky_cat_PCA1")
--
- install(TARGETS CoordGIC DESTINATION bin)
- install(TARGETS FuncGIC DESTINATION bin)
-
-diff --git a/example/Persistent_cohomology/CMakeLists.txt b/example/Persistent_cohomology/CMakeLists.txt
-index 0f73151..4cac586 100644
---- a/example/Persistent_cohomology/CMakeLists.txt
-+++ b/example/Persistent_cohomology/CMakeLists.txt
-@@ -28,10 +28,6 @@ add_test(NAME Persistent_cohomology_example_from_rips_step_by_step_on_tore_3D CO
- "${CMAKE_SOURCE_DIR}/data/points/tore3D_1307.off" "-r" "0.25" "-m" "0.5" "-d" "3" "-p" "3")
- add_test(NAME Persistent_cohomology_example_via_boundary_matrix COMMAND $<TARGET_FILE:rips_persistence_via_boundary_matrix>
- "${CMAKE_SOURCE_DIR}/data/points/Kl.off" "-r" "0.16" "-d" "3" "-p" "3" "-m" "100")
--add_test(NAME Persistent_cohomology_example_from_file_3_2_0 COMMAND $<TARGET_FILE:persistence_from_file>
-- "${CMAKE_SOURCE_DIR}/data/filtered_simplicial_complex/bunny_5000_complex.fsc" "-p" "2" "-m" "0")
--add_test(NAME Persistent_cohomology_example_from_file_3_3_100 COMMAND $<TARGET_FILE:persistence_from_file>
-- "${CMAKE_SOURCE_DIR}/data/filtered_simplicial_complex/bunny_5000_complex.fsc" "-p" "3" "-m" "100")
-
- install(TARGETS plain_homology DESTINATION bin)
- install(TARGETS persistence_from_simple_simplex_tree DESTINATION bin)
-diff --git a/example/Simplex_tree/CMakeLists.txt b/example/Simplex_tree/CMakeLists.txt
-index 857e851..48bb069 100644
---- a/example/Simplex_tree/CMakeLists.txt
-+++ b/example/Simplex_tree/CMakeLists.txt
-@@ -29,8 +29,6 @@ if(GMP_FOUND AND CGAL_FOUND)
- if (TBB_FOUND)
- target_link_libraries(Simplex_tree_example_alpha_shapes_3_from_off ${TBB_LIBRARIES})
- endif()
-- add_test(NAME Simplex_tree_example_alpha_shapes_3_from_off COMMAND $<TARGET_FILE:Simplex_tree_example_alpha_shapes_3_from_off>
-- "${CMAKE_SOURCE_DIR}/data/points/bunny_5000.off")
-
- install(TARGETS Simplex_tree_example_alpha_shapes_3_from_off DESTINATION bin)
-
-diff --git a/utilities/Nerve_GIC/CMakeLists.txt b/utilities/Nerve_GIC/CMakeLists.txt
-index 215f9df..20aeb8e 100644
---- a/utilities/Nerve_GIC/CMakeLists.txt
-+++ b/utilities/Nerve_GIC/CMakeLists.txt
-@@ -11,14 +11,6 @@ if (NOT CGAL_VERSION VERSION_LESS 4.8.1)
- endif()
-
- file(COPY KeplerMapperVisuFromTxtFile.py km.py DESTINATION ${CMAKE_CURRENT_BINARY_DIR}/)
-- # Copy files for not to pollute sources when testing
-- file(COPY "${CMAKE_SOURCE_DIR}/data/points/human.off" DESTINATION ${CMAKE_CURRENT_BINARY_DIR}/)
--
-- add_test(NAME Nerve_GIC_utilities_nerve COMMAND $<TARGET_FILE:Nerve>
-- "human.off" "2" "10" "0.3")
--
-- add_test(NAME Nerve_GIC_utilities_VoronoiGIC COMMAND $<TARGET_FILE:VoronoiGIC>
-- "human.off" "100")
-
- install(TARGETS Nerve DESTINATION bin)
- install(TARGETS VoronoiGIC DESTINATION bin)
diff --git a/debian/patches/0003-Use-system-MathJax.patch b/debian/patches/0003-Use-system-MathJax.patch
deleted file mode 100644
index 4791b5d9..00000000
--- a/debian/patches/0003-Use-system-MathJax.patch
+++ /dev/null
@@ -1,21 +0,0 @@
-From: Gard Spreemann <gspreemann@gmail.com>
-Date: Mon, 10 Sep 2018 05:18:37 +0200
-Subject: Use system MathJax.
-
----
- Doxyfile | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/Doxyfile b/Doxyfile
-index a16431a..fb67087 100644
---- a/Doxyfile
-+++ b/Doxyfile
-@@ -1456,7 +1456,7 @@ MATHJAX_FORMAT = HTML-CSS
- # The default value is: http://cdn.mathjax.org/mathjax/latest.
- # This tag requires that the tag USE_MATHJAX is set to YES.
-
--MATHJAX_RELPATH = ../common
-+MATHJAX_RELPATH = /usr/share/javascript/mathjax
-
- # The MATHJAX_EXTENSIONS tag can be used to specify one or more MathJax
- # extension names that should be enabled during MathJax rendering. For example
diff --git a/debian/patches/0004-Don-t-set-runtime-library-dirs-for-Python-extensions.patch b/debian/patches/0004-Don-t-set-runtime-library-dirs-for-Python-extensions.patch
deleted file mode 100644
index b2b8c39c..00000000
--- a/debian/patches/0004-Don-t-set-runtime-library-dirs-for-Python-extensions.patch
+++ /dev/null
@@ -1,21 +0,0 @@
-From: Gard Spreemann <gspreemann@gmail.com>
-Date: Mon, 10 Sep 2018 05:19:07 +0200
-Subject: Don't set runtime library dirs for Python extensions.
-
----
- cython/setup.py.in | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/cython/setup.py.in b/cython/setup.py.in
-index 4037aab..b0141aa 100644
---- a/cython/setup.py.in
-+++ b/cython/setup.py.in
-@@ -36,7 +36,7 @@ gudhi = Extension(
- libraries=[@GUDHI_CYTHON_LIBRARIES@],
- library_dirs=[@GUDHI_CYTHON_LIBRARY_DIRS@],
- include_dirs = [@GUDHI_CYTHON_INCLUDE_DIRS@],
-- runtime_library_dirs=[@GUDHI_CYTHON_RUNTIME_LIBRARY_DIRS@],
-+ runtime_library_dirs=[],
- )
-
- setup(
diff --git a/debian/patches/0005-Force-linking-of-Python-module-with-CGAL.patch b/debian/patches/0005-Force-linking-of-Python-module-with-CGAL.patch
deleted file mode 100644
index d8ca0255..00000000
--- a/debian/patches/0005-Force-linking-of-Python-module-with-CGAL.patch
+++ /dev/null
@@ -1,21 +0,0 @@
-From: Gard Spreemann <gspreemann@gmail.com>
-Date: Mon, 10 Sep 2018 05:20:33 +0200
-Subject: Force linking of Python module with CGAL.
-
----
- cython/CMakeLists.txt | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/cython/CMakeLists.txt b/cython/CMakeLists.txt
-index 219b99e..7b8e38f 100644
---- a/cython/CMakeLists.txt
-+++ b/cython/CMakeLists.txt
-@@ -143,7 +143,7 @@ if(CYTHON_FOUND)
- set(GUDHI_CYTHON_EXTRA_COMPILE_ARGS "${GUDHI_CYTHON_EXTRA_COMPILE_ARGS}'-DCGAL_HEADER_ONLY', ")
- else(CGAL_HEADER_ONLY)
- add_gudhi_debug_info("CGAL version ${CGAL_VERSION}")
-- add_gudhi_cython_lib("${CGAL_LIBRARY}")
-+ add_gudhi_cython_lib("${CGAL_LIBRARIES_DIR}/libCGAL.so")
- set(GUDHI_CYTHON_LIBRARY_DIRS "${GUDHI_CYTHON_LIBRARY_DIRS}'${CGAL_LIBRARIES_DIR}', ")
- # If CGAL is not header only, CGAL library may link with boost system,
- if(CMAKE_BUILD_TYPE MATCHES Debug)
diff --git a/debian/patches/0006-Force-linking-against-libatomic-for-parts-that-use-T.patch b/debian/patches/0006-Force-linking-against-libatomic-for-parts-that-use-T.patch
deleted file mode 100644
index b38232c8..00000000
--- a/debian/patches/0006-Force-linking-against-libatomic-for-parts-that-use-T.patch
+++ /dev/null
@@ -1,21 +0,0 @@
-From: Gard Spreemann <gspreemann@gmail.com>
-Date: Mon, 10 Sep 2018 05:20:57 +0200
-Subject: Force linking against libatomic for parts that use TBB.
-
----
- cmake/modules/FindTBB.cmake | 2 ++
- 1 file changed, 2 insertions(+)
-
-diff --git a/cmake/modules/FindTBB.cmake b/cmake/modules/FindTBB.cmake
-index 13f4d92..6baa8d7 100644
---- a/cmake/modules/FindTBB.cmake
-+++ b/cmake/modules/FindTBB.cmake
-@@ -375,6 +375,8 @@ if (TBB_INCLUDE_DIR)
- endif(NOT TBB_without_pthread)
- endif(UNIX AND NOT APPLE)
-
-+ list(APPEND ALL_TBB_LIBRARIES atomic)
-+
- set (TBB_LIBRARIES ${ALL_TBB_LIBRARIES}
- CACHE PATH "TBB libraries" FORCE)
-
diff --git a/debian/patches/0007-Offline-header-for-docs.patch b/debian/patches/0007-Offline-header-for-docs.patch
deleted file mode 100644
index 536227ad..00000000
--- a/debian/patches/0007-Offline-header-for-docs.patch
+++ /dev/null
@@ -1,21 +0,0 @@
-From: Gard Spreemann <gspreemann@gmail.com>
-Date: Mon, 10 Sep 2018 05:22:06 +0200
-Subject: Offline header for docs.
-
----
- Doxyfile | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/Doxyfile b/Doxyfile
-index fb67087..a341cc6 100644
---- a/Doxyfile
-+++ b/Doxyfile
-@@ -1061,7 +1061,7 @@ HTML_FILE_EXTENSION = .html
- # of the possible markers and block names see the documentation.
- # This tag requires that the tag GENERATE_HTML is set to YES.
-
--HTML_HEADER = doc/common/header.html
-+HTML_HEADER = doc/common/offline_header.html
-
- # The HTML_FOOTER tag can be used to specify a user-defined HTML footer for each
- # generated HTML page. If the tag is left blank doxygen will generate a standard
diff --git a/debian/patches/0008-Propagate-CXXFLAGS-when-building-Python-modules.patch b/debian/patches/0008-Propagate-CXXFLAGS-when-building-Python-modules.patch
deleted file mode 100644
index 03d4f63d..00000000
--- a/debian/patches/0008-Propagate-CXXFLAGS-when-building-Python-modules.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-From: Gard Spreemann <gspreemann@gmail.com>
-Date: Fri, 5 Oct 2018 11:15:26 +0200
-Subject: Propagate CXXFLAGS when building Python modules.
-
----
- cython/CMakeLists.txt | 5 +++++
- 1 file changed, 5 insertions(+)
-
-diff --git a/cython/CMakeLists.txt b/cython/CMakeLists.txt
-index 7b8e38f..6fdf343 100644
---- a/cython/CMakeLists.txt
-+++ b/cython/CMakeLists.txt
-@@ -199,6 +199,11 @@ if(CYTHON_FOUND)
- set( GUDHI_CYTHON_RUNTIME_LIBRARY_DIRS "${GUDHI_CYTHON_LIBRARY_DIRS}")
- endif(UNIX)
-
-+ string(REPLACE " " ";" TMP_FLAGS ${CMAKE_CXX_FLAGS})
-+ foreach(FLAG ${TMP_FLAGS})
-+ set(GUDHI_CYTHON_EXTRA_COMPILE_ARGS "${GUDHI_CYTHON_EXTRA_COMPILE_ARGS}'${FLAG}', ")
-+ endforeach()
-+
- # Generate setup.py file to cythonize Gudhi - This file must be named setup.py by convention
- configure_file(setup.py.in "${CMAKE_CURRENT_BINARY_DIR}/setup.py" @ONLY)
- # Generate gudhi.pyx - Gudhi cython file
diff --git a/debian/patches/series b/debian/patches/series
deleted file mode 100644
index 5f9ad2de..00000000
--- a/debian/patches/series
+++ /dev/null
@@ -1,8 +0,0 @@
-0001-Disable-Sphinx-test-since-we-re-not-currently-buildi.patch
-0002-Disable-tests-that-use-DFSG-deleted-data-files.patch
-0003-Use-system-MathJax.patch
-0004-Don-t-set-runtime-library-dirs-for-Python-extensions.patch
-0005-Force-linking-of-Python-module-with-CGAL.patch
-0006-Force-linking-against-libatomic-for-parts-that-use-T.patch
-0007-Offline-header-for-docs.patch
-0008-Propagate-CXXFLAGS-when-building-Python-modules.patch