summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorGard Spreemann <gspr@nonempty.org>2019-10-23 13:28:08 +0200
committerGard Spreemann <gspr@nonempty.org>2019-10-23 13:53:47 +0200
commit56c9dff589e2d7f96e648e7434c79d9c5349c314 (patch)
treebfd149285beb4584e2e21f4974c244a8d4e5cc58 /debian
parentbc9b55f6595c6406c4188fec126782bc1e083912 (diff)
Don't install byte-compiled Python files, have dh_python3 generate instead.
Diffstat (limited to 'debian')
-rwxr-xr-xdebian/rules7
1 files changed, 5 insertions, 2 deletions
diff --git a/debian/rules b/debian/rules
index dba306ef..3a28c2ca 100755
--- a/debian/rules
+++ b/debian/rules
@@ -23,9 +23,9 @@ endif
%:
# The --buildirectory=build is there so that we can easily get a hold
# of documentation and examples, which are not installed by upstream.
- dh $@ $(DHFLAGS) --builddirectory=build
+ dh $@ $(DHFLAGS) --with=python3 --builddirectory=build
for py3ver in $(REMAINING_PY3VERS) ; do \
- dh $@ $(DHFLAGS) --builddirectory=build$$py3ver ; \
+ dh $@ $(DHFLAGS) --with=python3 --builddirectory=build$$py3ver ; \
done
override_dh_auto_configure:
@@ -99,3 +99,6 @@ override_dh_auto_install:
override_dh_compress:
dh_compress -X.cpp
+
+override_dh_install:
+ dh_install -X__pycache__ -X.pyc -X.pyo