summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorGard Spreemann <gspr@nonempty.org>2022-08-19 11:37:38 +0200
committerGard Spreemann <gspr@nonempty.org>2022-08-19 11:37:38 +0200
commitdafd2c5ceb376eb359d20be03b51efc28a0b95cf (patch)
tree2c63e83ef20169467fc2da848976b0450f282e32 /debian
parent65b186afa2f71f3de4309346ee094b5ecae14880 (diff)
Disable inappropriate autopkgtests
One requires Internet access, another TF.
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog1
-rw-r--r--debian/tests/upstream.py6
2 files changed, 5 insertions, 2 deletions
diff --git a/debian/changelog b/debian/changelog
index 389b2f22..54f4a66e 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -8,6 +8,7 @@ gudhi (3.6.0+dfsg-1) unstable; urgency=medium
intended upstream.
- Drop doxygen patch now that we build correctly.
* Clean up documentation installation.
+ * Autopkgtests: Disable new inappropriate tests.
-- Gard Spreemann <gspr@nonempty.org> Wed, 17 Aug 2022 21:47:20 +0200
diff --git a/debian/tests/upstream.py b/debian/tests/upstream.py
index 63a35e0b..defa2da5 100644
--- a/debian/tests/upstream.py
+++ b/debian/tests/upstream.py
@@ -4,13 +4,15 @@ import pytest
blacklist = ["test_knn.py", # Requires pykeops
"test_representations.py", # Look into this
- "test_wasserstein_distance.py::test_wasserstein_distance_grad" # Requires PyTorch.
+ "test_wasserstein_distance.py::test_wasserstein_distance_grad", # Requires PyTorch.
+ "test_remote_datasets.py" # Requires Internet access, and downloads DFSG-dubious data.
]
print("Blacklist: %s" %(str(blacklist)))
# These should be completely ignored, not even loaded (their imports fail).
-ignorelist = ["test_dtm.py", # Requires hnswlib.
+ignorelist = ["test_diff.py", # Requires TF.
+ "test_dtm.py", # Requires hnswlib.
"test_wasserstein_with_tensors.py" # Requires PyTorch and TF
]