summaryrefslogtreecommitdiff
path: root/example/Witness_complex/CMakeLists.txt
diff options
context:
space:
mode:
authorGard Spreemann <gspr@nonempty.org>2019-09-25 14:29:41 +0200
committerGard Spreemann <gspr@nonempty.org>2019-09-25 14:29:41 +0200
commit599d68cd916f533bdb66dd9e684dd5703233b6bb (patch)
tree4b825dc642cb6eb9a060e54bf8d69288fbee4904 /example/Witness_complex/CMakeLists.txt
parenta2e642954ae39025e041471d486ecbac25dff440 (diff)
Delete all files in order to incorporate upstream's move to git.
Diffstat (limited to 'example/Witness_complex/CMakeLists.txt')
-rw-r--r--example/Witness_complex/CMakeLists.txt34
1 files changed, 0 insertions, 34 deletions
diff --git a/example/Witness_complex/CMakeLists.txt b/example/Witness_complex/CMakeLists.txt
deleted file mode 100644
index 3d838c0d..00000000
--- a/example/Witness_complex/CMakeLists.txt
+++ /dev/null
@@ -1,34 +0,0 @@
-project(Witness_complex_examples)
-
-add_executable ( Witness_complex_example_nearest_landmark_table example_nearest_landmark_table.cpp )
-if (TBB_FOUND)
- target_link_libraries(Witness_complex_example_nearest_landmark_table ${TBB_LIBRARIES})
-endif()
-add_test(NAME Witness_complex_example_nearest_landmark_table
- COMMAND $<TARGET_FILE:Witness_complex_example_nearest_landmark_table>)
-
-install(TARGETS Witness_complex_example_nearest_landmark_table DESTINATION bin)
-
-# CGAL and Eigen3 are required for Euclidean version of Witness
-if (NOT CGAL_WITH_EIGEN3_VERSION VERSION_LESS 4.6.0)
- add_executable( Witness_complex_example_off example_witness_complex_off.cpp )
- add_executable ( Witness_complex_example_sphere example_witness_complex_sphere.cpp )
-
- add_executable( Witness_complex_example_strong_off example_strong_witness_complex_off.cpp )
- target_link_libraries(Witness_complex_example_strong_off)
-
- add_test(NAME Witness_complex_example_off_test_torus
- COMMAND $<TARGET_FILE:Witness_complex_example_off>
- "${CMAKE_SOURCE_DIR}/data/points/tore3D_1307.off" "20" "1.0" "3")
- add_test(NAME Witness_complex_example_test_sphere_10
- COMMAND $<TARGET_FILE:Witness_complex_example_sphere> "10")
- add_test(NAME Witness_complex_example_strong_off_test_torus
- COMMAND $<TARGET_FILE:Witness_complex_example_strong_off>
- "${CMAKE_SOURCE_DIR}/data/points/tore3D_1307.off" "20" "1.0" "3")
-
- install(TARGETS Witness_complex_example_off DESTINATION bin)
- install(TARGETS Witness_complex_example_sphere DESTINATION bin)
- install(TARGETS Witness_complex_example_strong_off DESTINATION bin)
-
-
-endif (NOT CGAL_WITH_EIGEN3_VERSION VERSION_LESS 4.6.0)