summaryrefslogtreecommitdiff
path: root/scripts
diff options
context:
space:
mode:
authorvrouvrea <vrouvrea@636b058d-ea47-450e-bf9e-a15bfbe3eedb>2014-12-15 16:56:31 +0000
committervrouvrea <vrouvrea@636b058d-ea47-450e-bf9e-a15bfbe3eedb>2014-12-15 16:56:31 +0000
commit8e83a86b147987cc256812aff78335ac8a26c36e (patch)
tree1a00edc509e882a68dc78feea1e7222b672d8519 /scripts
parentbc09913a3a69da8cc3cbeb3eb796f166ef1025e2 (diff)
CMakeLists.txt uniformization. check_google_style bug fix. generate_version copy Doxyfile
git-svn-id: svn+ssh://scm.gforge.inria.fr/svnroot/gudhi/branches/cpplint_test@352 636b058d-ea47-450e-bf9e-a15bfbe3eedb Former-commit-id: a64f89b97ff3acbcf562070cc59b6065013d4aa1
Diffstat (limited to 'scripts')
-rwxr-xr-xscripts/check_google_style.sh3
-rw-r--r--scripts/generate_version.sh1
2 files changed, 3 insertions, 1 deletions
diff --git a/scripts/check_google_style.sh b/scripts/check_google_style.sh
index fc659346..9ed5cad0 100755
--- a/scripts/check_google_style.sh
+++ b/scripts/check_google_style.sh
@@ -4,6 +4,7 @@
# VERSION CHECK
ROOT_DIR=..
FILE_TO_CHECK="$1"
+PYTHON_SCRIPT="$2"
LOG_FILE=$FILE_TO_CHECK.cpplint
if [ -f $LOG_FILE ]; then
@@ -17,7 +18,7 @@ fi
# CPPLINT FILE
echo "File: $FILE_TO_CHECK" 2>&1 | tee -a $LOG_FILE
-python ~/cpplint.py --linelength=120 $FILE_TO_CHECK 2>&1 | tee -a $LOG_FILE
+python $PYTHON_SCRIPT --linelength=120 $FILE_TO_CHECK 2>&1 | tee -a $LOG_FILE
LINE_ERRORS=`grep "Total errors found:" $LOG_FILE`
NB_ERRORS=${LINE_ERRORS:20}
diff --git a/scripts/generate_version.sh b/scripts/generate_version.sh
index 4b5d08f4..1a8ce4ab 100644
--- a/scripts/generate_version.sh
+++ b/scripts/generate_version.sh
@@ -47,6 +47,7 @@ cp $ROOT_DIR/Conventions.txt $VERSION_DIR
cp $ROOT_DIR/COPYING $VERSION_DIR
cp -R $ROOT_DIR/data $VERSION_DIR
cp $ROOT_DIR/src/CMakeLists.txt $VERSION_DIR
+cp $ROOT_DIR/src/Doxyfile $VERSION_DIR
# PACKAGE LEVEL COPY
PACKAGE_INC_DIR="/include"