summaryrefslogtreecommitdiff
path: root/src/Alpha_complex/example/CMakeLists.txt
diff options
context:
space:
mode:
authorcjamin <cjamin@636b058d-ea47-450e-bf9e-a15bfbe3eedb>2016-06-10 10:44:32 +0000
committercjamin <cjamin@636b058d-ea47-450e-bf9e-a15bfbe3eedb>2016-06-10 10:44:32 +0000
commitb91a2880abed328aeb45cbf957d5198a20d8ef35 (patch)
tree96e2c252c63d6b467c187d3d5f84dd85668ac398 /src/Alpha_complex/example/CMakeLists.txt
parentdc7e8e3267dcabe24c56af9377baa1466eec6fc3 (diff)
Use TBB_LIBRARIES instead of TBB_RELEASE_LIBRARY + missing boost dependency
git-svn-id: svn+ssh://scm.gforge.inria.fr/svnroot/gudhi/trunk@1269 636b058d-ea47-450e-bf9e-a15bfbe3eedb Former-commit-id: d39ecf562678c53f960467e7cb14eeaff4b938c4
Diffstat (limited to 'src/Alpha_complex/example/CMakeLists.txt')
-rw-r--r--src/Alpha_complex/example/CMakeLists.txt8
1 files changed, 4 insertions, 4 deletions
diff --git a/src/Alpha_complex/example/CMakeLists.txt b/src/Alpha_complex/example/CMakeLists.txt
index f1346867..c1439f70 100644
--- a/src/Alpha_complex/example/CMakeLists.txt
+++ b/src/Alpha_complex/example/CMakeLists.txt
@@ -13,12 +13,12 @@ if(CGAL_FOUND)
include( ${EIGEN3_USE_FILE} )
add_executable ( alphapoints Alpha_complex_from_points.cpp )
- target_link_libraries(alphapoints ${Boost_SYSTEM_LIBRARY} ${CGAL_LIBRARY})
+ target_link_libraries(alphapoints ${Boost_SYSTEM_LIBRARY} ${Boost_THREAD_LIBRARY} ${CGAL_LIBRARY})
add_executable ( alphaoffreader Alpha_complex_from_off.cpp )
- target_link_libraries(alphaoffreader ${Boost_SYSTEM_LIBRARY} ${CGAL_LIBRARY})
+ target_link_libraries(alphaoffreader ${Boost_SYSTEM_LIBRARY} ${Boost_THREAD_LIBRARY} ${CGAL_LIBRARY})
if (TBB_FOUND)
- target_link_libraries(alphapoints ${TBB_RELEASE_LIBRARY})
- target_link_libraries(alphaoffreader ${TBB_RELEASE_LIBRARY})
+ target_link_libraries(alphapoints ${TBB_LIBRARIES})
+ target_link_libraries(alphaoffreader ${TBB_LIBRARIES})
endif()
add_test(alphapoints ${CMAKE_CURRENT_BINARY_DIR}/alphapoints)