summaryrefslogtreecommitdiff
path: root/src/Alpha_complex/example/CMakeLists.txt
diff options
context:
space:
mode:
authorvrouvrea <vrouvrea@636b058d-ea47-450e-bf9e-a15bfbe3eedb>2018-08-28 21:11:26 +0000
committervrouvrea <vrouvrea@636b058d-ea47-450e-bf9e-a15bfbe3eedb>2018-08-28 21:11:26 +0000
commitef84bab542eb07d83515293652841969dd462b1c (patch)
treeb250a609623f919fd4f8730976b065bdacf1ef96 /src/Alpha_complex/example/CMakeLists.txt
parent1b65f580392d33ac3d8516acced98de6906e6ed6 (diff)
Make fast/safe/exact, weighted/non-weighted, periodic/non-periodic more orthogonal choices
Only examples work for the moment. Periodic to be tested. Add Alpha_complex_3d_from_points.cpp example. Maybe to be removed. git-svn-id: svn+ssh://scm.gforge.inria.fr/svnroot/gudhi/branches/alpha_complex_3d_module_vincent@3840 636b058d-ea47-450e-bf9e-a15bfbe3eedb Former-commit-id: f5621df603bdb149c52400a6095271ea0f54b84c
Diffstat (limited to 'src/Alpha_complex/example/CMakeLists.txt')
-rw-r--r--src/Alpha_complex/example/CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/src/Alpha_complex/example/CMakeLists.txt b/src/Alpha_complex/example/CMakeLists.txt
index 4a1cd26d..1f127972 100644
--- a/src/Alpha_complex/example/CMakeLists.txt
+++ b/src/Alpha_complex/example/CMakeLists.txt
@@ -39,5 +39,13 @@ if(CGAL_FOUND)
add_test(NAME Alpha_complex_example_weighted_3d_from_points
COMMAND $<TARGET_FILE:Alpha_complex_example_weighted_3d_from_points>)
+ add_executable ( Alpha_complex_example_3d_from_points Alpha_complex_3d_from_points.cpp )
+ target_link_libraries(Alpha_complex_example_3d_from_points ${CGAL_LIBRARY})
+ if (TBB_FOUND)
+ target_link_libraries(Alpha_complex_example_3d_from_points ${TBB_LIBRARIES})
+ endif()
+ add_test(NAME Alpha_complex_example_3d_from_points
+ COMMAND $<TARGET_FILE:Alpha_complex_example_3d_from_points>)
+
endif(NOT CGAL_WITH_EIGEN3_VERSION VERSION_LESS 4.11.0)
endif() \ No newline at end of file