summaryrefslogtreecommitdiff
path: root/src/Alpha_complex/example
diff options
context:
space:
mode:
authorROUVREAU Vincent <vincent.rouvreau@inria.fr>2020-09-11 11:55:55 +0200
committerROUVREAU Vincent <vincent.rouvreau@inria.fr>2020-09-11 11:55:55 +0200
commit171ddab9b7a50f0303d7201fa547dbfb445f9698 (patch)
treee8464dd61a45c9c6a84b929e3eb00692f186d6b2 /src/Alpha_complex/example
parent9922407fe6f5d8872522157555c3573e95930ac3 (diff)
Requires CGAL >= 5.1. Fix is_gabriel computation
Diffstat (limited to 'src/Alpha_complex/example')
-rw-r--r--src/Alpha_complex/example/CMakeLists.txt14
-rw-r--r--src/Alpha_complex/example/Weighted_alpha_complex_from_points.cpp14
2 files changed, 16 insertions, 12 deletions
diff --git a/src/Alpha_complex/example/CMakeLists.txt b/src/Alpha_complex/example/CMakeLists.txt
index 17dc896c..1fc2330a 100644
--- a/src/Alpha_complex/example/CMakeLists.txt
+++ b/src/Alpha_complex/example/CMakeLists.txt
@@ -7,13 +7,10 @@ if (NOT CGAL_WITH_EIGEN3_VERSION VERSION_LESS 4.11.0)
target_link_libraries(Alpha_complex_example_from_off ${CGAL_LIBRARY})
add_executable ( Alpha_complex_example_fast_from_off Fast_alpha_complex_from_off.cpp )
target_link_libraries(Alpha_complex_example_fast_from_off ${CGAL_LIBRARY})
- add_executable ( Weighted_alpha_complex_example_from_points Weighted_alpha_complex_from_points.cpp )
- target_link_libraries(Weighted_alpha_complex_example_from_points ${CGAL_LIBRARY})
if (TBB_FOUND)
target_link_libraries(Alpha_complex_example_from_points ${TBB_LIBRARIES})
target_link_libraries(Alpha_complex_example_from_off ${TBB_LIBRARIES})
target_link_libraries(Alpha_complex_example_fast_from_off ${TBB_LIBRARIES})
- target_link_libraries(Weighted_alpha_complex_example_from_points ${TBB_LIBRARIES})
endif()
add_test(NAME Alpha_complex_example_from_points COMMAND $<TARGET_FILE:Alpha_complex_example_from_points>)
@@ -28,8 +25,6 @@ if (NOT CGAL_WITH_EIGEN3_VERSION VERSION_LESS 4.11.0)
add_test(NAME Alpha_complex_example_fast_from_off_32 COMMAND $<TARGET_FILE:Alpha_complex_example_fast_from_off>
"${CMAKE_SOURCE_DIR}/data/points/alphacomplexdoc.off" "32.0" "${CMAKE_CURRENT_BINARY_DIR}/fastalphaoffreader_result_32.txt")
- add_test(NAME Weighted_alpha_complex_example_from_points COMMAND $<TARGET_FILE:Weighted_alpha_complex_example_from_points>)
-
if (DIFF_PATH)
# Do not forget to copy test results files in current binary dir
file(COPY "alphaoffreader_for_doc_32.txt" DESTINATION ${CMAKE_CURRENT_BINARY_DIR}/)
@@ -69,3 +64,12 @@ if (NOT CGAL_VERSION VERSION_LESS 4.11.0)
COMMAND $<TARGET_FILE:Alpha_complex_example_3d_from_points>)
endif(NOT CGAL_VERSION VERSION_LESS 4.11.0)
+
+if (NOT CGAL_WITH_EIGEN3_VERSION VERSION_LESS 5.1.0)
+ add_executable ( Weighted_alpha_complex_example_from_points Weighted_alpha_complex_from_points.cpp )
+ target_link_libraries(Weighted_alpha_complex_example_from_points ${CGAL_LIBRARY})
+ if (TBB_FOUND)
+ target_link_libraries(Weighted_alpha_complex_example_from_points ${TBB_LIBRARIES})
+ endif()
+ add_test(NAME Weighted_alpha_complex_example_from_points COMMAND $<TARGET_FILE:Weighted_alpha_complex_example_from_points>)
+endif(NOT CGAL_WITH_EIGEN3_VERSION VERSION_LESS 5.1.0)
diff --git a/src/Alpha_complex/example/Weighted_alpha_complex_from_points.cpp b/src/Alpha_complex/example/Weighted_alpha_complex_from_points.cpp
index 05858084..19a04282 100644
--- a/src/Alpha_complex/example/Weighted_alpha_complex_from_points.cpp
+++ b/src/Alpha_complex/example/Weighted_alpha_complex_from_points.cpp
@@ -18,13 +18,13 @@ int main() {
// Init of a list of points
// ----------------------------------------------------------------------------
Vector_of_points points;
- points.push_back(Weighted_point(Bare_point(1.0, 1.0) , 0.));
- points.push_back(Weighted_point(Bare_point(7.0, 0.0) , 0.));
- points.push_back(Weighted_point(Bare_point(4.0, 6.0) , 0.));
- points.push_back(Weighted_point(Bare_point(9.0, 6.0) , 0.));
- points.push_back(Weighted_point(Bare_point(0.0, 14.0), 0.));
- points.push_back(Weighted_point(Bare_point(2.0, 19.0), 0.));
- points.push_back(Weighted_point(Bare_point(9.0, 17.0), 0.));
+ points.push_back(Weighted_point(Bare_point(1.0, 1.0) , 1.));
+ points.push_back(Weighted_point(Bare_point(7.0, 0.0) , 1.));
+ points.push_back(Weighted_point(Bare_point(4.0, 6.0) , 1.));
+ points.push_back(Weighted_point(Bare_point(9.0, 6.0) , 1.));
+ points.push_back(Weighted_point(Bare_point(0.0, 14.0), 1.));
+ points.push_back(Weighted_point(Bare_point(2.0, 19.0), 1.));
+ points.push_back(Weighted_point(Bare_point(9.0, 17.0), 1.));
// ----------------------------------------------------------------------------
// Init of an alpha complex from the list of points