summaryrefslogtreecommitdiff
path: root/src/Alpha_complex/test/CMakeLists.txt
diff options
context:
space:
mode:
authorROUVREAU Vincent <vincent.rouvreau@inria.fr>2020-09-04 17:26:33 +0200
committerROUVREAU Vincent <vincent.rouvreau@inria.fr>2020-09-04 17:26:33 +0200
commitda3debd6896830592bc305bc688431d09539014e (patch)
tree9f0317930aef92a82c33f83d9a00958e6ab0aa98 /src/Alpha_complex/test/CMakeLists.txt
parentdb938dbd74460e7a0fd705be8628984052f71dc0 (diff)
parent6e14ef1f31e09f3875316440303450ff870d9881 (diff)
Merge branch 'master' of https://github.com/GUDHI/gudhi-devel into weighted_alpha_complex_dD
Diffstat (limited to 'src/Alpha_complex/test/CMakeLists.txt')
-rw-r--r--src/Alpha_complex/test/CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/src/Alpha_complex/test/CMakeLists.txt b/src/Alpha_complex/test/CMakeLists.txt
index bd61c0d8..71e4ea7c 100644
--- a/src/Alpha_complex/test/CMakeLists.txt
+++ b/src/Alpha_complex/test/CMakeLists.txt
@@ -22,6 +22,10 @@ if (NOT CGAL_WITH_EIGEN3_VERSION VERSION_LESS 4.11.0)
gudhi_add_boost_test(Delaunay_complex_test_unit)
gudhi_add_boost_test(Alpha_kernel_d_test_unit)
+endif (NOT CGAL_WITH_EIGEN3_VERSION VERSION_LESS 4.11.0)
+
+if (NOT CGAL_VERSION VERSION_LESS 4.11.0)
+
add_executable ( Alpha_complex_3d_test_unit Alpha_complex_3d_unit_test.cpp )
target_link_libraries(Alpha_complex_3d_test_unit ${CGAL_LIBRARY})
add_executable ( Weighted_alpha_complex_3d_test_unit Weighted_alpha_complex_3d_unit_test.cpp )
@@ -42,4 +46,4 @@ if (NOT CGAL_WITH_EIGEN3_VERSION VERSION_LESS 4.11.0)
gudhi_add_boost_test(Periodic_alpha_complex_3d_test_unit)
gudhi_add_boost_test(Weighted_periodic_alpha_complex_3d_test_unit)
-endif (NOT CGAL_WITH_EIGEN3_VERSION VERSION_LESS 4.11.0)
+endif (NOT CGAL_VERSION VERSION_LESS 4.11.0)