summaryrefslogtreecommitdiff
path: root/src/Alpha_complex/test
diff options
context:
space:
mode:
authorvrouvrea <vrouvrea@636b058d-ea47-450e-bf9e-a15bfbe3eedb>2015-06-19 11:08:21 +0000
committervrouvrea <vrouvrea@636b058d-ea47-450e-bf9e-a15bfbe3eedb>2015-06-19 11:08:21 +0000
commitea986c68192c7536716d139e5a5f0a30a76f0fc1 (patch)
tree95e5d64f5d615709be39c4e57dc7cb3dc87fc650 /src/Alpha_complex/test
parent5ade372f809008bf41410455836d07c5efb6bdb9 (diff)
Alpha complex documetation - 1st part
git-svn-id: svn+ssh://scm.gforge.inria.fr/svnroot/gudhi/branches/alphashapes@630 636b058d-ea47-450e-bf9e-a15bfbe3eedb Former-commit-id: b64e860b0fb6d60e706784605f699349ea17a869
Diffstat (limited to 'src/Alpha_complex/test')
-rw-r--r--src/Alpha_complex/test/CMakeLists.txt8
-rw-r--r--src/Alpha_complex/test/alphaoffreader_for_doc.txt27
2 files changed, 32 insertions, 3 deletions
diff --git a/src/Alpha_complex/test/CMakeLists.txt b/src/Alpha_complex/test/CMakeLists.txt
index 0bd55433..79300790 100644
--- a/src/Alpha_complex/test/CMakeLists.txt
+++ b/src/Alpha_complex/test/CMakeLists.txt
@@ -16,9 +16,11 @@ if(CGAL_FOUND)
include_directories (BEFORE "../../include")
#add_definitions(-DDEBUG_TRACES)
- add_executable ( AlphaComplexUnitTest Alpha_complex_unit_test.cpp )
- target_link_libraries(AlphaComplexUnitTest ${Boost_SYSTEM_LIBRARY} ${CGAL_LIBRARY} ${Boost_UNIT_TEST_FRAMEWORK_LIBRARY})
- add_test(AlphaComplexUnitTest ${CMAKE_CURRENT_BINARY_DIR}/AlphaComplexUnitTest)
+ add_executable ( AlphaComplexUT Alpha_complex_unit_test.cpp )
+ target_link_libraries(AlphaComplexUT ${Boost_SYSTEM_LIBRARY} ${CGAL_LIBRARY} ${Boost_UNIT_TEST_FRAMEWORK_LIBRARY})
+ add_test(AlphaComplexUT ${CMAKE_CURRENT_BINARY_DIR}/AlphaComplexUT
+ # XML format for Jenkins xUnit plugin
+ --log_format=XML --log_sink=${CMAKE_SOURCE_DIR}/AlphaComplexUT.xml --log_level=test_suite --report_level=no)
else()
message(WARNING "Eigen3 not found. Version 3.1.0 is required for Alpha complex feature.")
diff --git a/src/Alpha_complex/test/alphaoffreader_for_doc.txt b/src/Alpha_complex/test/alphaoffreader_for_doc.txt
new file mode 100644
index 00000000..1153f097
--- /dev/null
+++ b/src/Alpha_complex/test/alphaoffreader_for_doc.txt
@@ -0,0 +1,27 @@
+Alpha complex is of dimension 2 - 25 simplices - 7 vertices.
+Iterator on alpha complex simplices in the filtration order, with [filtration value]:
+ ( 1 ) -> [0]
+ ( 2 ) -> [0]
+ ( 3 ) -> [0]
+ ( 4 ) -> [0]
+ ( 5 ) -> [0]
+ ( 6 ) -> [0]
+ ( 7 ) -> [0]
+ ( 4 3 ) -> [6.25]
+ ( 6 5 ) -> [7.25]
+ ( 3 1 ) -> [8.5]
+ ( 2 1 ) -> [9.25]
+ ( 4 2 ) -> [10]
+ ( 3 2 ) -> [11.25]
+ ( 4 3 2 ) -> [12.5]
+ ( 3 2 1 ) -> [12.9959]
+ ( 7 6 ) -> [13.25]
+ ( 5 3 ) -> [20]
+ ( 7 5 ) -> [22.7367]
+ ( 7 6 5 ) -> [22.7367]
+ ( 7 4 ) -> [30.25]
+ ( 7 3 ) -> [36.5]
+ ( 7 4 3 ) -> [36.5]
+ ( 7 5 3 ) -> [37.2449]
+ ( 5 1 ) -> [59.7107]
+ ( 5 3 1 ) -> [59.7107]