summaryrefslogtreecommitdiff
path: root/src/Alpha_complex/utilities/CMakeLists.txt
diff options
context:
space:
mode:
authorvrouvrea <vrouvrea@636b058d-ea47-450e-bf9e-a15bfbe3eedb>2018-06-22 08:30:53 +0000
committervrouvrea <vrouvrea@636b058d-ea47-450e-bf9e-a15bfbe3eedb>2018-06-22 08:30:53 +0000
commit138ee2657f03206209ff5c7d6c4392168beef819 (patch)
tree62f464875d12d48c2eb79a14def1dda8383849a7 /src/Alpha_complex/utilities/CMakeLists.txt
parent82f15e71f43a5547627699b625830126dad1c4ab (diff)
Use unique_ptr to store cgal alpha_shapes_3. Required for not objects_ to be freed.
git-svn-id: svn+ssh://scm.gforge.inria.fr/svnroot/gudhi/branches/alpha_complex_3d_module_vincent@3626 636b058d-ea47-450e-bf9e-a15bfbe3eedb Former-commit-id: 6dc9bbe25757a1a7bef2178ef63876c20d3a38b1
Diffstat (limited to 'src/Alpha_complex/utilities/CMakeLists.txt')
-rw-r--r--src/Alpha_complex/utilities/CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/src/Alpha_complex/utilities/CMakeLists.txt b/src/Alpha_complex/utilities/CMakeLists.txt
index 7ace6064..c4d986c4 100644
--- a/src/Alpha_complex/utilities/CMakeLists.txt
+++ b/src/Alpha_complex/utilities/CMakeLists.txt
@@ -8,10 +8,15 @@ if(CGAL_FOUND)
add_executable(weighted_alpha_complex_3d_persistence weighted_alpha_complex_3d_persistence.cpp)
target_link_libraries(weighted_alpha_complex_3d_persistence ${CGAL_LIBRARY} ${Boost_PROGRAM_OPTIONS_LIBRARY})
+ add_executable(old_alpha_complex_3d_persistence old_alpha_complex_3d_persistence.cpp)
+ target_link_libraries(old_alpha_complex_3d_persistence ${CGAL_LIBRARY} ${Boost_PROGRAM_OPTIONS_LIBRARY})
+
if (TBB_FOUND)
target_link_libraries(alpha_complex_3d_persistence ${TBB_LIBRARIES})
target_link_libraries(exact_alpha_complex_3d_persistence ${TBB_LIBRARIES})
target_link_libraries(weighted_alpha_complex_3d_persistence ${TBB_LIBRARIES})
+
+ target_link_libraries(old_alpha_complex_3d_persistence ${TBB_LIBRARIES})
endif(TBB_FOUND)
add_test(NAME Alpha_complex_utilities_alpha_complex_3d_persistence COMMAND $<TARGET_FILE:alpha_complex_3d_persistence>