summaryrefslogtreecommitdiff
path: root/src/Alpha_complex
diff options
context:
space:
mode:
authorvrouvrea <vrouvrea@636b058d-ea47-450e-bf9e-a15bfbe3eedb>2015-06-18 14:21:31 +0000
committervrouvrea <vrouvrea@636b058d-ea47-450e-bf9e-a15bfbe3eedb>2015-06-18 14:21:31 +0000
commit56e89b6b7666dec86a70f6a30f08ef8b7960eb21 (patch)
treea43dd7705fcf7435df726e5bc5123662abc8ea4d /src/Alpha_complex
parent77b57ae69fa2042b652d91d8015c1d9533176090 (diff)
Moved alphashapedoc.off in data/points
Moved Delaunay triangulation OFF files read and write in src/common Delaunay triangulation OFF files read and write documentation, examples and tests git-svn-id: svn+ssh://scm.gforge.inria.fr/svnroot/gudhi/branches/alphashapes@623 636b058d-ea47-450e-bf9e-a15bfbe3eedb Former-commit-id: e03902736a79436e97dbf77a88504f3faa8bd9c6
Diffstat (limited to 'src/Alpha_complex')
-rw-r--r--src/Alpha_complex/example/CMakeLists.txt9
-rw-r--r--src/Alpha_complex/example/Delaunay_triangulation_off_rw.cpp79
-rw-r--r--src/Alpha_complex/example/Simplex_tree_from_delaunay_triangulation.cpp27
-rwxr-xr-xsrc/Alpha_complex/example/alphashapedoc.off10
-rw-r--r--src/Alpha_complex/include/gudhi/Alpha_complex.h70
-rw-r--r--src/Alpha_complex/include/gudhi/Alpha_shapes/Delaunay_triangulation_off_io.h210
-rw-r--r--src/Alpha_complex/test/Alpha_complex_unit_test.cpp71
-rw-r--r--src/Alpha_complex/test/CMakeLists.txt2
-rw-r--r--src/Alpha_complex/test/README2
-rw-r--r--src/Alpha_complex/test/S4_100.off4
-rw-r--r--src/Alpha_complex/test/S8_10.off4
11 files changed, 74 insertions, 414 deletions
diff --git a/src/Alpha_complex/example/CMakeLists.txt b/src/Alpha_complex/example/CMakeLists.txt
index 258def49..9129fdcf 100644
--- a/src/Alpha_complex/example/CMakeLists.txt
+++ b/src/Alpha_complex/example/CMakeLists.txt
@@ -14,17 +14,10 @@ if(CGAL_FOUND)
message(STATUS "Eigen3 version: ${EIGEN3_VERSION}.")
include( ${EIGEN3_USE_FILE} )
- add_definitions(-DDEBUG_TRACES)
-
- add_executable ( dtoffrw Delaunay_triangulation_off_rw.cpp )
- target_link_libraries(dtoffrw ${Boost_SYSTEM_LIBRARY} ${CGAL_LIBRARY})
- add_test(dtoffrw_tore3D ${CMAKE_CURRENT_BINARY_DIR}/dtoffrw ${CMAKE_SOURCE_DIR}/data/points/tore3D_1307.off 3)
-
+ #add_definitions(-DDEBUG_TRACES)
add_executable ( stfromdt Simplex_tree_from_delaunay_triangulation.cpp )
target_link_libraries(stfromdt ${Boost_SYSTEM_LIBRARY} ${CGAL_LIBRARY})
- add_executable ( template_off template_off.cpp )
- target_link_libraries(template_off ${Boost_SYSTEM_LIBRARY} ${CGAL_LIBRARY})
else()
message(WARNING "Eigen3 not found. Version 3.1.0 is required for Alpha shapes feature.")
endif()
diff --git a/src/Alpha_complex/example/Delaunay_triangulation_off_rw.cpp b/src/Alpha_complex/example/Delaunay_triangulation_off_rw.cpp
deleted file mode 100644
index 405b3cb9..00000000
--- a/src/Alpha_complex/example/Delaunay_triangulation_off_rw.cpp
+++ /dev/null
@@ -1,79 +0,0 @@
-/* This file is part of the Gudhi Library. The Gudhi library
- * (Geometric Understanding in Higher Dimensions) is a generic C++
- * library for computational topology.
- *
- * Author(s): Vincent Rouvreau
- *
- * Copyright (C) 2014 INRIA Saclay (France)
- *
- * This program is free software: you can redistribute it and/or modify
- * it under the terms of the GNU General Public License as published by
- * the Free Software Foundation, either version 3 of the License, or
- * (at your option) any later version.
- *
- * This program is distributed in the hope that it will be useful,
- * but WITHOUT ANY WARRANTY; without even the implied warranty of
- * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
- * GNU General Public License for more details.
- *
- * You should have received a copy of the GNU General Public License
- * along with this program. If not, see <http://www.gnu.org/licenses/>.
- */
-
-// to construct a Delaunay_triangulation from a OFF file
-#include "gudhi/Alpha_shapes/Delaunay_triangulation_off_io.h"
-
-#include <CGAL/Delaunay_triangulation.h>
-#include <CGAL/Epick_d.h>
-#include <CGAL/point_generators_d.h>
-#include <CGAL/algorithm.h>
-#include <CGAL/assertions.h>
-
-#include <iostream>
-#include <iterator>
-#include <vector>
-
-#include <stdio.h>
-#include <stdlib.h>
-#include <string>
-
-// Use dynamic_dimension_tag for the user to be able to set dimension
-typedef CGAL::Epick_d< CGAL::Dynamic_dimension_tag > K;
-typedef CGAL::Delaunay_triangulation<K> T;
-// The triangulation uses the default instanciation of the
-// TriangulationDataStructure template parameter
-
-void usage(char * const progName) {
- std::cerr << "Usage: " << progName << " inputFile.off dimension outputFile.off" << std::endl;
- exit(-1); // ----- >>
-}
-
-int main(int argc, char **argv) {
- if (argc != 4) {
- std::cerr << "Error: Number of arguments (" << argc << ") is not correct" << std::endl;
- usage(argv[0]);
- }
-
- int dimension = 0;
- int returnedScanValue = sscanf(argv[2], "%d", &dimension);
- if ((returnedScanValue == EOF) || (dimension <= 0)) {
- std::cerr << "Error: " << argv[2] << " is not correct" << std::endl;
- usage(argv[0]);
- }
-
- T dt(dimension);
- std::string offFileName(argv[1]);
- Gudhi::alphacomplex::Delaunay_triangulation_off_reader<T> off_reader(offFileName, dt);
- if (!off_reader.is_valid()) {
- std::cerr << "Unable to read file " << offFileName << std::endl;
- exit(-1); // ----- >>
- }
-
- std::cout << "number_of_finite_full_cells= " << dt.number_of_finite_full_cells() << std::endl;
-
- std::string outFileName(argv[3]);
- std::string offOutputFile(outFileName);
- Gudhi::alphacomplex::Delaunay_triangulation_off_writer<T> off_writer(offOutputFile, dt);
-
- return 0;
-} \ No newline at end of file
diff --git a/src/Alpha_complex/example/Simplex_tree_from_delaunay_triangulation.cpp b/src/Alpha_complex/example/Simplex_tree_from_delaunay_triangulation.cpp
index f09e6121..1523372a 100644
--- a/src/Alpha_complex/example/Simplex_tree_from_delaunay_triangulation.cpp
+++ b/src/Alpha_complex/example/Simplex_tree_from_delaunay_triangulation.cpp
@@ -21,19 +21,13 @@
*/
// to construct a Delaunay_triangulation from a OFF file
-#include "gudhi/Alpha_shapes/Delaunay_triangulation_off_io.h"
+#include "gudhi/Delaunay_triangulation_off_io.h"
#include "gudhi/Alpha_complex.h"
// to construct a simplex_tree from Delaunay_triangulation
#include "gudhi/graph_simplicial_complex.h"
#include "gudhi/Simplex_tree.h"
-#include <CGAL/Delaunay_triangulation.h>
-#include <CGAL/Epick_d.h>
-#include <CGAL/point_generators_d.h>
-#include <CGAL/algorithm.h>
-#include <CGAL/assertions.h>
-
#include <iostream>
#include <iterator>
@@ -41,12 +35,6 @@
#include <stdlib.h>
#include <string>
-// Use dynamic_dimension_tag for the user to be able to set dimension
-typedef CGAL::Epick_d< CGAL::Dynamic_dimension_tag > K;
-typedef CGAL::Delaunay_triangulation<K> T;
-// The triangulation uses the default instanciation of the
-// TriangulationDataStructure template parameter
-
void usage(char * const progName) {
std::cerr << "Usage: " << progName << " filename.off" << std::endl;
exit(-1); // ----- >>
@@ -62,7 +50,7 @@ int main(int argc, char **argv) {
// ----------------------------------------------------------------------------
//
- // Init of an alpha-complex from a OFF file
+ // Init of an alpha-complex from an OFF file
//
// ----------------------------------------------------------------------------
Gudhi::alphacomplex::Alpha_complex alpha_complex_from_file(off_file_name);
@@ -71,7 +59,14 @@ int main(int argc, char **argv) {
std::cout << "alpha_complex_from_file.filtration()=" << alpha_complex_from_file.filtration() << std::endl;
std::cout << "alpha_complex_from_file.num_simplices()=" << alpha_complex_from_file.num_simplices() << std::endl;
std::cout << "alpha_complex_from_file.num_vertices()=" << alpha_complex_from_file.num_vertices() << std::endl;
- std::cout << alpha_complex_from_file << std::endl;
-
+
+ std::cout << "Iterator on Simplices in the filtration order, with [filtration value]:" << std::endl;
+ for (auto f_simplex : alpha_complex_from_file.filtration_simplex_range()) {
+ std::cout << " " << "[" << alpha_complex_from_file.filtration(f_simplex) << "] ";
+ for (auto vertex : alpha_complex_from_file.simplex_vertex_range(f_simplex)) {
+ std::cout << vertex << " ";
+ }
+ std::cout << std::endl;
+ }
return 0;
} \ No newline at end of file
diff --git a/src/Alpha_complex/example/alphashapedoc.off b/src/Alpha_complex/example/alphashapedoc.off
deleted file mode 100755
index bb790193..00000000
--- a/src/Alpha_complex/example/alphashapedoc.off
+++ /dev/null
@@ -1,10 +0,0 @@
-nOFF
-2 7 0 0
-1.0 1.0
-7.0 0.0
-4.0 6.0
-9.0 6.0
-0.0 14.0
-2.0 19.0
-9.0 17.0
-
diff --git a/src/Alpha_complex/include/gudhi/Alpha_complex.h b/src/Alpha_complex/include/gudhi/Alpha_complex.h
index ca84d6d9..d25c05cb 100644
--- a/src/Alpha_complex/include/gudhi/Alpha_complex.h
+++ b/src/Alpha_complex/include/gudhi/Alpha_complex.h
@@ -23,9 +23,6 @@
#ifndef SRC_ALPHA_SHAPES_INCLUDE_GUDHI_ALPHA_SHAPES_H_
#define SRC_ALPHA_SHAPES_INCLUDE_GUDHI_ALPHA_SHAPES_H_
-// to construct a Delaunay_triangulation from a OFF file
-#include <gudhi/Alpha_shapes/Delaunay_triangulation_off_io.h>
-
// to construct a simplex_tree from Delaunay_triangulation
#include <gudhi/graph_simplicial_complex.h>
#include <gudhi/Simplex_tree.h>
@@ -46,8 +43,7 @@
#include <iterator>
#include <vector>
#include <string>
-#include <limits>
-#include <map>
+#include <limits> // NaN
namespace Gudhi {
@@ -82,59 +78,59 @@ class Alpha_complex {
private:
// From Simplex_tree
/** \brief Type required to insert into a simplex_tree (with or without subfaces).*/
- typedef std::vector<Vertex_handle> typeVectorVertex;
+ typedef std::vector<Vertex_handle> Vector_vertex;
+ /** \brief Simplex_handle type from simplex_tree.*/
typedef typename Gudhi::Simplex_tree<>::Simplex_handle Simplex_handle;
+ /** \brief Simplex_result is the type returned from simplex_tree insert function.*/
typedef typename std::pair<Simplex_handle, bool> Simplex_result;
+ /** \brief Filtration_simplex_range type from simplex_tree.*/
+ typedef typename Gudhi::Simplex_tree<>::Filtration_simplex_range Filtration_simplex_range;
+
+ /** \brief Simplex_vertex_range type from simplex_tree.*/
+ typedef typename Gudhi::Simplex_tree<>::Simplex_vertex_range Simplex_vertex_range;
+
// From CGAL
- /** \brief Kernel for the Delaunay_triangulation->
- * Dimension can be set dynamically.
- */
+ /** \brief Kernel for the Delaunay_triangulation. Dimension can be set dynamically.*/
typedef CGAL::Epick_d< CGAL::Dynamic_dimension_tag > Kernel;
- /** \brief Delaunay_triangulation type required to create an alpha-complex.
- */
+ /** \brief Delaunay_triangulation type required to create an alpha-complex.*/
typedef CGAL::Delaunay_triangulation<Kernel> Delaunay_triangulation;
typedef typename Kernel::Compute_squared_radius_d Squared_Radius;
typedef typename Kernel::Side_of_bounded_sphere_d Is_Gabriel;
- /** \brief Type required to insert into a simplex_tree (with or without subfaces).*/
+ /** \brief Type required to compute squared radius, or side of bounded sphere on a vector of points.*/
typedef std::vector<Kernel::Point_d> Vector_of_CGAL_points;
+ /** \brief Vertex_iterator type from CGAL.*/
typedef Delaunay_triangulation::Vertex_iterator CGAL_vertex_iterator;
+ /** \brief Boost bimap type to switch from CGAL vertex iterator to simplex tree vertex handle and vice versa.*/
typedef boost::bimap< CGAL_vertex_iterator, Vertex_handle > Bimap_vertex;
private:
- /** \brief Upper bound on the simplex tree of the simplicial complex.*/
+ /** \brief Alpha complex is represented internally by a simplex tree.*/
Gudhi::Simplex_tree<> st_;
+ /** \brief Boost bimap to switch from CGAL vertex iterator to simplex tree vertex handle and vice versa.*/
Bimap_vertex cgal_simplextree;
+ /** \brief Pointer on the CGAL Delaunay triangulation.*/
Delaunay_triangulation* triangulation;
public:
-
Alpha_complex(std::string& off_file_name)
: triangulation(nullptr) {
-#ifdef DEBUG_TRACES
- char buffer[256]={0};
- sprintf(buffer,"%p", triangulation);
- std::cout << "pointer=" << buffer << std::endl;
-#endif // DEBUG_TRACES
- Gudhi::alphacomplex::Delaunay_triangulation_off_reader<Delaunay_triangulation> off_reader(off_file_name);
+ Gudhi::Delaunay_triangulation_off_reader<Delaunay_triangulation> off_reader(off_file_name);
if (!off_reader.is_valid()) {
std::cerr << "Unable to read file " << off_file_name << std::endl;
exit(-1); // ----- >>
}
triangulation = off_reader.get_complex();
-#ifdef DEBUG_TRACES
- //char buffer[256]={0};
- sprintf(buffer,"%p", triangulation);
- std::cout << "pointer=" << buffer << std::endl;
- std::cout << "number of vertices=" << triangulation->number_of_vertices() << std::endl;
- std::cout << "number of full cells=" << triangulation->number_of_full_cells() << std::endl;
- std::cout << "number of finite full cells=" << triangulation->number_of_finite_full_cells() << std::endl;
-#endif // DEBUG_TRACES
+ init();
+ }
+
+ Alpha_complex(Delaunay_triangulation* triangulation_ptr)
+ : triangulation(triangulation_ptr) {
init();
}
@@ -142,6 +138,21 @@ class Alpha_complex {
delete triangulation;
}
+ Filtration_simplex_range filtration_simplex_range() {
+ return st_.filtration_simplex_range();
+ }
+
+ Simplex_vertex_range simplex_vertex_range(Simplex_handle sh) {
+ return st_.simplex_vertex_range(sh);
+ }
+
+ /** \brief Returns the filtration value of a simplex.
+ *
+ * Called on the null_simplex, returns INFINITY. */
+ Gudhi::Simplex_tree<>::Filtration_value filtration(Simplex_handle sh) {
+ return st_.filtration(sh);
+ }
+
private:
void init() {
@@ -161,7 +172,7 @@ class Alpha_complex {
// --------------------------------------------------------------------------------------------
// Simplex_tree construction from loop on triangulation finite full cells list
for (auto cit = triangulation->finite_full_cells_begin(); cit != triangulation->finite_full_cells_end(); ++cit) {
- typeVectorVertex vertexVector;
+ Vector_vertex vertexVector;
#ifdef DEBUG_TRACES
std::cout << "Simplex_tree insertion ";
#endif // DEBUG_TRACES
@@ -325,7 +336,6 @@ class Alpha_complex {
}
friend std::ostream& operator<<(std::ostream& os, const Alpha_complex & alpha_complex) {
- // TODO: Program terminated with signal SIGABRT, Aborted - Maybe because of copy constructor
Gudhi::Simplex_tree<> st = alpha_complex.st_;
os << st << std::endl;
return os;
diff --git a/src/Alpha_complex/include/gudhi/Alpha_shapes/Delaunay_triangulation_off_io.h b/src/Alpha_complex/include/gudhi/Alpha_shapes/Delaunay_triangulation_off_io.h
deleted file mode 100644
index 8bda23b7..00000000
--- a/src/Alpha_complex/include/gudhi/Alpha_shapes/Delaunay_triangulation_off_io.h
+++ /dev/null
@@ -1,210 +0,0 @@
-/* This file is part of the Gudhi Library. The Gudhi library
- * (Geometric Understanding in Higher Dimensions) is a generic C++
- * library for computational topology.
- *
- * Author(s): Vincent Rouvreau
- *
- * Copyright (C) 2015 INRIA Saclay (France)
- *
- * This program is free software: you can redistribute it and/or modify
- * it under the terms of the GNU General Public License as published by
- * the Free Software Foundation, either version 3 of the License, or
- * (at your option) any later version.
- *
- * This program is distributed in the hope that it will be useful,
- * but WITHOUT ANY WARRANTY; without even the implied warranty of
- * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
- * GNU General Public License for more details.
- *
- * You should have received a copy of the GNU General Public License
- * along with this program. If not, see <http://www.gnu.org/licenses/>.
- */
-#ifndef SRC_ALPHA_SHAPES_INCLUDE_GUDHI_ALPHA_SHAPES_DELAUNAY_TRIANGULATION_OFF_IO_H_
-#define SRC_ALPHA_SHAPES_INCLUDE_GUDHI_ALPHA_SHAPES_DELAUNAY_TRIANGULATION_OFF_IO_H_
-
-#include <string>
-#include <vector>
-#include <fstream>
-#include <map>
-
-#include "gudhi/Off_reader.h"
-
-namespace Gudhi {
-
-namespace alphacomplex {
-
-/**
- *@brief Off reader visitor with flag that can be passed to Off_reader to read a Delaunay_triangulation_complex.
- */
-template<typename Complex>
-class Delaunay_triangulation_off_visitor_reader {
- private:
- Complex* _complex;
- typedef typename Complex::Point Point;
-
- public:
-
- // Pass a Complex as a parameter is required, even if not used. Otherwise, compilation is KO.
- Delaunay_triangulation_off_visitor_reader(Complex* _complex_ptr)
- : _complex(nullptr) { }
-
- void init(int dim, int num_vertices, int num_faces, int num_edges) {
-#ifdef DEBUG_TRACES
- std::cout << "Delaunay_triangulation_off_visitor_reader::init - dim=" << dim << " - num_vertices=" <<
- num_vertices << " - num_faces=" << num_faces << " - num_edges=" << num_edges << std::endl;
-#endif // DEBUG_TRACES
- if (num_faces > 0) {
- std::cerr << "Delaunay_triangulation_off_visitor_reader::init faces are not taken into account from OFF " <<
- "file for Delaunay triangulation - faces are computed." << std::endl;
- }
- if (num_edges > 0) {
- std::cerr << "Delaunay_triangulation_off_visitor_reader::init edges are not taken into account from OFF " <<
- "file for Delaunay triangulation - edges are computed." << std::endl;
- }
- // Complex construction with dimension from file
- _complex = new Complex(dim);
- }
-
- void point(const std::vector<double>& point) {
-#ifdef DEBUG_TRACES
- std::cout << "Delaunay_triangulation_off_visitor_reader::point ";
- for (auto coordinate : point) {
- std::cout << coordinate << " | ";
- }
- std::cout << std::endl;
-#endif // DEBUG_TRACES
- _complex->insert(Point(point.size(), point.begin(), point.end()));
- }
-
- void maximal_face(const std::vector<int>& face) {
- // For Delaunay Triangulation, only points are read
-#ifdef DEBUG_TRACES
- std::cout << "Delaunay_triangulation_off_visitor_reader::face ";
- for (auto vertex : face) {
- std::cout << vertex << " | ";
- }
- std::cout << std::endl;
-#endif // DEBUG_TRACES
- }
-
- void done() {
-#ifdef DEBUG_TRACES
- std::cout << "Delaunay_triangulation_off_visitor_reader::done" << std::endl;
-#endif // DEBUG_TRACES
- }
-
- Complex* get_complex() {
- return _complex;
- }
-};
-
-/**
- *@brief Class that allows to load a Delaunay_triangulation_complex from an off file.
- */
-template<typename Complex>
-class Delaunay_triangulation_off_reader {
- public:
-
- /**
- * name_file : file to read
- * read_complex : complex that will receive the file content
- * read_only_points : specify true if only the points must be read
- */
- Delaunay_triangulation_off_reader(const std::string & name_file) : valid_(false) {
- std::ifstream stream(name_file);
- if (stream.is_open()) {
- Delaunay_triangulation_off_visitor_reader<Complex> off_visitor(_complex);
- Off_reader off_reader(stream);
- valid_ = off_reader.read(off_visitor);
- if (valid_) {
- _complex = off_visitor.get_complex();
- }
- } else {
- std::cerr << "Delaunay_triangulation_off_reader::Delaunay_triangulation_off_reader could not open file " <<
- name_file << std::endl;
- }
-
- }
-
- /**
- * return true if reading did not meet problems.
- */
- bool is_valid() const {
- return valid_;
- }
-
- Complex* get_complex() {
- if (valid_)
- return _complex;
- return nullptr;
-
- }
-
- private:
- bool valid_;
- Complex* _complex;
-};
-
-template<typename Complex>
-class Delaunay_triangulation_off_writer {
- public:
- typedef typename Complex::Point Point;
-
- /**
- * name_file : file where the off will be written
- * save_complex : complex that be outputted in the file
- * for now only save triangles.
- */
- Delaunay_triangulation_off_writer(const std::string & name_file, Complex* complex_ptr) {
- std::ofstream stream(name_file);
- if (stream.is_open()) {
- if (complex_ptr->current_dimension() == 3) {
- // OFF header
- stream << "OFF" << std::endl;
- // no endl on next line - don't know why...
- stream << complex_ptr->number_of_vertices() << " " << complex_ptr->number_of_finite_full_cells() << " 0";
- } else {
- // nOFF header
- stream << "nOFF" << std::endl;
- // no endl on next line - don't know why...
- stream << complex_ptr->current_dimension() << " " << complex_ptr->number_of_vertices() << " " <<
- complex_ptr->number_of_finite_full_cells() << " 0";
-
- }
-
- // bimap to retrieve vertex handles from points and vice versa
- std::map< Point, int > points_to_vh;
- // Start to insert at default handle value
- int vertex_handle = int();
-
- // Points list
- for (auto vit = complex_ptr->vertices_begin(); vit != complex_ptr->vertices_end(); ++vit) {
- for (auto Coord = vit->point().cartesian_begin(); Coord != vit->point().cartesian_end(); ++Coord) {
- stream << *Coord << " ";
- }
- stream << std::endl;
- points_to_vh[vit->point()] = vertex_handle;
- vertex_handle++;
- }
-
- for (auto cit = complex_ptr->finite_full_cells_begin(); cit != complex_ptr->finite_full_cells_end(); ++cit) {
- std::vector<int> vertexVector;
- stream << std::distance(cit->vertices_begin(), cit->vertices_end()) << " ";
- for (auto vit = cit->vertices_begin(); vit != cit->vertices_end(); ++vit) {
- stream << points_to_vh[(*vit)->point()] << " ";
- }
- stream << std::endl;
- }
- stream.close();
- } else {
- std::cerr << "Delaunay_triangulation_off_writer::Delaunay_triangulation_off_writer could not open file " <<
- name_file << std::endl;
- }
- }
-};
-
-} // namespace alphacomplex
-
-} // namespace Gudhi
-
-#endif // SRC_ALPHA_SHAPES_INCLUDE_GUDHI_ALPHA_SHAPES_DELAUNAY_TRIANGULATION_OFF_IO_H_
diff --git a/src/Alpha_complex/test/Alpha_complex_unit_test.cpp b/src/Alpha_complex/test/Alpha_complex_unit_test.cpp
index 38168f10..86d4d9c3 100644
--- a/src/Alpha_complex/test/Alpha_complex_unit_test.cpp
+++ b/src/Alpha_complex/test/Alpha_complex_unit_test.cpp
@@ -25,25 +25,10 @@
#include <boost/system/error_code.hpp>
#include <boost/chrono/thread_clock.hpp>
// to construct a Delaunay_triangulation from a OFF file
-#include "gudhi/Alpha_shapes/Delaunay_triangulation_off_io.h"
+#include "gudhi/Delaunay_triangulation_off_io.h"
#include "gudhi/Alpha_complex.h"
-// to construct a simplex_tree from Delaunay_triangulation
-#include "gudhi/graph_simplicial_complex.h"
-#include "gudhi/Simplex_tree.h"
-
-#include <CGAL/Delaunay_triangulation.h>
-#include <CGAL/Epick_d.h>
-#include <CGAL/point_generators_d.h>
-#include <CGAL/algorithm.h>
-#include <CGAL/assertions.h>
-
-#include <iostream>
-#include <iterator>
-
-#include <stdio.h>
-#include <stdlib.h>
-#include <string>
+#include <cmath> // float comparison
// Use dynamic_dimension_tag for the user to be able to set dimension
typedef CGAL::Epick_d< CGAL::Dynamic_dimension_tag > K;
@@ -51,7 +36,7 @@ typedef CGAL::Delaunay_triangulation<K> T;
// The triangulation uses the default instantiation of the
// TriangulationDataStructure template parameter
-BOOST_AUTO_TEST_CASE( OFF_file ) {
+BOOST_AUTO_TEST_CASE( S4_100_OFF_file ) {
// ----------------------------------------------------------------------------
//
// Init of an alpha-complex from a OFF file
@@ -66,61 +51,37 @@ BOOST_AUTO_TEST_CASE( OFF_file ) {
std::cout << "alpha_complex_from_file.dimension()=" << alpha_complex_from_file.dimension() << std::endl;
BOOST_CHECK(alpha_complex_from_file.dimension() == DIMENSION);
- const double FILTRATION = 0.0;
- std::cout << "alpha_complex_from_file.filtration()=" << alpha_complex_from_file.filtration() << std::endl;
- BOOST_CHECK(alpha_complex_from_file.filtration() == FILTRATION);
-
const int NUMBER_OF_VERTICES = 100;
std::cout << "alpha_complex_from_file.num_vertices()=" << alpha_complex_from_file.num_vertices() << std::endl;
BOOST_CHECK(alpha_complex_from_file.num_vertices() == NUMBER_OF_VERTICES);
- const int NUMBER_OF_SIMPLICES = 6779;
+ const int NUMBER_OF_SIMPLICES = 6879;
std::cout << "alpha_complex_from_file.num_simplices()=" << alpha_complex_from_file.num_simplices() << std::endl;
BOOST_CHECK(alpha_complex_from_file.num_simplices() == NUMBER_OF_SIMPLICES);
}
-BOOST_AUTO_TEST_CASE( Delaunay_triangulation ) {
+BOOST_AUTO_TEST_CASE( S8_10_OFF_file ) {
// ----------------------------------------------------------------------------
//
- // Init of an alpha-complex from a Delaunay triangulation
+ // Init of an alpha-complex from a OFF file
//
// ----------------------------------------------------------------------------
- T dt;
std::string off_file_name("S8_10.off");
std::cout << "========== OFF FILE NAME = " << off_file_name << " ==========" << std::endl;
- Gudhi::alphacomplex::Delaunay_triangulation_off_reader<T> off_reader(off_file_name, dt);
- std::cout << "off_reader.is_valid()=" << off_reader.is_valid() << std::endl;
- BOOST_CHECK(off_reader.is_valid());
-
- const int NUMBER_OF_VERTICES = 10;
- std::cout << "dt.number_of_vertices()=" << dt.number_of_vertices() << std::endl;
- BOOST_CHECK(dt.number_of_vertices() == NUMBER_OF_VERTICES);
-
- const int NUMBER_OF_FULL_CELLS = 30;
- std::cout << "dt.number_of_full_cells()=" << dt.number_of_full_cells() << std::endl;
- BOOST_CHECK(dt.number_of_full_cells() == NUMBER_OF_FULL_CELLS);
-
- const int NUMBER_OF_FINITE_FULL_CELLS = 6;
- std::cout << "dt.number_of_finite_full_cells()=" << dt.number_of_finite_full_cells() << std::endl;
- BOOST_CHECK(dt.number_of_finite_full_cells() == NUMBER_OF_FINITE_FULL_CELLS);
-
- Gudhi::alphacomplex::Alpha_complex alpha_complex_from_dt(dt);
+ Gudhi::alphacomplex::Alpha_complex alpha_complex_from_file(off_file_name);
const int DIMENSION = 8;
- std::cout << "alpha_complex_from_dt.dimension()=" << alpha_complex_from_dt.dimension() << std::endl;
- BOOST_CHECK(alpha_complex_from_dt.dimension() == DIMENSION);
-
- const double FILTRATION = 0.0;
- std::cout << "alpha_complex_from_dt.filtration()=" << alpha_complex_from_dt.filtration() << std::endl;
- BOOST_CHECK(alpha_complex_from_dt.filtration() == FILTRATION);
+ std::cout << "alpha_complex_from_file.dimension()=" << alpha_complex_from_file.dimension() << std::endl;
+ BOOST_CHECK(alpha_complex_from_file.dimension() == DIMENSION);
- std::cout << "alpha_complex_from_dt.num_vertices()=" << alpha_complex_from_dt.num_vertices() << std::endl;
- BOOST_CHECK(alpha_complex_from_dt.num_vertices() == NUMBER_OF_VERTICES);
+ const int NUMBER_OF_VERTICES = 10;
+ std::cout << "alpha_complex_from_file.num_vertices()=" << alpha_complex_from_file.num_vertices() << std::endl;
+ BOOST_CHECK(alpha_complex_from_file.num_vertices() == NUMBER_OF_VERTICES);
- const int NUMBER_OF_SIMPLICES = 997;
- std::cout << "alpha_complex_from_dt.num_simplices()=" << alpha_complex_from_dt.num_simplices() << std::endl;
- BOOST_CHECK(alpha_complex_from_dt.num_simplices() == NUMBER_OF_SIMPLICES);
-}
+ const int NUMBER_OF_SIMPLICES = 1007;
+ std::cout << "alpha_complex_from_file.num_simplices()=" << alpha_complex_from_file.num_simplices() << std::endl;
+ BOOST_CHECK(alpha_complex_from_file.num_simplices() == NUMBER_OF_SIMPLICES);
+}
diff --git a/src/Alpha_complex/test/CMakeLists.txt b/src/Alpha_complex/test/CMakeLists.txt
index 72e8390a..4fe69ce5 100644
--- a/src/Alpha_complex/test/CMakeLists.txt
+++ b/src/Alpha_complex/test/CMakeLists.txt
@@ -15,7 +15,7 @@ if(CGAL_FOUND)
include( ${EIGEN3_USE_FILE} )
include_directories (BEFORE "../../include")
- add_definitions(-DDEBUG_TRACES)
+ #add_definitions(-DDEBUG_TRACES)
add_executable ( AlphaComplexUnitTest Alpha_complex_unit_test.cpp )
target_link_libraries(AlphaComplexUnitTest ${Boost_SYSTEM_LIBRARY} ${CGAL_LIBRARY} ${Boost_UNIT_TEST_FRAMEWORK_LIBRARY})
add_test(AlphaComplexUnitTest ${CMAKE_CURRENT_BINARY_DIR}/AlphaComplexUnitTest)
diff --git a/src/Alpha_complex/test/README b/src/Alpha_complex/test/README
index 244a2b84..45b87d91 100644
--- a/src/Alpha_complex/test/README
+++ b/src/Alpha_complex/test/README
@@ -7,6 +7,6 @@ make
To launch with details:
***********************
-./AlphaShapesUnitTest --report_level=detailed --log_level=all
+./AlphaComplexUnitTest --report_level=detailed --log_level=all
==> echo $? returns 0 in case of success (non-zero otherwise)
diff --git a/src/Alpha_complex/test/S4_100.off b/src/Alpha_complex/test/S4_100.off
index 0a5dc58c..cd017e12 100644
--- a/src/Alpha_complex/test/S4_100.off
+++ b/src/Alpha_complex/test/S4_100.off
@@ -1,5 +1,5 @@
-OFF
-100 0 0
+nOFF
+4 100 0 0
0.562921 -0.735261 -0.256472 0.277007
-0.803733 -0.0527915 -0.315125 0.501918
-0.24946 -0.354982 -0.410773 -0.801887
diff --git a/src/Alpha_complex/test/S8_10.off b/src/Alpha_complex/test/S8_10.off
index 1d67e10f..4e147c44 100644
--- a/src/Alpha_complex/test/S8_10.off
+++ b/src/Alpha_complex/test/S8_10.off
@@ -1,5 +1,5 @@
-OFF
-10 0 0
+nOFF
+8 10 0 0
0.440036 -0.574754 -0.200485 0.216537 -0.501251 -0.0329236 -0.196529 0.313023
-0.129367 -0.184089 -0.213021 -0.415848 0.783529 -0.0438025 0.317256 0.120749
0.132429 0.683748 -0.124536 -0.166133 -0.540695 -0.0887576 0.390234 -0.139031