summaryrefslogtreecommitdiff
path: root/src/Bitmap_cubical_complex/test/CMakeLists.txt
diff options
context:
space:
mode:
authorGard Spreemann <gspr@nonempty.org>2020-01-17 15:37:17 +0100
committerGard Spreemann <gspr@nonempty.org>2020-01-17 15:37:17 +0100
commit9acc59fcc1d5001a212e7b9cd6f00a569a625882 (patch)
tree0f8c3a3c29a9fef6394394a9650198b348bff130 /src/Bitmap_cubical_complex/test/CMakeLists.txt
parent5ccee32ec2ba38743c6b96867db3e1b5151e45e4 (diff)
parentcabc43b34723efa7640313348b844eabe9971e38 (diff)
Merge tag 'tags/gudhi-release-3.1.0.rc1' into dfsg/latest
Diffstat (limited to 'src/Bitmap_cubical_complex/test/CMakeLists.txt')
-rw-r--r--src/Bitmap_cubical_complex/test/CMakeLists.txt5
1 files changed, 2 insertions, 3 deletions
diff --git a/src/Bitmap_cubical_complex/test/CMakeLists.txt b/src/Bitmap_cubical_complex/test/CMakeLists.txt
index d2f002a6..eb7eb6b5 100644
--- a/src/Bitmap_cubical_complex/test/CMakeLists.txt
+++ b/src/Bitmap_cubical_complex/test/CMakeLists.txt
@@ -1,14 +1,13 @@
project(Bitmap_cubical_complex_tests)
-include(GUDHI_test_coverage)
+include(GUDHI_boost_test)
# Do not forget to copy test files in current binary dir
file(COPY "${CMAKE_SOURCE_DIR}/data/bitmap/sinusoid.txt" DESTINATION ${CMAKE_CURRENT_BINARY_DIR}/)
add_executable ( Bitmap_cubical_complex_test_unit Bitmap_test.cpp )
-target_link_libraries(Bitmap_cubical_complex_test_unit ${Boost_UNIT_TEST_FRAMEWORK_LIBRARY})
if (TBB_FOUND)
target_link_libraries(Bitmap_cubical_complex_test_unit ${TBB_LIBRARIES})
endif()
-gudhi_add_coverage_test(Bitmap_cubical_complex_test_unit)
+gudhi_add_boost_test(Bitmap_cubical_complex_test_unit)