summaryrefslogtreecommitdiff
path: root/src/Bitmap_cubical_complex
diff options
context:
space:
mode:
authorvrouvrea <vrouvrea@636b058d-ea47-450e-bf9e-a15bfbe3eedb>2017-04-14 16:00:00 +0000
committervrouvrea <vrouvrea@636b058d-ea47-450e-bf9e-a15bfbe3eedb>2017-04-14 16:00:00 +0000
commit64f04c1f15d9ccc4311d162d988c35a3d4130ace (patch)
treea1480eb9d8583b364968462e66c8feb732911e08 /src/Bitmap_cubical_complex
parentb6fbe2815e082eeb27109b71cb51d2173bc67ba4 (diff)
Remove scripts/generate_version.sh, use make user_version
Remove GUDHIVersion.cmake.in (was for scripts/generate_version.sh) and CMakeLists.txt mechanism Modify src/Bitmap_cubical_complex/example/CMakeLists.txt to generate files in build directory git-svn-id: svn+ssh://scm.gforge.inria.fr/svnroot/gudhi/trunk@2358 636b058d-ea47-450e-bf9e-a15bfbe3eedb Former-commit-id: 32c73be6aa9a0a6fcfde09ebf21ff38d48abf5e0
Diffstat (limited to 'src/Bitmap_cubical_complex')
-rw-r--r--src/Bitmap_cubical_complex/example/CMakeLists.txt27
1 files changed, 23 insertions, 4 deletions
diff --git a/src/Bitmap_cubical_complex/example/CMakeLists.txt b/src/Bitmap_cubical_complex/example/CMakeLists.txt
index 2fddc514..97a45190 100644
--- a/src/Bitmap_cubical_complex/example/CMakeLists.txt
+++ b/src/Bitmap_cubical_complex/example/CMakeLists.txt
@@ -6,8 +6,18 @@ target_link_libraries(Bitmap_cubical_complex ${Boost_SYSTEM_LIBRARY})
if (TBB_FOUND)
target_link_libraries(Bitmap_cubical_complex ${TBB_LIBRARIES})
endif()
-add_test(Bitmap_cubical_complex_one_sphere ${CMAKE_CURRENT_BINARY_DIR}/Bitmap_cubical_complex ${CMAKE_SOURCE_DIR}/data/bitmap/CubicalOneSphere.txt)
-add_test(Bitmap_cubical_complex_two_sphere ${CMAKE_CURRENT_BINARY_DIR}/Bitmap_cubical_complex ${CMAKE_SOURCE_DIR}/data/bitmap/CubicalTwoSphere.txt)
+
+# Do not forget to copy test files in current binary dir
+file(COPY "${CMAKE_SOURCE_DIR}/data/bitmap/CubicalOneSphere.txt" DESTINATION ${CMAKE_CURRENT_BINARY_DIR}/)
+file(COPY "${CMAKE_SOURCE_DIR}/data/bitmap/CubicalTwoSphere.txt" DESTINATION ${CMAKE_CURRENT_BINARY_DIR}/)
+
+add_test(Bitmap_cubical_complex_one_sphere
+ ${CMAKE_CURRENT_BINARY_DIR}/Bitmap_cubical_complex
+ ${CMAKE_CURRENT_BINARY_DIR}/CubicalOneSphere.txt)
+
+add_test(Bitmap_cubical_complex_two_sphere
+ ${CMAKE_CURRENT_BINARY_DIR}/Bitmap_cubical_complex
+ ${CMAKE_CURRENT_BINARY_DIR}/CubicalTwoSphere.txt)
add_executable ( Random_bitmap_cubical_complex Random_bitmap_cubical_complex.cpp )
target_link_libraries(Random_bitmap_cubical_complex ${Boost_SYSTEM_LIBRARY})
@@ -21,6 +31,15 @@ target_link_libraries(Bitmap_cubical_complex_periodic_boundary_conditions ${Boos
if (TBB_FOUND)
target_link_libraries(Bitmap_cubical_complex_periodic_boundary_conditions ${TBB_LIBRARIES})
endif()
-add_test(Bitmap_cubical_complex_periodic_2d_torus ${CMAKE_CURRENT_BINARY_DIR}/Bitmap_cubical_complex_periodic_boundary_conditions ${CMAKE_SOURCE_DIR}/data/bitmap/2d_torus.txt)
-add_test(Bitmap_cubical_complex_periodic_3d_torus ${CMAKE_CURRENT_BINARY_DIR}/Bitmap_cubical_complex_periodic_boundary_conditions ${CMAKE_SOURCE_DIR}/data/bitmap/3d_torus.txt)
+
+# Do not forget to copy test files in current binary dir
+file(COPY "${CMAKE_SOURCE_DIR}/data/bitmap/2d_torus.txt" DESTINATION ${CMAKE_CURRENT_BINARY_DIR}/)
+file(COPY "${CMAKE_SOURCE_DIR}/data/bitmap/3d_torus.txt" DESTINATION ${CMAKE_CURRENT_BINARY_DIR}/)
+
+add_test(Bitmap_cubical_complex_periodic_2d_torus
+ ${CMAKE_CURRENT_BINARY_DIR}/Bitmap_cubical_complex_periodic_boundary_conditions
+ ${CMAKE_CURRENT_BINARY_DIR}/2d_torus.txt)
+add_test(Bitmap_cubical_complex_periodic_3d_torus
+ ${CMAKE_CURRENT_BINARY_DIR}/Bitmap_cubical_complex_periodic_boundary_conditions
+ ${CMAKE_CURRENT_BINARY_DIR}/3d_torus.txt)