summaryrefslogtreecommitdiff
path: root/src/Bitmap_cubical_complex
diff options
context:
space:
mode:
authorskachano <skachano@636b058d-ea47-450e-bf9e-a15bfbe3eedb>2017-11-14 19:40:43 +0000
committerskachano <skachano@636b058d-ea47-450e-bf9e-a15bfbe3eedb>2017-11-14 19:40:43 +0000
commitc438bf42d79c464104755108440d70b5dc2abf0b (patch)
tree7f8b961abd8ac34be29144ec41d26b0e8181caed /src/Bitmap_cubical_complex
parent72263df69d75f6b987fae2ac22a9115f4f8b4279 (diff)
Merged trunk in cc_wit for having fun with Pawel's idea
git-svn-id: svn+ssh://scm.gforge.inria.fr/svnroot/gudhi/trunk@2873 636b058d-ea47-450e-bf9e-a15bfbe3eedb Former-commit-id: 56c9a7c1528f0b94ab69e5327dabbc602f18036c
Diffstat (limited to 'src/Bitmap_cubical_complex')
-rw-r--r--src/Bitmap_cubical_complex/example/CMakeLists.txt10
1 files changed, 10 insertions, 0 deletions
diff --git a/src/Bitmap_cubical_complex/example/CMakeLists.txt b/src/Bitmap_cubical_complex/example/CMakeLists.txt
index a0401619..66defc8f 100644
--- a/src/Bitmap_cubical_complex/example/CMakeLists.txt
+++ b/src/Bitmap_cubical_complex/example/CMakeLists.txt
@@ -6,6 +6,16 @@ if (TBB_FOUND)
target_link_libraries(Bitmap_cubical_complex ${TBB_LIBRARIES})
endif()
+add_executable ( cc_wit_hiraoka cc_wit_hiraoka.cpp )
+if (TBB_FOUND)
+ target_link_libraries(cc_wit_hiraoka ${TBB_LIBRARIES})
+endif()
+
+add_executable ( cc_wit_hiraoka_img cc_wit_hiraoka_img.cpp )
+if (TBB_FOUND)
+ target_link_libraries(cc_wit_hiraoka_img ${TBB_LIBRARIES})
+endif()
+
add_test(NAME Bitmap_cubical_complex_example_persistence_one_sphere COMMAND $<TARGET_FILE:Bitmap_cubical_complex>
"${CMAKE_SOURCE_DIR}/data/bitmap/CubicalOneSphere.txt")