summaryrefslogtreecommitdiff
path: root/src/Bottleneck_distance/example/CMakeLists.txt
diff options
context:
space:
mode:
authorcjamin <cjamin@636b058d-ea47-450e-bf9e-a15bfbe3eedb>2017-05-31 12:03:13 +0000
committercjamin <cjamin@636b058d-ea47-450e-bf9e-a15bfbe3eedb>2017-05-31 12:03:13 +0000
commit267f55ba68cd3c7beee9cd8c7bd9e13d90217848 (patch)
treeffd0d2d23c17f81e270f65c9739bbff35c575aa5 /src/Bottleneck_distance/example/CMakeLists.txt
parentdf15aa4e16c00a7dc3bca01e01db8608b50dd4b9 (diff)
Test bottleneck_read_file_example
git-svn-id: svn+ssh://scm.gforge.inria.fr/svnroot/gudhi/branches/read_persistence_from_file@2490 636b058d-ea47-450e-bf9e-a15bfbe3eedb Former-commit-id: dbbce2ac4862dfdd3c01a619bf68120112ab44d5
Diffstat (limited to 'src/Bottleneck_distance/example/CMakeLists.txt')
-rw-r--r--src/Bottleneck_distance/example/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/src/Bottleneck_distance/example/CMakeLists.txt b/src/Bottleneck_distance/example/CMakeLists.txt
index 0534a2c4..508e57bf 100644
--- a/src/Bottleneck_distance/example/CMakeLists.txt
+++ b/src/Bottleneck_distance/example/CMakeLists.txt
@@ -19,6 +19,10 @@ if (NOT CGAL_WITH_EIGEN3_VERSION VERSION_LESS 4.8.1)
COMMAND $<TARGET_FILE:alpha_rips_persistence_bottleneck_distance>
"${CMAKE_SOURCE_DIR}/data/points/tore3D_1307.off" "-r" "0.15" "-m" "0.12" "-d" "3" "-p" "3")
+ add_test(NAME Bottleneck_read_file_example
+ COMMAND $<TARGET_FILE:bottleneck_read_file_example>
+ "${CMAKE_SOURCE_DIR}/data/persistence_diagram/first.pers" "${CMAKE_SOURCE_DIR}/data/persistence_diagram/second.pers")
+
install(TARGETS bottleneck_read_file_example DESTINATION bin)
install(TARGETS bottleneck_basic_example DESTINATION bin)
install(TARGETS alpha_rips_persistence_bottleneck_distance DESTINATION bin)