summaryrefslogtreecommitdiff
path: root/src/Bottleneck_distance/example/CMakeLists.txt
diff options
context:
space:
mode:
authorcjamin <cjamin@636b058d-ea47-450e-bf9e-a15bfbe3eedb>2017-11-15 14:20:30 +0000
committercjamin <cjamin@636b058d-ea47-450e-bf9e-a15bfbe3eedb>2017-11-15 14:20:30 +0000
commit8428e315efa22a1b40eb996c98eff671f91a9b27 (patch)
treedc2a8813436d0decc171e6779ef4e1db8c89c212 /src/Bottleneck_distance/example/CMakeLists.txt
parent629542264458d2174ece2c18a490f63d1a231802 (diff)
Fixes according to Marc's review
git-svn-id: svn+ssh://scm.gforge.inria.fr/svnroot/gudhi/branches/add_utils_in_gudhi_v2@2881 636b058d-ea47-450e-bf9e-a15bfbe3eedb Former-commit-id: 84870193cb05cabd8c756a3bbc49083e4d739525
Diffstat (limited to 'src/Bottleneck_distance/example/CMakeLists.txt')
-rw-r--r--src/Bottleneck_distance/example/CMakeLists.txt12
1 files changed, 6 insertions, 6 deletions
diff --git a/src/Bottleneck_distance/example/CMakeLists.txt b/src/Bottleneck_distance/example/CMakeLists.txt
index 6a602dbb..9677f5c5 100644
--- a/src/Bottleneck_distance/example/CMakeLists.txt
+++ b/src/Bottleneck_distance/example/CMakeLists.txt
@@ -3,15 +3,15 @@ project(Bottleneck_distance_examples)
if (NOT CGAL_VERSION VERSION_LESS 4.8.1)
add_executable (bottleneck_basic_example bottleneck_basic_example.cpp)
- add_executable (bottleneck_read_file_example bottleneck_read_file_example.cpp)
+ add_executable (alpha_rips_persistence_bottleneck_distance alpha_rips_persistence_bottleneck_distance.cpp)
+ target_link_libraries(alpha_rips_persistence_bottleneck_distance ${Boost_PROGRAM_OPTIONS_LIBRARY})
add_test(NAME Bottleneck_distance_example_basic COMMAND $<TARGET_FILE:bottleneck_basic_example>)
+ add_test(NAME Bottleneck_distance_example_alpha_rips_persistence_bottleneck
+ COMMAND $<TARGET_FILE:alpha_rips_persistence_bottleneck_distance>
+ "${CMAKE_SOURCE_DIR}/data/points/tore3D_1307.off" "-r" "0.15" "-m" "0.12" "-d" "3" "-p" "3")
- add_test(NAME Bottleneck_read_file_example
- COMMAND $<TARGET_FILE:bottleneck_read_file_example>
- "${CMAKE_SOURCE_DIR}/data/persistence_diagram/first.pers" "${CMAKE_SOURCE_DIR}/data/persistence_diagram/second.pers")
-
- install(TARGETS bottleneck_read_file_example DESTINATION bin)
install(TARGETS bottleneck_basic_example DESTINATION bin)
+ install(TARGETS alpha_rips_persistence_bottleneck_distance DESTINATION bin)
endif (NOT CGAL_VERSION VERSION_LESS 4.8.1)