summaryrefslogtreecommitdiff
path: root/src/Bottleneck_distance/example
diff options
context:
space:
mode:
authorvrouvrea <vrouvrea@636b058d-ea47-450e-bf9e-a15bfbe3eedb>2016-09-13 07:30:29 +0000
committervrouvrea <vrouvrea@636b058d-ea47-450e-bf9e-a15bfbe3eedb>2016-09-13 07:30:29 +0000
commitb57185091b250252fe343a572cef6195bca47d2e (patch)
treeeedc4090fd9c8e35bd1fdbd6d10b4bdfcca35df8 /src/Bottleneck_distance/example
parent35c679061122f630358d927bd22089c1d4c0c8cd (diff)
parentaa9705ab541323e1d7aa0129c8faf0416b0489e0 (diff)
Merge branch bottleneckDistance on a up-to-date branch
git-svn-id: svn+ssh://scm.gforge.inria.fr/svnroot/gudhi/branches/bottleneck_integration@1492 636b058d-ea47-450e-bf9e-a15bfbe3eedb Former-commit-id: bccdeaf8456b7b88ad2da71205dbb4c5d08a53ee
Diffstat (limited to 'src/Bottleneck_distance/example')
-rw-r--r--src/Bottleneck_distance/example/CMakeLists.txt12
-rw-r--r--src/Bottleneck_distance/example/bottleneck_example.cpp78
2 files changed, 90 insertions, 0 deletions
diff --git a/src/Bottleneck_distance/example/CMakeLists.txt b/src/Bottleneck_distance/example/CMakeLists.txt
new file mode 100644
index 00000000..adf298aa
--- /dev/null
+++ b/src/Bottleneck_distance/example/CMakeLists.txt
@@ -0,0 +1,12 @@
+cmake_minimum_required(VERSION 2.6)
+project(Bottleneck_distance_examples)
+
+# need CGAL 4.6
+# cmake -DCGAL_DIR=~/workspace/CGAL-4.6-beta1 ../../..
+if(CGAL_FOUND)
+ if (NOT CGAL_VERSION VERSION_LESS 4.6.0)
+ if (EIGEN3_FOUND)
+ add_executable (bottleneck_example bottleneck_example.cpp)
+ endif()
+ endif ()
+endif()
diff --git a/src/Bottleneck_distance/example/bottleneck_example.cpp b/src/Bottleneck_distance/example/bottleneck_example.cpp
new file mode 100644
index 00000000..472c5c84
--- /dev/null
+++ b/src/Bottleneck_distance/example/bottleneck_example.cpp
@@ -0,0 +1,78 @@
+/* This file is part of the Gudhi Library. The Gudhi library
+ * (Geometric Understanding in Higher Dimensions) is a generic C++
+ * library for computational topology.
+ *
+ * Author(s): Francois Godi, small modifications by Pawel Dlotko
+ *
+ * Copyright (C) 2015 INRIA Saclay (France)
+ *
+ * This program is free software: you can redistribute it and/or modify
+ * it under the terms of the GNU General Public License as published by
+ * the Free Software Foundation, either version 3 of the License, or
+ * (at your option) any later version.
+ *
+ * This program is distributed in the hope that it will be useful,
+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ * GNU General Public License for more details.
+ *
+ * You should have received a copy of the GNU General Public License
+ * along with this program. If not, see <http://www.gnu.org/licenses/>.
+ */
+
+#define CGAL_HAS_THREADS
+
+#include <gudhi/Graph_matching.h>
+#include <iostream>
+#include <fstream>
+#include <sstream>
+#include <string>
+
+using namespace std;
+
+//PD: I am using this type of procedures a lot in Gudhi stat. We should make one for all at some point.
+std::vector< std::pair<double, double> > read_diagram_from_file( const char* filename )
+{
+ ifstream in;
+ in.open( filename );
+ std::vector< std::pair<double, double> > result;
+ if ( !in.is_open() )
+ {
+ std::cerr << "File : " << filename << " do not exist. The program will now terminate \n";
+ throw "File do not exist \n";
+ }
+
+ std::string line;
+ while (!in.eof())
+ {
+ getline(in,line);
+ if ( line.length() != 0 )
+ {
+ std::stringstream lineSS;
+ lineSS << line;
+ double beginn, endd;
+ lineSS >> beginn;
+ lineSS >> endd;
+ result.push_back( std::make_pair( beginn , endd ) );
+ }
+ }
+ in.close();
+ return result;
+}//read_diagram_from_file
+
+int main( int argc , char** argv )
+{
+ if ( argc < 3 )
+ {
+ std::cout << "To run this program please provide as an input two files with persistence diagrams. Each file should contain a birth-death pair per line. Third, optional parameter is an error bound on a bottleneck distance (set by default to zero). The program will now terminate \n";
+ }
+ std::vector< std::pair< double , double > > diag1 = read_diagram_from_file( argv[1] );
+ std::vector< std::pair< double , double > > diag2 = read_diagram_from_file( argv[2] );
+ double tolerance = 0;
+ if ( argc == 4 )
+ {
+ tolerance = atof( argv[3] );
+ }
+ double b = Gudhi::Bottleneck_distance::compute(diag1, diag2, tolerance);
+ std::cout << "The distance between the diagrams is : " << b << ". The tolerace is : " << tolerance << std::endl;
+}