summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorvrouvrea <vrouvrea@636b058d-ea47-450e-bf9e-a15bfbe3eedb>2016-08-04 15:41:38 +0000
committervrouvrea <vrouvrea@636b058d-ea47-450e-bf9e-a15bfbe3eedb>2016-08-04 15:41:38 +0000
commitc4f7417b79dfe7610a9e7b5ffbf487abfe7fa3a0 (patch)
tree39ea60d6613c56dd81f5d05869ab2a630ae786f9 /src/CMakeLists.txt
parentd5c5c59161b724f93999c78d979c555b9a72d1ec (diff)
Make GUDHI Cmake less verbose on CGAL package finding
git-svn-id: svn+ssh://scm.gforge.inria.fr/svnroot/gudhi/trunk@1415 636b058d-ea47-450e-bf9e-a15bfbe3eedb Former-commit-id: 2eebce43b0f75ab1cef3a2fe6f2c1bd0b38672a9
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt8
1 files changed, 5 insertions, 3 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 80f6e1ff..c02f816d 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -32,12 +32,14 @@ else()
# A fix would be to use https://cmake.org/cmake/help/v3.1/prop_gbl/CMAKE_CXX_KNOWN_FEATURES.html
# or even better https://cmake.org/cmake/help/v3.1/variable/CMAKE_CXX_STANDARD.html
# but it implies to use cmake version 3.1 at least.
- find_package(CGAL)
+
+ # find CGAL in QUIET mode for cmake to be less verbose when CGAL is not found.
+ find_package(CGAL QUIET)
# Only CGAL versions > 4.4 supports what Gudhi uses from CGAL
- if (CGAL_VERSION VERSION_LESS 4.4.0)
+ if (CGAL_VERSION VERSION_LESS 4.4.0 AND CGAL_FOUND)
message("CGAL version ${CGAL_VERSION} is considered too old to be used by Gudhi.")
unset(CGAL_FOUND)
- endif()
+ endif(CGAL_VERSION VERSION_LESS 4.4.0 AND CGAL_FOUND)
if(CGAL_FOUND)
message(STATUS "CGAL version: ${CGAL_VERSION}.")
include( ${CGAL_USE_FILE} )