summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorvrouvrea <vrouvrea@636b058d-ea47-450e-bf9e-a15bfbe3eedb>2016-10-11 13:57:03 +0000
committervrouvrea <vrouvrea@636b058d-ea47-450e-bf9e-a15bfbe3eedb>2016-10-11 13:57:03 +0000
commit16aaf4cda5fd97da12a7f1da8b0a5168fac2e289 (patch)
tree31554bf878ca21a6330a4a28116398e400072427 /src/CMakeLists.txt
parent74bb6a8a2179090ffc5e65bb7e33fdff62ae4a65 (diff)
Problem of merge with tangentialcomplex branch.
Redo in an integration branch git-svn-id: svn+ssh://scm.gforge.inria.fr/svnroot/gudhi/branches/tangential_integration@1701 636b058d-ea47-450e-bf9e-a15bfbe3eedb Former-commit-id: fa029e8e90b3e203ea675f02098ec6fe95596f9f
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt7
1 files changed, 6 insertions, 1 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 3a831814..e26b2d25 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -12,7 +12,7 @@ list(APPEND CMAKE_MODULE_PATH "${CMAKE_SOURCE_DIR}/cmake/modules/")
find_package(Boost REQUIRED COMPONENTS system filesystem program_options chrono timer date_time REQUIRED)
if(NOT Boost_FOUND)
- message(FATAL_ERROR "NOTICE: This demo requires Boost and will not be compiled.")
+ message(FATAL_ERROR "NOTICE: This program requires Boost and will not be compiled.")
else()
# For "make doxygen"
@@ -47,6 +47,10 @@ else()
if(CGAL_FOUND)
message(STATUS "CGAL version: ${CGAL_VERSION}.")
include( ${CGAL_USE_FILE} )
+
+ if (NOT CGAL_VERSION VERSION_LESS 4.8.0)
+ include_directories(BEFORE "include/gudhi_patches")
+ endif()
endif()
if(MSVC)
@@ -110,6 +114,7 @@ else()
add_subdirectory(example/Alpha_complex)
add_subdirectory(example/Spatial_searching)
add_subdirectory(example/Subsampling)
+ add_subdirectory(example/Tangential_complex)
# data points generator
add_subdirectory(data/points/generator)