summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorvrouvrea <vrouvrea@636b058d-ea47-450e-bf9e-a15bfbe3eedb>2016-11-16 11:49:41 +0000
committervrouvrea <vrouvrea@636b058d-ea47-450e-bf9e-a15bfbe3eedb>2016-11-16 11:49:41 +0000
commit668e76bbe8f350ab0fdf6f6105e8c7818a5ad38f (patch)
tree069ec9b257efeb05f775bf8f267b26adc720cb68 /src/CMakeLists.txt
parentdef467c2cb019b7a5cc758b6778957be11465a6e (diff)
parent1839d09009b10ce3c62770e082a4d7816d991e14 (diff)
Merged last trunk modifications
Make Witness compile and test git-svn-id: svn+ssh://scm.gforge.inria.fr/svnroot/gudhi/branches/rips_complex_module@1755 636b058d-ea47-450e-bf9e-a15bfbe3eedb Former-commit-id: e6eec55ac0a4cc66da3bb081a222cae5b998c1cf
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt9
1 files changed, 8 insertions, 1 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 7973ae39..db9c40fc 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -12,7 +12,7 @@ list(APPEND CMAKE_MODULE_PATH "${CMAKE_SOURCE_DIR}/cmake/modules/")
find_package(Boost REQUIRED COMPONENTS system filesystem program_options chrono timer date_time REQUIRED)
if(NOT Boost_FOUND)
- message(FATAL_ERROR "NOTICE: This demo requires Boost and will not be compiled.")
+ message(FATAL_ERROR "NOTICE: This program requires Boost and will not be compiled.")
else()
# For "make doxygen"
@@ -47,6 +47,10 @@ else()
if(CGAL_FOUND)
message(STATUS "CGAL version: ${CGAL_VERSION}.")
include( ${CGAL_USE_FILE} )
+
+ if (NOT CGAL_VERSION VERSION_LESS 4.8.0)
+ include_directories(BEFORE "include/gudhi_patches")
+ endif()
endif()
if(MSVC)
@@ -109,6 +113,9 @@ else()
add_subdirectory(example/Witness_complex)
add_subdirectory(example/Alpha_complex)
add_subdirectory(example/Rips_complex)
+ add_subdirectory(example/Spatial_searching)
+ add_subdirectory(example/Subsampling)
+ add_subdirectory(example/Tangential_complex)
# data points generator
add_subdirectory(data/points/generator)