summaryrefslogtreecommitdiff
path: root/src/Cech_complex/example/CMakeLists.txt
diff options
context:
space:
mode:
authorGard Spreemann <gspr@nonempty.org>2020-12-16 15:15:38 +0100
committerGard Spreemann <gspr@nonempty.org>2020-12-16 15:15:38 +0100
commitb6a3def70b15baf2dda0844762dcd291e240d2c1 (patch)
treedf4d6b690d0fc7f46d259364fe4a6fcc85f62b40 /src/Cech_complex/example/CMakeLists.txt
parent1c05c20d7cf92c96b5036620cc892cb956c96785 (diff)
parentcf36a3971fb6a0ed37577295d7f1f13a930d1dba (diff)
Merge tag 'tags/gudhi-release-3.4.0' into dfsg/latest
Diffstat (limited to 'src/Cech_complex/example/CMakeLists.txt')
-rw-r--r--src/Cech_complex/example/CMakeLists.txt15
1 files changed, 8 insertions, 7 deletions
diff --git a/src/Cech_complex/example/CMakeLists.txt b/src/Cech_complex/example/CMakeLists.txt
index 98757988..1b08c7cb 100644
--- a/src/Cech_complex/example/CMakeLists.txt
+++ b/src/Cech_complex/example/CMakeLists.txt
@@ -1,13 +1,14 @@
-cmake_minimum_required(VERSION 2.6)
project(Cech_complex_examples)
-add_executable ( Cech_complex_example_step_by_step cech_complex_step_by_step.cpp )
-target_link_libraries(Cech_complex_example_step_by_step Boost::program_options)
-if (TBB_FOUND)
- target_link_libraries(Cech_complex_example_step_by_step ${TBB_LIBRARIES})
+if (TARGET Boost::program_options)
+ add_executable ( Cech_complex_example_step_by_step cech_complex_step_by_step.cpp )
+ target_link_libraries(Cech_complex_example_step_by_step Boost::program_options)
+ if (TBB_FOUND)
+ target_link_libraries(Cech_complex_example_step_by_step ${TBB_LIBRARIES})
+ endif()
+ add_test(NAME Cech_complex_utility_from_rips_on_tore_3D COMMAND $<TARGET_FILE:Cech_complex_example_step_by_step>
+ "${CMAKE_SOURCE_DIR}/data/points/tore3D_300.off" "-r" "0.25" "-d" "3")
endif()
-add_test(NAME Cech_complex_utility_from_rips_on_tore_3D COMMAND $<TARGET_FILE:Cech_complex_example_step_by_step>
- "${CMAKE_SOURCE_DIR}/data/points/tore3D_300.off" "-r" "0.25" "-d" "3")
add_executable ( Cech_complex_example_from_points cech_complex_example_from_points.cpp)
if (TBB_FOUND)