summaryrefslogtreecommitdiff
path: root/src/Cech_complex/test/CMakeLists.txt
diff options
context:
space:
mode:
authorHind-M <hind.montassif@gmail.com>2021-09-30 16:13:39 +0200
committerHind-M <hind.montassif@gmail.com>2021-09-30 16:13:39 +0200
commit65b32d167810a107cf807572f84cef082c76067d (patch)
treeb1b526c798717dda22dacfbfbba54708fe808bd2 /src/Cech_complex/test/CMakeLists.txt
parent767d9fca5da2d3dd9698a5c27e9bedc159271f67 (diff)
Add Cech tests, examples, utilities and benchmark to the build only if CGAL is present
Diffstat (limited to 'src/Cech_complex/test/CMakeLists.txt')
-rw-r--r--src/Cech_complex/test/CMakeLists.txt19
1 files changed, 11 insertions, 8 deletions
diff --git a/src/Cech_complex/test/CMakeLists.txt b/src/Cech_complex/test/CMakeLists.txt
index e6a2a18f..8e725f50 100644
--- a/src/Cech_complex/test/CMakeLists.txt
+++ b/src/Cech_complex/test/CMakeLists.txt
@@ -1,11 +1,14 @@
-include(GUDHI_boost_test)
+if (CGAL_FOUND)
+ include(GUDHI_boost_test)
-add_executable ( Cech_complex_test_unit test_cech_complex.cpp )
-if (TBB_FOUND)
- target_link_libraries(Cech_complex_test_unit ${TBB_LIBRARIES})
-endif()
+ add_executable ( Cech_complex_test_unit test_cech_complex.cpp )
+ if (TBB_FOUND)
+ target_link_libraries(Cech_complex_test_unit ${TBB_LIBRARIES})
+ endif()
+
+ # Do not forget to copy test files in current binary dir
+ file(COPY "${CMAKE_SOURCE_DIR}/data/points/alphacomplexdoc.off" DESTINATION ${CMAKE_CURRENT_BINARY_DIR}/)
-# Do not forget to copy test files in current binary dir
-file(COPY "${CMAKE_SOURCE_DIR}/data/points/alphacomplexdoc.off" DESTINATION ${CMAKE_CURRENT_BINARY_DIR}/)
+ gudhi_add_boost_test(Cech_complex_test_unit)
-gudhi_add_boost_test(Cech_complex_test_unit)
+endif()