summaryrefslogtreecommitdiff
path: root/src/Cech_complex
diff options
context:
space:
mode:
authorvrouvrea <vrouvrea@636b058d-ea47-450e-bf9e-a15bfbe3eedb>2018-03-22 08:36:00 +0000
committervrouvrea <vrouvrea@636b058d-ea47-450e-bf9e-a15bfbe3eedb>2018-03-22 08:36:00 +0000
commit0d0ca116e7fef77cc950b7e85380495661311d91 (patch)
tree09328b79afdbfb15b1bd166411a5d22c0136afc4 /src/Cech_complex
parent61c5f3a96c33ce4e6a90fefaef03c7c474ce51b5 (diff)
Move Miniball in gudhi
git-svn-id: svn+ssh://scm.gforge.inria.fr/svnroot/gudhi/branches/cechcomplex_vincent@3302 636b058d-ea47-450e-bf9e-a15bfbe3eedb Former-commit-id: 736e5c33a9593e4dfb5b19ddc745ab9852d71b40
Diffstat (limited to 'src/Cech_complex')
-rw-r--r--src/Cech_complex/benchmark/cech_complex_benchmark.cpp5
-rw-r--r--src/Cech_complex/example/CMakeLists.txt2
-rw-r--r--src/Cech_complex/example/cech_complex_step_by_step.cpp4
-rw-r--r--src/Cech_complex/include/gudhi/Miniball.COPYRIGHT (renamed from src/Cech_complex/include/Miniball/Miniball.COPYRIGHT)0
-rw-r--r--src/Cech_complex/include/gudhi/Miniball.README (renamed from src/Cech_complex/include/Miniball/Miniball.README)0
-rw-r--r--src/Cech_complex/include/gudhi/Miniball.hpp (renamed from src/Cech_complex/include/Miniball/Miniball.hpp)5
-rw-r--r--src/Cech_complex/test/test_cech_complex.cpp5
7 files changed, 12 insertions, 9 deletions
diff --git a/src/Cech_complex/benchmark/cech_complex_benchmark.cpp b/src/Cech_complex/benchmark/cech_complex_benchmark.cpp
index 83ef9dca..6ba52419 100644
--- a/src/Cech_complex/benchmark/cech_complex_benchmark.cpp
+++ b/src/Cech_complex/benchmark/cech_complex_benchmark.cpp
@@ -27,8 +27,7 @@
#include <gudhi/Rips_complex.h>
#include <gudhi/Cech_complex.h>
#include <gudhi/Simplex_tree.h>
-
-#include <Miniball/Miniball.hpp>
+#include <gudhi/Miniball.hpp>
#include "boost/filesystem.hpp" // includes all needed Boost.Filesystem declarations
@@ -57,7 +56,7 @@ class Radius_distance {
using Point_cloud = std::vector<Point>;
using Point_iterator = typename Point_cloud::const_iterator;
using Coordinate_iterator = typename Point::const_iterator;
- using Min_sphere = typename Miniball::Miniball<Miniball::CoordAccessor<Point_iterator, Coordinate_iterator>>;
+ using Min_sphere = typename Gudhi::Miniball::Miniball<Gudhi::Miniball::CoordAccessor<Point_iterator, Coordinate_iterator>>;
Point_cloud point_cloud;
point_cloud.push_back(p1);
diff --git a/src/Cech_complex/example/CMakeLists.txt b/src/Cech_complex/example/CMakeLists.txt
index ac32ff95..ab391215 100644
--- a/src/Cech_complex/example/CMakeLists.txt
+++ b/src/Cech_complex/example/CMakeLists.txt
@@ -6,6 +6,8 @@ target_link_libraries(Cech_complex_example_step_by_step ${Boost_PROGRAM_OPTIONS_
if (TBB_FOUND)
target_link_libraries(Cech_complex_example_step_by_step ${TBB_LIBRARIES})
endif()
+add_test(NAME Cech_complex_utility_from_rips_on_tore_3D COMMAND $<TARGET_FILE:Cech_complex_example_step_by_step>
+ "${CMAKE_SOURCE_DIR}/data/points/tore3D_300.off" "-r" "0.25" "-d" "3")
add_executable ( Cech_complex_example_from_points cech_complex_example_from_points.cpp)
if (TBB_FOUND)
diff --git a/src/Cech_complex/example/cech_complex_step_by_step.cpp b/src/Cech_complex/example/cech_complex_step_by_step.cpp
index 8705a3e5..0e7c4bbd 100644
--- a/src/Cech_complex/example/cech_complex_step_by_step.cpp
+++ b/src/Cech_complex/example/cech_complex_step_by_step.cpp
@@ -25,7 +25,7 @@
#include <gudhi/Simplex_tree.h>
#include <gudhi/Points_off_io.h>
-#include <Miniball/Miniball.hpp>
+#include <gudhi/Miniball.hpp>
#include <boost/program_options.hpp>
@@ -55,7 +55,7 @@ class Cech_blocker {
using Point_cloud = std::vector<Point>;
using Point_iterator = Point_cloud::const_iterator;
using Coordinate_iterator = Point::const_iterator;
- using Min_sphere = Miniball::Miniball <Miniball::CoordAccessor<Point_iterator, Coordinate_iterator>>;
+ using Min_sphere = Gudhi::Miniball::Miniball <Gudhi::Miniball::CoordAccessor<Point_iterator, Coordinate_iterator>>;
public:
bool operator()(Simplex_handle sh) {
std::vector<Point> points;
diff --git a/src/Cech_complex/include/Miniball/Miniball.COPYRIGHT b/src/Cech_complex/include/gudhi/Miniball.COPYRIGHT
index dbe4c553..dbe4c553 100644
--- a/src/Cech_complex/include/Miniball/Miniball.COPYRIGHT
+++ b/src/Cech_complex/include/gudhi/Miniball.COPYRIGHT
diff --git a/src/Cech_complex/include/Miniball/Miniball.README b/src/Cech_complex/include/gudhi/Miniball.README
index 86a96f08..86a96f08 100644
--- a/src/Cech_complex/include/Miniball/Miniball.README
+++ b/src/Cech_complex/include/gudhi/Miniball.README
diff --git a/src/Cech_complex/include/Miniball/Miniball.hpp b/src/Cech_complex/include/gudhi/Miniball.hpp
index a42d62a7..ce6cbb5b 100644
--- a/src/Cech_complex/include/Miniball/Miniball.hpp
+++ b/src/Cech_complex/include/gudhi/Miniball.hpp
@@ -32,6 +32,8 @@
#include <ctime>
#include <limits>
+namespace Gudhi {
+
namespace Miniball {
// Global Functions
@@ -514,7 +516,8 @@ namespace Miniball {
return -min_l;
return nt0;
}
+} // namespace Miniball
-} // end Namespace Miniball
+} // namespace Gudhi
#endif // MINIBALL_HPP_
diff --git a/src/Cech_complex/test/test_cech_complex.cpp b/src/Cech_complex/test/test_cech_complex.cpp
index 8cbfe431..4aa85057 100644
--- a/src/Cech_complex/test/test_cech_complex.cpp
+++ b/src/Cech_complex/test/test_cech_complex.cpp
@@ -36,8 +36,7 @@
#include <gudhi/Simplex_tree.h>
#include <gudhi/distance_functions.h>
#include <gudhi/Unitary_tests_utils.h>
-
-#include <Miniball/Miniball.hpp>
+#include <gudhi/Miniball.hpp>
// Type definitions
using Simplex_tree = Gudhi::Simplex_tree<>;
@@ -49,7 +48,7 @@ using Cech_complex = Gudhi::cech_complex::Cech_complex<Simplex_tree, Point_cloud
using Point_iterator = Point_cloud::const_iterator;
using Coordinate_iterator = Point::const_iterator;
-using Min_sphere = Miniball::Miniball<Miniball::CoordAccessor<Point_iterator, Coordinate_iterator>>;
+using Min_sphere = Gudhi::Miniball::Miniball<Gudhi::Miniball::CoordAccessor<Point_iterator, Coordinate_iterator>>;
BOOST_AUTO_TEST_CASE(Cech_complex_for_documentation) {
// ----------------------------------------------------------------------------