summaryrefslogtreecommitdiff
path: root/src/Contraction/example/CMakeLists.txt
diff options
context:
space:
mode:
authorGard Spreemann <gspr@nonempty.org>2019-09-25 14:53:36 +0200
committerGard Spreemann <gspr@nonempty.org>2019-09-25 14:53:36 +0200
commit70ad5fc411b0e0a3d590ad281fc97d488994062b (patch)
treeb0ddd84d7ee935936787eee2b75f78f2e21c41f0 /src/Contraction/example/CMakeLists.txt
parentb50046e487ab42cdef19b02128a9f498d6a36482 (diff)
parent5ccee32ec2ba38743c6b96867db3e1b5151e45e4 (diff)
Merge branch 'dfsg/latest' into debian/sid
Diffstat (limited to 'src/Contraction/example/CMakeLists.txt')
-rw-r--r--src/Contraction/example/CMakeLists.txt17
1 files changed, 17 insertions, 0 deletions
diff --git a/src/Contraction/example/CMakeLists.txt b/src/Contraction/example/CMakeLists.txt
new file mode 100644
index 00000000..f0dc885d
--- /dev/null
+++ b/src/Contraction/example/CMakeLists.txt
@@ -0,0 +1,17 @@
+project(Contraction_examples)
+
+if (NOT CGAL_VERSION VERSION_LESS 4.11.0)
+ add_executable(RipsContraction Rips_contraction.cpp)
+
+ add_executable(GarlandHeckbert Garland_heckbert.cpp)
+ target_link_libraries(GarlandHeckbert ${Boost_TIMER_LIBRARY})
+
+ add_test(NAME Contraction_example_tore3D_0.2 COMMAND $<TARGET_FILE:RipsContraction>
+ "${CMAKE_SOURCE_DIR}/data/points/tore3D_1307.off" "0.2")
+ # TODO(DS) : These tests are too long under Windows
+ #add_test(NAME Contraction_example_sphere_0.2 COMMAND $<TARGET_FILE:RipsContraction>
+ # "${CMAKE_SOURCE_DIR}/data/points/sphere3D_2646.off" "0.2")
+ #add_test(NAME Contraction_example_SO3_0.3 COMMAND $<TARGET_FILE:RipsContraction>
+ # "${CMAKE_SOURCE_DIR}/data/points/SO3_10000.off" "0.3")
+
+endif (NOT CGAL_VERSION VERSION_LESS 4.11.0)