summaryrefslogtreecommitdiff
path: root/src/Contraction/example
diff options
context:
space:
mode:
authorvrouvrea <vrouvrea@636b058d-ea47-450e-bf9e-a15bfbe3eedb>2014-12-16 14:38:36 +0000
committervrouvrea <vrouvrea@636b058d-ea47-450e-bf9e-a15bfbe3eedb>2014-12-16 14:38:36 +0000
commite6078c1e4c7561f790afc653269cd3deca4c2350 (patch)
treee55ed929e8ad4d7c2be0e7bd8999878df3485d7c /src/Contraction/example
parent54c6bc50795f53ff1a1227c098f0d4fe84a8d885 (diff)
parent8e83a86b147987cc256812aff78335ac8a26c36e (diff)
Merge of cpplint branch
git-svn-id: svn+ssh://scm.gforge.inria.fr/svnroot/gudhi/trunk@357 636b058d-ea47-450e-bf9e-a15bfbe3eedb Former-commit-id: 8b6af51684401f4c45c953142aae90d6f45e6778
Diffstat (limited to 'src/Contraction/example')
-rw-r--r--src/Contraction/example/CMakeLists.txt5
1 files changed, 3 insertions, 2 deletions
diff --git a/src/Contraction/example/CMakeLists.txt b/src/Contraction/example/CMakeLists.txt
index 717830da..13eb5537 100644
--- a/src/Contraction/example/CMakeLists.txt
+++ b/src/Contraction/example/CMakeLists.txt
@@ -1,6 +1,7 @@
cmake_minimum_required(VERSION 2.6)
project(GUDHIskbl)
-add_executable ( RipsContraction Rips_contraction.cpp)
-target_link_libraries( RipsContraction ${Boost_TIMER_LIBRARY})
+add_executable(RipsContraction Rips_contraction.cpp)
+target_link_libraries(RipsContraction ${Boost_TIMER_LIBRARY} ${Boost_SYSTEM_LIBRARY})
+add_test(RipsContraction ${CMAKE_CURRENT_BINARY_DIR}/RipsContraction ${CMAKE_SOURCE_DIR}/data/meshes/sphere3D_2646.off 0.2)