summaryrefslogtreecommitdiff
path: root/src/Contraction
diff options
context:
space:
mode:
authorcjamin <cjamin@636b058d-ea47-450e-bf9e-a15bfbe3eedb>2017-05-31 16:48:08 +0000
committercjamin <cjamin@636b058d-ea47-450e-bf9e-a15bfbe3eedb>2017-05-31 16:48:08 +0000
commit14f55cf58e9be168e6be635ddafebc6c86cc7eea (patch)
treedbe47ed41dd833626280de54ecbde703accad666 /src/Contraction
parent5096889af20a04d25439ffbe5c37e663c11087bc (diff)
Convert more examples into utilities
git-svn-id: svn+ssh://scm.gforge.inria.fr/svnroot/gudhi/branches/add_utils_in_gudhi_v2@2494 636b058d-ea47-450e-bf9e-a15bfbe3eedb Former-commit-id: 54fa703f0489cba059a8df973738118f6a092f70
Diffstat (limited to 'src/Contraction')
-rw-r--r--src/Contraction/example/CMakeLists.txt5
-rw-r--r--src/Contraction/utilities/CMakeLists.txt7
-rw-r--r--src/Contraction/utilities/Garland_heckbert.cpp (renamed from src/Contraction/example/Garland_heckbert.cpp)0
-rw-r--r--src/Contraction/utilities/Garland_heckbert/Error_quadric.h (renamed from src/Contraction/example/Garland_heckbert/Error_quadric.h)0
4 files changed, 8 insertions, 4 deletions
diff --git a/src/Contraction/example/CMakeLists.txt b/src/Contraction/example/CMakeLists.txt
index b2b38dea..5cd32daf 100644
--- a/src/Contraction/example/CMakeLists.txt
+++ b/src/Contraction/example/CMakeLists.txt
@@ -3,10 +3,8 @@ project(Contraction_examples)
add_executable(RipsContraction Rips_contraction.cpp)
-add_executable(GarlandHeckbert Garland_heckbert.cpp)
-target_link_libraries(RipsContraction ${Boost_TIMER_LIBRARY} ${Boost_SYSTEM_LIBRARY})
-target_link_libraries(GarlandHeckbert ${Boost_TIMER_LIBRARY} ${Boost_SYSTEM_LIBRARY})
+target_link_libraries(RipsContraction ${Boost_TIMER_LIBRARY} ${Boost_SYSTEM_LIBRARY})
add_test(NAME Contraction_example_tore3D_0.2 COMMAND $<TARGET_FILE:RipsContraction>
@@ -18,4 +16,3 @@ add_test(NAME Contraction_example_tore3D_0.2 COMMAND $<TARGET_FILE:RipsContracti
# "${CMAKE_SOURCE_DIR}/data/points/SO3_10000.off" "0.3")
install(TARGETS RipsContraction DESTINATION bin)
-install(TARGETS GarlandHeckbert DESTINATION bin)
diff --git a/src/Contraction/utilities/CMakeLists.txt b/src/Contraction/utilities/CMakeLists.txt
new file mode 100644
index 00000000..77aa99d5
--- /dev/null
+++ b/src/Contraction/utilities/CMakeLists.txt
@@ -0,0 +1,7 @@
+cmake_minimum_required(VERSION 2.6)
+project(Contraction_utilities)
+
+add_executable(GarlandHeckbert Garland_heckbert.cpp)
+target_link_libraries(GarlandHeckbert ${Boost_TIMER_LIBRARY} ${Boost_SYSTEM_LIBRARY})
+
+install(TARGETS GarlandHeckbert DESTINATION bin)
diff --git a/src/Contraction/example/Garland_heckbert.cpp b/src/Contraction/utilities/Garland_heckbert.cpp
index 8b5a6a6c..8b5a6a6c 100644
--- a/src/Contraction/example/Garland_heckbert.cpp
+++ b/src/Contraction/utilities/Garland_heckbert.cpp
diff --git a/src/Contraction/example/Garland_heckbert/Error_quadric.h b/src/Contraction/utilities/Garland_heckbert/Error_quadric.h
index e7dafaa0..e7dafaa0 100644
--- a/src/Contraction/example/Garland_heckbert/Error_quadric.h
+++ b/src/Contraction/utilities/Garland_heckbert/Error_quadric.h