summaryrefslogtreecommitdiff
path: root/src/Contraction
diff options
context:
space:
mode:
authorcjamin <cjamin@636b058d-ea47-450e-bf9e-a15bfbe3eedb>2017-10-26 15:06:12 +0000
committercjamin <cjamin@636b058d-ea47-450e-bf9e-a15bfbe3eedb>2017-10-26 15:06:12 +0000
commita60c38b4738f8147b0f6fb0f27eaa55cf466e22f (patch)
tree22afcb701a3b5ae35c09a6af0747478b3d04e03b /src/Contraction
parent300914816e3e5d347efd9eaa5d06c236ad81511e (diff)
Cancel the move of Garland_heckbert.cpp & co
git-svn-id: svn+ssh://scm.gforge.inria.fr/svnroot/gudhi/branches/add_utils_in_gudhi_v2@2806 636b058d-ea47-450e-bf9e-a15bfbe3eedb Former-commit-id: a3df461085b25b301ea52fcdefecd8d17903e211
Diffstat (limited to 'src/Contraction')
-rw-r--r--src/Contraction/example/CMakeLists.txt5
-rw-r--r--src/Contraction/example/Garland_heckbert.cpp (renamed from src/Contraction/utilities/Garland_heckbert.cpp)0
-rw-r--r--src/Contraction/example/Garland_heckbert/Error_quadric.h (renamed from src/Contraction/utilities/Garland_heckbert/Error_quadric.h)0
-rw-r--r--src/Contraction/utilities/CMakeLists.txt7
4 files changed, 4 insertions, 8 deletions
diff --git a/src/Contraction/example/CMakeLists.txt b/src/Contraction/example/CMakeLists.txt
index f02949e4..a92d1685 100644
--- a/src/Contraction/example/CMakeLists.txt
+++ b/src/Contraction/example/CMakeLists.txt
@@ -1,9 +1,11 @@
cmake_minimum_required(VERSION 2.6)
project(Contraction_examples)
-
add_executable(RipsContraction Rips_contraction.cpp)
+add_executable(GarlandHeckbert Garland_heckbert.cpp)
+target_link_libraries(GarlandHeckbert ${Boost_TIMER_LIBRARY})
+
add_test(NAME Contraction_example_tore3D_0.2 COMMAND $<TARGET_FILE:RipsContraction>
"${CMAKE_SOURCE_DIR}/data/points/tore3D_1307.off" "0.2")
# TODO(DS) : These tests are too long under Windows
@@ -13,3 +15,4 @@ add_test(NAME Contraction_example_tore3D_0.2 COMMAND $<TARGET_FILE:RipsContracti
# "${CMAKE_SOURCE_DIR}/data/points/SO3_10000.off" "0.3")
install(TARGETS RipsContraction DESTINATION bin)
+install(TARGETS GarlandHeckbert DESTINATION bin)
diff --git a/src/Contraction/utilities/Garland_heckbert.cpp b/src/Contraction/example/Garland_heckbert.cpp
index 2b0dc973..2b0dc973 100644
--- a/src/Contraction/utilities/Garland_heckbert.cpp
+++ b/src/Contraction/example/Garland_heckbert.cpp
diff --git a/src/Contraction/utilities/Garland_heckbert/Error_quadric.h b/src/Contraction/example/Garland_heckbert/Error_quadric.h
index e7dafaa0..e7dafaa0 100644
--- a/src/Contraction/utilities/Garland_heckbert/Error_quadric.h
+++ b/src/Contraction/example/Garland_heckbert/Error_quadric.h
diff --git a/src/Contraction/utilities/CMakeLists.txt b/src/Contraction/utilities/CMakeLists.txt
deleted file mode 100644
index 36efd99a..00000000
--- a/src/Contraction/utilities/CMakeLists.txt
+++ /dev/null
@@ -1,7 +0,0 @@
-cmake_minimum_required(VERSION 2.6)
-project(Contraction_utilities)
-
-add_executable(GarlandHeckbert Garland_heckbert.cpp)
-target_link_libraries(GarlandHeckbert ${Boost_TIMER_LIBRARY})
-
-install(TARGETS GarlandHeckbert DESTINATION bin)