summaryrefslogtreecommitdiff
path: root/src/Contraction
diff options
context:
space:
mode:
authorcjamin <cjamin@636b058d-ea47-450e-bf9e-a15bfbe3eedb>2017-09-29 15:59:03 +0000
committercjamin <cjamin@636b058d-ea47-450e-bf9e-a15bfbe3eedb>2017-09-29 15:59:03 +0000
commitf45959484fb85299d9ac60c43de9325e5c06e730 (patch)
tree64055685e3e2d1b1bb8db82db57bd1c45d7657ea /src/Contraction
parent0a66874247cb6ab10a2d96e22ecd5009113291d2 (diff)
parent768c70aa382a7b0b561ea842720f5963a412b88e (diff)
Merge from trunk
git-svn-id: svn+ssh://scm.gforge.inria.fr/svnroot/gudhi/branches/add_utils_in_gudhi_v2@2732 636b058d-ea47-450e-bf9e-a15bfbe3eedb Former-commit-id: 7872aa224ee471c05e9213b81192d304254e608a
Diffstat (limited to 'src/Contraction')
-rw-r--r--src/Contraction/example/CMakeLists.txt3
-rw-r--r--src/Contraction/example/Rips_contraction.cpp7
-rw-r--r--src/Contraction/utilities/CMakeLists.txt1
3 files changed, 3 insertions, 8 deletions
diff --git a/src/Contraction/example/CMakeLists.txt b/src/Contraction/example/CMakeLists.txt
index 5cd32daf..f02949e4 100644
--- a/src/Contraction/example/CMakeLists.txt
+++ b/src/Contraction/example/CMakeLists.txt
@@ -4,9 +4,6 @@ project(Contraction_examples)
add_executable(RipsContraction Rips_contraction.cpp)
-target_link_libraries(RipsContraction ${Boost_TIMER_LIBRARY} ${Boost_SYSTEM_LIBRARY})
-
-
add_test(NAME Contraction_example_tore3D_0.2 COMMAND $<TARGET_FILE:RipsContraction>
"${CMAKE_SOURCE_DIR}/data/points/tore3D_1307.off" "0.2")
# TODO(DS) : These tests are too long under Windows
diff --git a/src/Contraction/example/Rips_contraction.cpp b/src/Contraction/example/Rips_contraction.cpp
index 8289b1d3..501b0e87 100644
--- a/src/Contraction/example/Rips_contraction.cpp
+++ b/src/Contraction/example/Rips_contraction.cpp
@@ -23,8 +23,8 @@
#include <gudhi/Skeleton_blocker.h>
#include <gudhi/Off_reader.h>
#include <gudhi/Point.h>
+#include <gudhi/Clock.h>
-#include <boost/timer/timer.hpp>
#include <iostream>
struct Geometry_trait {
@@ -68,7 +68,7 @@ int main(int argc, char *argv[]) {
build_rips(complex, atof(argv[2]));
- boost::timer::auto_cpu_timer t;
+ Gudhi::Clock contraction_chrono("Time to simplify and enumerate simplices");
std::cout << "Initial complex has " <<
complex.num_vertices() << " vertices and " <<
@@ -90,8 +90,7 @@ int main(int argc, char *argv[]) {
complex.num_blockers() << " blockers and " <<
num_simplices << " simplices" << std::endl;
-
- std::cout << "Time to simplify and enumerate simplices:\n";
+ std::cout << contraction_chrono;
return EXIT_SUCCESS;
}
diff --git a/src/Contraction/utilities/CMakeLists.txt b/src/Contraction/utilities/CMakeLists.txt
index 77aa99d5..a18783ef 100644
--- a/src/Contraction/utilities/CMakeLists.txt
+++ b/src/Contraction/utilities/CMakeLists.txt
@@ -2,6 +2,5 @@ cmake_minimum_required(VERSION 2.6)
project(Contraction_utilities)
add_executable(GarlandHeckbert Garland_heckbert.cpp)
-target_link_libraries(GarlandHeckbert ${Boost_TIMER_LIBRARY} ${Boost_SYSTEM_LIBRARY})
install(TARGETS GarlandHeckbert DESTINATION bin)