summaryrefslogtreecommitdiff
path: root/src/Nerve_GIC/example/CMakeLists.txt
diff options
context:
space:
mode:
authorGard Spreemann <gspr@nonempty.org>2019-09-25 14:53:36 +0200
committerGard Spreemann <gspr@nonempty.org>2019-09-25 14:53:36 +0200
commit70ad5fc411b0e0a3d590ad281fc97d488994062b (patch)
treeb0ddd84d7ee935936787eee2b75f78f2e21c41f0 /src/Nerve_GIC/example/CMakeLists.txt
parentb50046e487ab42cdef19b02128a9f498d6a36482 (diff)
parent5ccee32ec2ba38743c6b96867db3e1b5151e45e4 (diff)
Merge branch 'dfsg/latest' into debian/sid
Diffstat (limited to 'src/Nerve_GIC/example/CMakeLists.txt')
-rw-r--r--src/Nerve_GIC/example/CMakeLists.txt28
1 files changed, 28 insertions, 0 deletions
diff --git a/src/Nerve_GIC/example/CMakeLists.txt b/src/Nerve_GIC/example/CMakeLists.txt
new file mode 100644
index 00000000..1667472f
--- /dev/null
+++ b/src/Nerve_GIC/example/CMakeLists.txt
@@ -0,0 +1,28 @@
+project(Nerve_GIC_examples)
+
+if (NOT CGAL_VERSION VERSION_LESS 4.11.0)
+
+ add_executable ( CoordGIC CoordGIC.cpp )
+ add_executable ( FuncGIC FuncGIC.cpp )
+
+ if (TBB_FOUND)
+ target_link_libraries(CoordGIC ${TBB_LIBRARIES})
+ target_link_libraries(FuncGIC ${TBB_LIBRARIES})
+ endif()
+
+ # Copy files for not to pollute sources when testing
+ file(COPY "${CMAKE_SOURCE_DIR}/data/points/tore3D_1307.off" DESTINATION ${CMAKE_CURRENT_BINARY_DIR}/)
+ file(COPY "${CMAKE_SOURCE_DIR}/data/points/COIL_database/lucky_cat.off" DESTINATION ${CMAKE_CURRENT_BINARY_DIR}/)
+ file(COPY "${CMAKE_SOURCE_DIR}/data/points/COIL_database/lucky_cat_PCA1" DESTINATION ${CMAKE_CURRENT_BINARY_DIR}/)
+
+ add_test(NAME Nerve_GIC_example_CoordGIC COMMAND $<TARGET_FILE:CoordGIC>
+ "${CMAKE_CURRENT_BINARY_DIR}/tore3D_1307.off" "0")
+
+ add_test(NAME Nerve_GIC_example_FuncGIC COMMAND $<TARGET_FILE:FuncGIC>
+ "${CMAKE_CURRENT_BINARY_DIR}/lucky_cat.off"
+ "${CMAKE_CURRENT_BINARY_DIR}/lucky_cat_PCA1")
+
+ install(TARGETS CoordGIC DESTINATION bin)
+ install(TARGETS FuncGIC DESTINATION bin)
+
+endif (NOT CGAL_VERSION VERSION_LESS 4.11.0)