summaryrefslogtreecommitdiff
path: root/src/Nerve_GIC/example
diff options
context:
space:
mode:
authorvrouvrea <vrouvrea@636b058d-ea47-450e-bf9e-a15bfbe3eedb>2018-01-30 15:39:37 +0000
committervrouvrea <vrouvrea@636b058d-ea47-450e-bf9e-a15bfbe3eedb>2018-01-30 15:39:37 +0000
commit0fe356ae3a1071950382ab308b03fd4a647ae796 (patch)
tree6ed357f59e3713a3ed778a3a2946d1d470eb427d /src/Nerve_GIC/example
parentb92ea601f15a239957ec6beba78ee2deee3d32d6 (diff)
Copy test files in build directory for not to pollute sources
git-svn-id: svn+ssh://scm.gforge.inria.fr/svnroot/gudhi/trunk@3185 636b058d-ea47-450e-bf9e-a15bfbe3eedb Former-commit-id: 4926f0a4e3c02ce77bdbf5847d421b6152a24a65
Diffstat (limited to 'src/Nerve_GIC/example')
-rw-r--r--src/Nerve_GIC/example/CMakeLists.txt11
1 files changed, 8 insertions, 3 deletions
diff --git a/src/Nerve_GIC/example/CMakeLists.txt b/src/Nerve_GIC/example/CMakeLists.txt
index 434637fa..f2626927 100644
--- a/src/Nerve_GIC/example/CMakeLists.txt
+++ b/src/Nerve_GIC/example/CMakeLists.txt
@@ -11,11 +11,16 @@ if (NOT CGAL_VERSION VERSION_LESS 4.8.1)
target_link_libraries(FuncGIC ${TBB_LIBRARIES})
endif()
+ # Copy files for not to pollute sources when testing
+ file(COPY "${CMAKE_SOURCE_DIR}/data/points/tore3D_1307.off" DESTINATION ${CMAKE_CURRENT_BINARY_DIR}/)
+ file(COPY "${CMAKE_SOURCE_DIR}/data/points/COIL_database/lucky_cat.off" DESTINATION ${CMAKE_CURRENT_BINARY_DIR}/)
+ file(COPY "${CMAKE_SOURCE_DIR}/data/points/COIL_database/lucky_cat_PCA1" DESTINATION ${CMAKE_CURRENT_BINARY_DIR}/)
+
add_test(NAME Nerve_GIC_example_CoordGIC COMMAND $<TARGET_FILE:CoordGIC>
- "${CMAKE_SOURCE_DIR}/data/points/tore3D_1307.off" "0")
+ "tore3D_1307.off" "0")
add_test(NAME Nerve_GIC_example_FuncGIC COMMAND $<TARGET_FILE:FuncGIC>
- "${CMAKE_SOURCE_DIR}/data/points/COIL_database/lucky_cat.off"
- "${CMAKE_SOURCE_DIR}/data/points/COIL_database/lucky_cat_PCA1")
+ "lucky_cat.off"
+ "lucky_cat_PCA1")
endif (NOT CGAL_VERSION VERSION_LESS 4.8.1)