summaryrefslogtreecommitdiff
path: root/src/Nerve_GIC/example
diff options
context:
space:
mode:
authormcarrier <mcarrier@636b058d-ea47-450e-bf9e-a15bfbe3eedb>2017-01-30 16:33:22 +0000
committermcarrier <mcarrier@636b058d-ea47-450e-bf9e-a15bfbe3eedb>2017-01-30 16:33:22 +0000
commitab2e89665e16be2dcd36e55df8543d4ff5974675 (patch)
treea99233d22b7b01f08f714ccaa1e247a860f57e0c /src/Nerve_GIC/example
parent2541dd198e10ffebad5cff7c97b192199db38f88 (diff)
git-svn-id: svn+ssh://scm.gforge.inria.fr/svnroot/gudhi/branches/Nerve_GIC@2032 636b058d-ea47-450e-bf9e-a15bfbe3eedb
Former-commit-id: e8901f1be678dbc71b8e6e7b5666cc475b573b1a
Diffstat (limited to 'src/Nerve_GIC/example')
-rw-r--r--src/Nerve_GIC/example/CMakeLists.txt8
-rw-r--r--src/Nerve_GIC/example/simple_GIC.cpp36
2 files changed, 15 insertions, 29 deletions
diff --git a/src/Nerve_GIC/example/CMakeLists.txt b/src/Nerve_GIC/example/CMakeLists.txt
new file mode 100644
index 00000000..e4debf2d
--- /dev/null
+++ b/src/Nerve_GIC/example/CMakeLists.txt
@@ -0,0 +1,8 @@
+cmake_minimum_required(VERSION 2.6)
+project(Nerve_GIC_examples)
+
+add_executable ( GIC simple_GIC.cpp )
+target_link_libraries(GIC ${Boost_SYSTEM_LIBRARY})
+if (TBB_FOUND)
+ target_link_libraries(GIC ${TBB_LIBRARIES})
+endif() \ No newline at end of file
diff --git a/src/Nerve_GIC/example/simple_GIC.cpp b/src/Nerve_GIC/example/simple_GIC.cpp
index 33ebfcbb..d9297d04 100644
--- a/src/Nerve_GIC/example/simple_GIC.cpp
+++ b/src/Nerve_GIC/example/simple_GIC.cpp
@@ -1,18 +1,9 @@
-#include <gudhi/Rips_complex.h>
-// to construct Rips_complex from a OFF file of points
-#include <gudhi/Points_off_io.h>
-#include <gudhi/Simplex_tree.h>
-#include <gudhi/distance_functions.h>
#include <gudhi/GIC.h>
-#include <iostream>
-#include <string>
-#include <vector>
-
void usage(int nbArgs, char * const progName) {
std::cerr << "Error: Number of arguments (" << nbArgs << ") is not correct\n";
- std::cerr << "Usage: " << progName << " filename.off threshold dim_max [ouput_file.txt]\n";
- std::cerr << " i.e.: " << progName << " ../../data/points/alphacomplexdoc.off 60.0\n";
+ std::cerr << "Usage: " << progName << " filename.off threshold cover [ouput_file.txt]\n";
+ std::cerr << " i.e.: " << progName << " ../../data/points/test.off 1.5 test_cov \n";
exit(-1); // ----- >>
}
@@ -21,30 +12,20 @@ int main(int argc, char **argv) {
std::string off_file_name(argv[1]);
double threshold = atof(argv[2]);
- int dim_max = atoi(argv[3]);
+ std::string cover_file_name(argv[3]);
// Type definitions
- using Point = std::vector<float>;
- using Simplex_tree = Gudhi::Simplex_tree<>;
- using Filtration_value = Simplex_tree::Filtration_value;
- using Rips_complex = Gudhi::rips_complex::Rips_complex<Filtration_value>;
using Graph_t = boost::adjacency_list < boost::vecS, boost::vecS, boost::undirectedS,\
boost::property < vertex_filtration_t, Filtration_value >,\
boost::property < edge_filtration_t, Filtration_value > >;
- using Cover = std::map<int,int>;
// ----------------------------------------------------------------------------
// Init of a graph induced complex from an OFF file
// ----------------------------------------------------------------------------
- Gudhi::Points_off_reader<Point> off_reader(off_file_name);
- Rips_complex rips_complex_from_points(off_reader.get_point_cloud(), threshold, Euclidean_distance());
- Simplex_tree st;
- rips_complex_from_points.create_complex(st, 1);
- Cover C;
- Gudhi::graph_induced_complex::Graph_induced_complex GIC(st,C,dim_max);
- Simplex_tree stree;
- GIC.create_complex(stree);
+ Gudhi::graph_induced_complex::Graph_induced_complex GIC;
+ GIC.set_graph_simplex_tree(threshold, off_file_name); GIC.set_cover(cover_file_name); GIC.find_simplices();
+ Simplex_tree stree; GIC.create_complex(stree);
std::streambuf* streambufffer;
std::ofstream ouput_file_stream;
@@ -65,14 +46,11 @@ int main(int argc, char **argv) {
" - " << stree.num_simplices() << " simplices - " <<
stree.num_vertices() << " vertices." << std::endl;
- output_stream << "Iterator on graph induced complex simplices in the filtration order, with [filtration value]:" <<
- std::endl;
+ output_stream << "Iterator on graph induced complex simplices" << std::endl;
for (auto f_simplex : stree.filtration_simplex_range()) {
- output_stream << " ( ";
for (auto vertex : stree.simplex_vertex_range(f_simplex)) {
output_stream << vertex << " ";
}
- output_stream << ") -> " << "[" << stree.filtration(f_simplex) << "] ";
output_stream << std::endl;
}