summaryrefslogtreecommitdiff
path: root/src/Nerve_GIC/example
diff options
context:
space:
mode:
authormcarrier <mcarrier@636b058d-ea47-450e-bf9e-a15bfbe3eedb>2017-10-09 16:48:40 +0000
committermcarrier <mcarrier@636b058d-ea47-450e-bf9e-a15bfbe3eedb>2017-10-09 16:48:40 +0000
commitfe381d1ffe037028a9704966ec26d19894f4f5b1 (patch)
tree7365b91c1e4b40bcd10ef0cf9b1a4f20e8531653 /src/Nerve_GIC/example
parent304012f82e02a5727f604b2907070b4661a9ed18 (diff)
git-svn-id: svn+ssh://scm.gforge.inria.fr/svnroot/gudhi/branches/Nerve_GIC@2771 636b058d-ea47-450e-bf9e-a15bfbe3eedb
Former-commit-id: cd87a5b72b67d27b21f765fac822ea69f9496019
Diffstat (limited to 'src/Nerve_GIC/example')
-rw-r--r--src/Nerve_GIC/example/CMakeLists.txt24
-rw-r--r--src/Nerve_GIC/example/CoordGIC.cpp (renamed from src/Nerve_GIC/example/MapperDeltaCoord.cpp)26
-rw-r--r--src/Nerve_GIC/example/FuncGIC.cpp (renamed from src/Nerve_GIC/example/MapperDeltaFunc.cpp)26
-rw-r--r--src/Nerve_GIC/example/GIC.cpp4
-rw-r--r--src/Nerve_GIC/example/Nerve.cpp7
-rw-r--r--src/Nerve_GIC/example/VoronoiGIC.cpp (renamed from src/Nerve_GIC/example/GICvoronoi.cpp)5
6 files changed, 45 insertions, 47 deletions
diff --git a/src/Nerve_GIC/example/CMakeLists.txt b/src/Nerve_GIC/example/CMakeLists.txt
index ea504c11..871e46a6 100644
--- a/src/Nerve_GIC/example/CMakeLists.txt
+++ b/src/Nerve_GIC/example/CMakeLists.txt
@@ -4,24 +4,20 @@ project(Nerve_GIC_examples)
add_executable ( Nerve Nerve.cpp )
target_link_libraries(Nerve ${Boost_SYSTEM_LIBRARY})
-add_executable ( GIC GIC.cpp )
-target_link_libraries(GIC ${Boost_SYSTEM_LIBRARY})
+add_executable ( CoordGIC CoordGIC.cpp )
+target_link_libraries(CoordGIC ${Boost_SYSTEM_LIBRARY})
-add_executable ( MapperDeltaCoord MapperDeltaCoord.cpp )
-target_link_libraries(MapperDeltaCoord ${Boost_SYSTEM_LIBRARY})
+add_executable ( FuncGIC FuncGIC.cpp )
+target_link_libraries(FuncGIC ${Boost_SYSTEM_LIBRARY})
-add_executable ( MapperDeltaFunc MapperDeltaFunc.cpp )
-target_link_libraries(MapperDeltaFunc ${Boost_SYSTEM_LIBRARY})
+add_executable ( VoronoiGIC VoronoiGIC.cpp )
+target_link_libraries(VoronoiGIC ${Boost_SYSTEM_LIBRARY})
-add_executable ( GICvoronoi GICvoronoi.cpp )
-target_link_libraries(MapperDeltaFunc ${Boost_SYSTEM_LIBRARY})
-
-file(COPY KeplerMapperVisuFromTxtFile.py km.py DESTINATION ${CMAKE_CURRENT_BINARY_DIR}/)
+#[[file(COPY KeplerMapperVisuFromTxtFile.py km.py DESTINATION ${CMAKE_CURRENT_BINARY_DIR}/)]]
if (TBB_FOUND)
target_link_libraries(Nerve ${TBB_LIBRARIES})
- target_link_libraries(GIC ${TBB_LIBRARIES})
- target_link_libraries(MapperDeltaCoord ${TBB_LIBRARIES})
- target_link_libraries(MapperDeltaFunc ${TBB_LIBRARIES})
- target_link_libraries(GICvoronoi ${TBB_LIBRARIES})
+ target_link_libraries(CoordGIC ${TBB_LIBRARIES})
+ target_link_libraries(FuncGIC ${TBB_LIBRARIES})
+ target_link_libraries(VoronoiGIC ${TBB_LIBRARIES})
endif() \ No newline at end of file
diff --git a/src/Nerve_GIC/example/MapperDeltaCoord.cpp b/src/Nerve_GIC/example/CoordGIC.cpp
index 382649e8..89b0f9a4 100644
--- a/src/Nerve_GIC/example/MapperDeltaCoord.cpp
+++ b/src/Nerve_GIC/example/CoordGIC.cpp
@@ -38,12 +38,12 @@ int main(int argc, char **argv) {
int coord = atoi(argv[2]);
bool verb = 0; if(argc == 4) verb = 1;
- // ---------------------------------------
- // Init of a Mapper Delta from an OFF file
- // ---------------------------------------
+ // -----------------------------------------
+ // Init of a functional GIC from an OFF file
+ // -----------------------------------------
Gudhi::graph_induced_complex::Graph_induced_complex<Point> GIC;
- GIC.set_verbose(verb); GIC.set_mask(); GIC.set_subsampling();
+ GIC.set_verbose(verb);
bool check = GIC.read_point_cloud(off_file_name);
@@ -55,25 +55,25 @@ int main(int argc, char **argv) {
GIC.set_graph_from_automatic_rips(Gudhi::Euclidean_distance());
- GIC.set_automatic_resolution_for_GICMAP(); GIC.set_gain();
+ GIC.set_automatic_resolution_for_GIC(); GIC.set_gain();
GIC.set_cover_from_function();
- GIC.find_GICMAP_simplices_with_functional_minimal_cover();
+ GIC.find_GIC_simplices_with_functional_minimal_cover();
- GIC.plot_DOT_for_neato();
+ GIC.plot_DOT();
- Gudhi::graph_induced_complex::Simplex_tree stree; GIC.create_complex(stree);
+ Gudhi::Simplex_tree<> stree; GIC.create_complex(stree);
- // ------------------------------------------
- // Display information about the Mapper Delta
- // ------------------------------------------
+ // --------------------------------------------
+ // Display information about the functional GIC
+ // --------------------------------------------
if(verb){
- std::cout << "Mapper Delta is of dimension " << stree.dimension() <<
+ std::cout << "Functional GIC is of dimension " << stree.dimension() <<
" - " << stree.num_simplices() << " simplices - " <<
stree.num_vertices() << " vertices." << std::endl;
- std::cout << "Iterator on Mapper Delta simplices" << std::endl;
+ std::cout << "Iterator on functional GIC simplices" << std::endl;
for (auto f_simplex : stree.filtration_simplex_range()) {
for (auto vertex : stree.simplex_vertex_range(f_simplex)) {
std::cout << vertex << " ";
diff --git a/src/Nerve_GIC/example/MapperDeltaFunc.cpp b/src/Nerve_GIC/example/FuncGIC.cpp
index 586b733c..56c97b7f 100644
--- a/src/Nerve_GIC/example/MapperDeltaFunc.cpp
+++ b/src/Nerve_GIC/example/FuncGIC.cpp
@@ -38,12 +38,12 @@ int main(int argc, char **argv) {
std::string func_file_name = argv[2];
bool verb = 0; if(argc == 4) verb = 1;
- // ---------------------------------------
- // Init of a Mapper Delta from an OFF file
- // ---------------------------------------
+ // -----------------------------------------
+ // Init of a functional GIC from an OFF file
+ // -----------------------------------------
Gudhi::graph_induced_complex::Graph_induced_complex<Point> GIC;
- GIC.set_verbose(verb); GIC.set_mask(); GIC.set_subsampling();
+ GIC.set_verbose(verb);
bool check = GIC.read_point_cloud(off_file_name);
@@ -55,25 +55,25 @@ int main(int argc, char **argv) {
GIC.set_graph_from_automatic_rips(Gudhi::Euclidean_distance());
- GIC.set_automatic_resolution_for_GICMAP(); GIC.set_gain();
+ GIC.set_automatic_resolution_for_GIC(); GIC.set_gain();
GIC.set_cover_from_function();
- GIC.find_GICMAP_simplices_with_functional_minimal_cover();
+ GIC.find_GIC_simplices_with_functional_minimal_cover();
- GIC.plot_DOT_for_neato();
+ GIC.plot_DOT();
- Gudhi::graph_induced_complex::Simplex_tree stree; GIC.create_complex(stree);
+ Gudhi::Simplex_tree<> stree; GIC.create_complex(stree);
- // ------------------------------------------
- // Display information about the Mapper Delta
- // ------------------------------------------
+ // --------------------------------------------
+ // Display information about the functional GIC
+ // --------------------------------------------
if(verb){
- std::cout << "Mapper Delta is of dimension " << stree.dimension() <<
+ std::cout << "Functional GIC is of dimension " << stree.dimension() <<
" - " << stree.num_simplices() << " simplices - " <<
stree.num_vertices() << " vertices." << std::endl;
- std::cout << "Iterator on Mapper Delta simplices" << std::endl;
+ std::cout << "Iterator on functional GIC simplices" << std::endl;
for (auto f_simplex : stree.filtration_simplex_range()) {
for (auto vertex : stree.simplex_vertex_range(f_simplex)) {
std::cout << vertex << " ";
diff --git a/src/Nerve_GIC/example/GIC.cpp b/src/Nerve_GIC/example/GIC.cpp
index 6e5c5ca7..b8b5cd05 100644
--- a/src/Nerve_GIC/example/GIC.cpp
+++ b/src/Nerve_GIC/example/GIC.cpp
@@ -46,7 +46,7 @@ int main(int argc, char **argv) {
// ----------------------------------------------------------------------------
Gudhi::graph_induced_complex::Graph_induced_complex<Point> GIC;
- GIC.set_verbose(verb); GIC.set_mask();
+ GIC.set_verbose(verb);
bool check = GIC.read_point_cloud(off_file_name);
@@ -65,7 +65,7 @@ int main(int argc, char **argv) {
GIC.plot_TXT_for_KeplerMapper();
- Gudhi::graph_induced_complex::Simplex_tree stree; GIC.create_complex(stree);
+ Gudhi::Simplex_tree<> stree; GIC.create_complex(stree);
// ----------------------------------------------------------------------------
// Display information about the graph induced complex
diff --git a/src/Nerve_GIC/example/Nerve.cpp b/src/Nerve_GIC/example/Nerve.cpp
index e47982c4..e863b48b 100644
--- a/src/Nerve_GIC/example/Nerve.cpp
+++ b/src/Nerve_GIC/example/Nerve.cpp
@@ -39,13 +39,14 @@ int main(int argc, char **argv) {
int resolution = atoi(argv[3]);
double gain = atof(argv[4]);
bool verb = 0; if(argc == 6) verb = 1;
+ //int mask = 0;
// --------------------------------
// Init of a Nerve from an OFF file
// --------------------------------
Gudhi::graph_induced_complex::Graph_induced_complex<Point> GIC;
- GIC.set_verbose(verb); GIC.set_mask();
+ GIC.set_verbose(verb);
bool check = GIC.read_point_cloud(off_file_name);
@@ -62,9 +63,9 @@ int main(int argc, char **argv) {
GIC.find_Nerve_simplices();
- GIC.plot_TXT_for_KeplerMapper();
+ GIC.plot_TXT();
- Gudhi::graph_induced_complex::Simplex_tree stree; GIC.create_complex(stree);
+ Gudhi::Simplex_tree<> stree; GIC.create_complex(stree);
// ----------------------------------------------------------------------------
// Display information about the graph induced complex
diff --git a/src/Nerve_GIC/example/GICvoronoi.cpp b/src/Nerve_GIC/example/VoronoiGIC.cpp
index 2c4f5acf..f000c263 100644
--- a/src/Nerve_GIC/example/GICvoronoi.cpp
+++ b/src/Nerve_GIC/example/VoronoiGIC.cpp
@@ -37,13 +37,14 @@ int main(int argc, char **argv) {
std::string off_file_name(argv[1]);
int m = atoi(argv[2]);
bool verb = 0; if(argc == 4) verb = 1;
+ //int mask = 0;
// ----------------------------------------------------------------------------
// Init of a graph induced complex from an OFF file
// ----------------------------------------------------------------------------
Gudhi::graph_induced_complex::Graph_induced_complex<Point> GIC;
- GIC.set_verbose(verb); GIC.set_mask();
+ GIC.set_verbose(verb);
bool check = GIC.read_point_cloud(off_file_name);
@@ -60,7 +61,7 @@ int main(int argc, char **argv) {
GIC.plot_OFF();
- Gudhi::graph_induced_complex::Simplex_tree stree; GIC.create_complex(stree);
+ Gudhi::Simplex_tree<> stree; GIC.create_complex(stree);
// ----------------------------------------------------------------------------
// Display information about the graph induced complex