summaryrefslogtreecommitdiff
path: root/src/Nerve_GIC/utilities
diff options
context:
space:
mode:
authorvrouvrea <vrouvrea@636b058d-ea47-450e-bf9e-a15bfbe3eedb>2018-01-30 15:39:37 +0000
committervrouvrea <vrouvrea@636b058d-ea47-450e-bf9e-a15bfbe3eedb>2018-01-30 15:39:37 +0000
commit0fe356ae3a1071950382ab308b03fd4a647ae796 (patch)
tree6ed357f59e3713a3ed778a3a2946d1d470eb427d /src/Nerve_GIC/utilities
parentb92ea601f15a239957ec6beba78ee2deee3d32d6 (diff)
Copy test files in build directory for not to pollute sources
git-svn-id: svn+ssh://scm.gforge.inria.fr/svnroot/gudhi/trunk@3185 636b058d-ea47-450e-bf9e-a15bfbe3eedb Former-commit-id: 4926f0a4e3c02ce77bdbf5847d421b6152a24a65
Diffstat (limited to 'src/Nerve_GIC/utilities')
-rw-r--r--src/Nerve_GIC/utilities/CMakeLists.txt6
1 files changed, 4 insertions, 2 deletions
diff --git a/src/Nerve_GIC/utilities/CMakeLists.txt b/src/Nerve_GIC/utilities/CMakeLists.txt
index a0508dc2..7762c8a0 100644
--- a/src/Nerve_GIC/utilities/CMakeLists.txt
+++ b/src/Nerve_GIC/utilities/CMakeLists.txt
@@ -12,11 +12,13 @@ if (NOT CGAL_VERSION VERSION_LESS 4.8.1)
endif()
file(COPY KeplerMapperVisuFromTxtFile.py km.py DESTINATION ${CMAKE_CURRENT_BINARY_DIR}/)
+ # Copy files for not to pollute sources when testing
+ file(COPY "${CMAKE_SOURCE_DIR}/data/points/human.off" DESTINATION ${CMAKE_CURRENT_BINARY_DIR}/)
add_test(NAME Nerve_GIC_utilities_nerve COMMAND $<TARGET_FILE:Nerve>
- "${CMAKE_SOURCE_DIR}/data/points/human.off" "2" "10" "0.3")
+ "human.off" "2" "10" "0.3")
add_test(NAME Nerve_GIC_utilities_VoronoiGIC COMMAND $<TARGET_FILE:VoronoiGIC>
- "${CMAKE_SOURCE_DIR}/data/points/human.off" "100")
+ "human.off" "100")
endif (NOT CGAL_VERSION VERSION_LESS 4.8.1)