summaryrefslogtreecommitdiff
path: root/src/Persistence_representations/example/CMakeLists.txt
diff options
context:
space:
mode:
authorvrouvrea <vrouvrea@636b058d-ea47-450e-bf9e-a15bfbe3eedb>2017-06-06 11:15:17 +0000
committervrouvrea <vrouvrea@636b058d-ea47-450e-bf9e-a15bfbe3eedb>2017-06-06 11:15:17 +0000
commit82e2f453feae8011a529b0e932a7c2a2f6472f9d (patch)
treee1b3a2d7bb20f92e0580c2c378491a984e867241 /src/Persistence_representations/example/CMakeLists.txt
parent1233fc448dd35f4f29cf7dfff811f7b2a805d2aa (diff)
Make build out of source
git-svn-id: svn+ssh://scm.gforge.inria.fr/svnroot/gudhi/branches/persistence_representation_integration@2513 636b058d-ea47-450e-bf9e-a15bfbe3eedb Former-commit-id: 7b6b18858d5e71613c4c15c4c262b4c4b5a6ac8e
Diffstat (limited to 'src/Persistence_representations/example/CMakeLists.txt')
-rw-r--r--src/Persistence_representations/example/CMakeLists.txt48
1 files changed, 27 insertions, 21 deletions
diff --git a/src/Persistence_representations/example/CMakeLists.txt b/src/Persistence_representations/example/CMakeLists.txt
index 3357017a..7788b603 100644
--- a/src/Persistence_representations/example/CMakeLists.txt
+++ b/src/Persistence_representations/example/CMakeLists.txt
@@ -1,27 +1,33 @@
cmake_minimum_required(VERSION 2.6)
project(Persistence_representations_example)
-file(COPY "simple_diagram.txt" DESTINATION ${CMAKE_CURRENT_BINARY_DIR}/)
-
-add_executable ( persistence_landscape_on_grid persistence_landscape_on_grid.cpp )
-target_link_libraries(persistence_landscape_on_grid ${Boost_SYSTEM_LIBRARY})
-add_test ( persistence_landscape_on_grid ${CMAKE_CURRENT_BINARY_DIR}/persistence_landscape_on_grid )
-
-add_executable ( persistence_landscape persistence_landscape.cpp )
-target_link_libraries(persistence_landscape ${Boost_SYSTEM_LIBRARY})
-add_test ( persistence_landscape ${CMAKE_CURRENT_BINARY_DIR}/persistence_landscape )
-
-add_executable ( persistence_intervals persistence_intervals.cpp )
-target_link_libraries(persistence_intervals ${Boost_SYSTEM_LIBRARY})
-add_test ( persistence_intervals ${CMAKE_CURRENT_BINARY_DIR}/persistence_intervals simple_diagram.txt )
-
-add_executable ( persistence_vectors persistence_vectors.cpp )
-target_link_libraries(persistence_vectors ${Boost_SYSTEM_LIBRARY})
-add_test ( persistence_vectors ${CMAKE_CURRENT_BINARY_DIR}/persistence_vectors )
-
-add_executable ( persistence_heat_maps persistence_heat_maps.cpp )
-target_link_libraries(persistence_heat_maps ${Boost_SYSTEM_LIBRARY})
-add_test ( persistence_heat_maps ${CMAKE_CURRENT_BINARY_DIR}/persistence_heat_maps )
+file(COPY "${CMAKE_SOURCE_DIR}/data/persistence_diagram/simple_diagram.txt" DESTINATION "${CMAKE_CURRENT_BINARY_DIR}/")
+
+add_executable ( Persistence_representations_example_landscape_on_grid persistence_landscape_on_grid.cpp )
+target_link_libraries(Persistence_representations_example_landscape_on_grid ${Boost_SYSTEM_LIBRARY})
+add_test(NAME Persistence_representations_example_landscape_on_grid
+ COMMAND $<TARGET_FILE:Persistence_representations_example_landscape_on_grid>)
+
+add_executable ( Persistence_representations_example_landscape persistence_landscape.cpp )
+target_link_libraries(Persistence_representations_example_landscape ${Boost_SYSTEM_LIBRARY})
+add_test(NAME Persistence_representations_example_landscape
+ COMMAND $<TARGET_FILE:Persistence_representations_example_landscape>)
+
+add_executable ( Persistence_representations_example_intervals persistence_intervals.cpp )
+target_link_libraries(Persistence_representations_example_intervals ${Boost_SYSTEM_LIBRARY})
+add_test(NAME Persistence_representations_example_intervals
+ COMMAND $<TARGET_FILE:Persistence_representations_example_intervals>
+ "${CMAKE_CURRENT_BINARY_DIR}/simple_diagram.txt")
+
+add_executable ( Persistence_representations_example_vectors persistence_vectors.cpp )
+target_link_libraries(Persistence_representations_example_vectors ${Boost_SYSTEM_LIBRARY})
+add_test(NAME Persistence_representations_example_vectors
+ COMMAND $<TARGET_FILE:Persistence_representations_example_vectors>)
+
+add_executable ( Persistence_representations_example_heat_maps persistence_heat_maps.cpp )
+target_link_libraries(Persistence_representations_example_heat_maps ${Boost_SYSTEM_LIBRARY})
+add_test(NAME Persistence_representations_example_heat_maps
+ COMMAND $<TARGET_FILE:Persistence_representations_example_heat_maps>)