summaryrefslogtreecommitdiff
path: root/src/Persistence_representations/example
diff options
context:
space:
mode:
authormcarrier <mcarrier@636b058d-ea47-450e-bf9e-a15bfbe3eedb>2018-05-10 05:52:21 +0000
committermcarrier <mcarrier@636b058d-ea47-450e-bf9e-a15bfbe3eedb>2018-05-10 05:52:21 +0000
commite778857da09c25ed351b5e77dcba319ce44fdb7f (patch)
tree79834c6e9e2868196cc00611f7d720120dd21bea /src/Persistence_representations/example
parenta0e9b3eb318c9ec708a396ce14af947c4eb6229e (diff)
added betti sequences
git-svn-id: svn+ssh://scm.gforge.inria.fr/svnroot/gudhi/branches/kernels@3431 636b058d-ea47-450e-bf9e-a15bfbe3eedb Former-commit-id: 4680471ce781468c247c40fb5e6eb699dce890c8
Diffstat (limited to 'src/Persistence_representations/example')
-rw-r--r--src/Persistence_representations/example/CMakeLists.txt5
-rw-r--r--src/Persistence_representations/example/betti_sequence.cpp49
-rw-r--r--src/Persistence_representations/example/persistence_landscape_on_grid_exact.cpp4
3 files changed, 56 insertions, 2 deletions
diff --git a/src/Persistence_representations/example/CMakeLists.txt b/src/Persistence_representations/example/CMakeLists.txt
index 3142f19b..9be22085 100644
--- a/src/Persistence_representations/example/CMakeLists.txt
+++ b/src/Persistence_representations/example/CMakeLists.txt
@@ -46,3 +46,8 @@ add_executable ( Persistence_landscape_on_grid_exact persistence_landscape_on_gr
add_test(NAME Persistence_landscape_on_grid_exact
COMMAND $<TARGET_FILE:Persistence_landscape_on_grid_exact>)
install(TARGETS Persistence_landscape_on_grid_exact DESTINATION bin)
+
+add_executable ( Betti_sequence betti_sequence.cpp )
+add_test(NAME Betti_sequence
+ COMMAND $<TARGET_FILE:Betti_sequence>)
+install(TARGETS Betti_sequence DESTINATION bin)
diff --git a/src/Persistence_representations/example/betti_sequence.cpp b/src/Persistence_representations/example/betti_sequence.cpp
new file mode 100644
index 00000000..a422a822
--- /dev/null
+++ b/src/Persistence_representations/example/betti_sequence.cpp
@@ -0,0 +1,49 @@
+/* This file is part of the Gudhi Library. The Gudhi library
+ * (Geometric Understanding in Higher Dimensions) is a generic C++
+ * library for computational topology.
+ *
+ * Author(s): Mathieu Carriere
+ *
+ * Copyright (C) 2018 INRIA (France)
+ *
+ * This program is free software: you can redistribute it and/or modify
+ * it under the terms of the GNU General Public License as published by
+ * the Free Software Foundation, either version 3 of the License, or
+ * (at your option) any later version.
+ *
+ * This program is distributed in the hope that it will be useful,
+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ * GNU General Public License for more details.
+ *
+ * You should have received a copy of the GNU General Public License
+ * along with this program. If not, see <http://www.gnu.org/licenses/>.
+ */
+
+#include <gudhi/Betti_sequence.h>
+
+#include <iostream>
+#include <vector>
+#include <utility>
+
+using Persistence_diagram = Gudhi::Persistence_representations::Persistence_diagram;
+using BS = Gudhi::Persistence_representations::Betti_sequence;
+
+int main(int argc, char** argv) {
+
+ Persistence_diagram persistence;
+
+ persistence.push_back(std::make_pair(1, 2));
+ persistence.push_back(std::make_pair(6, 8));
+ persistence.push_back(std::make_pair(0, 4));
+ persistence.push_back(std::make_pair(3, 8));
+
+ double min_x = 0; double max_x = 8; int res_x = 1000;
+
+ BS bs(persistence, min_x, max_x, res_x);
+ std::vector<int> B = bs.vectorize();
+
+ for(int i = 0; i < res_x; i++) std::cout << B[i] << ", ";
+
+ return 0;
+}
diff --git a/src/Persistence_representations/example/persistence_landscape_on_grid_exact.cpp b/src/Persistence_representations/example/persistence_landscape_on_grid_exact.cpp
index da27bc5a..9ce42649 100644
--- a/src/Persistence_representations/example/persistence_landscape_on_grid_exact.cpp
+++ b/src/Persistence_representations/example/persistence_landscape_on_grid_exact.cpp
@@ -38,13 +38,13 @@ int main(int argc, char** argv) {
persistence.push_back(std::make_pair(0, 4));
persistence.push_back(std::make_pair(3, 8));
- int nb_ls = 3; double min_x = 0.0; double max_x = 10.0; int res_x = 100;
+ int nb_ls = 2; double min_x = 0; double max_x = 8; int res_x = 1000;
LS ls(persistence, nb_ls, min_x, max_x, res_x);
std::vector<std::vector<double> > L = ls.vectorize();
for(int i = 0; i < nb_ls; i++){
- for(int j = 0; j < res_x; j++) std::cout << L[i][j] << " ";
+ for(int j = 0; j < res_x; j++) std::cout << L[i][j] << ", ";
std::cout << std::endl;
}