summaryrefslogtreecommitdiff
path: root/src/Persistence_representations/test/CMakeLists.txt
diff options
context:
space:
mode:
authorVincent Rouvreau <10407034+VincentRouvreau@users.noreply.github.com>2019-07-01 17:32:10 +0200
committerGitHub <noreply@github.com>2019-07-01 17:32:10 +0200
commit00b9f30933134dbc8c5a90373308e4993a0e2871 (patch)
tree0da27b8d7cc6dd805201823bf15d685438153dad /src/Persistence_representations/test/CMakeLists.txt
parente9e875a4ec84b7ca28b350f8cd0b9024246b00e2 (diff)
parent4d8dc4477942d196a304e71db4918ac71862e597 (diff)
Merge pull request #76 from VincentRouvreau/gpl_to_mit
Gpl to mit
Diffstat (limited to 'src/Persistence_representations/test/CMakeLists.txt')
-rw-r--r--src/Persistence_representations/test/CMakeLists.txt16
1 files changed, 8 insertions, 8 deletions
diff --git a/src/Persistence_representations/test/CMakeLists.txt b/src/Persistence_representations/test/CMakeLists.txt
index fb650485..a95880c9 100644
--- a/src/Persistence_representations/test/CMakeLists.txt
+++ b/src/Persistence_representations/test/CMakeLists.txt
@@ -39,14 +39,14 @@ target_link_libraries(kernels_unit ${Boost_UNIT_TEST_FRAMEWORK_LIBRARY})
gudhi_add_coverage_test(kernels_unit)
-if (NOT CGAL_WITH_EIGEN3_VERSION VERSION_LESS 4.8.1)
- add_executable (Persistence_intervals_with_distances_test_unit persistence_intervals_with_distances_test.cpp )
- target_link_libraries(Persistence_intervals_with_distances_test_unit ${Boost_UNIT_TEST_FRAMEWORK_LIBRARY})
- if (TBB_FOUND)
- target_link_libraries(Persistence_intervals_with_distances_test_unit ${TBB_LIBRARIES})
- endif(TBB_FOUND)
- gudhi_add_coverage_test(Persistence_intervals_with_distances_test_unit)
-endif (NOT CGAL_WITH_EIGEN3_VERSION VERSION_LESS 4.8.1)
+if (NOT CGAL_WITH_EIGEN3_VERSION VERSION_LESS 4.11.0)
+ add_executable (Persistence_intervals_with_distances_test_unit persistence_intervals_with_distances_test.cpp )
+ target_link_libraries(Persistence_intervals_with_distances_test_unit ${Boost_UNIT_TEST_FRAMEWORK_LIBRARY})
+ if (TBB_FOUND)
+ target_link_libraries(Persistence_intervals_with_distances_test_unit ${TBB_LIBRARIES})
+ endif(TBB_FOUND)
+ gudhi_add_coverage_test(Persistence_intervals_with_distances_test_unit)
+endif (NOT CGAL_WITH_EIGEN3_VERSION VERSION_LESS 4.11.0)