summaryrefslogtreecommitdiff
path: root/src/Persistence_representations/utilities/persistence_intervals/CMakeLists.txt
diff options
context:
space:
mode:
authorGard Spreemann <gspr@nonempty.org>2019-09-25 14:53:36 +0200
committerGard Spreemann <gspr@nonempty.org>2019-09-25 14:53:36 +0200
commit70ad5fc411b0e0a3d590ad281fc97d488994062b (patch)
treeb0ddd84d7ee935936787eee2b75f78f2e21c41f0 /src/Persistence_representations/utilities/persistence_intervals/CMakeLists.txt
parentb50046e487ab42cdef19b02128a9f498d6a36482 (diff)
parent5ccee32ec2ba38743c6b96867db3e1b5151e45e4 (diff)
Merge branch 'dfsg/latest' into debian/sid
Diffstat (limited to 'src/Persistence_representations/utilities/persistence_intervals/CMakeLists.txt')
-rw-r--r--src/Persistence_representations/utilities/persistence_intervals/CMakeLists.txt37
1 files changed, 37 insertions, 0 deletions
diff --git a/src/Persistence_representations/utilities/persistence_intervals/CMakeLists.txt b/src/Persistence_representations/utilities/persistence_intervals/CMakeLists.txt
new file mode 100644
index 00000000..a025183e
--- /dev/null
+++ b/src/Persistence_representations/utilities/persistence_intervals/CMakeLists.txt
@@ -0,0 +1,37 @@
+project(Persistence_representations_intervals_utilities)
+
+
+add_executable ( plot_histogram_of_intervals_lengths plot_histogram_of_intervals_lengths.cpp )
+
+add_test(NAME plot_histogram_of_intervals_lengths COMMAND $<TARGET_FILE:plot_histogram_of_intervals_lengths>
+ "${CMAKE_CURRENT_BINARY_DIR}/../first.pers" "-1")
+
+install(TARGETS plot_histogram_of_intervals_lengths DESTINATION bin)
+
+add_persistence_representation_plot_utility(plot_persistence_intervals "")
+add_persistence_representation_plot_utility(plot_persistence_Betti_numbers "")
+
+add_persistence_representation_creation_utility(compute_birth_death_range_in_persistence_diagram "-1")
+
+
+add_executable ( compute_number_of_dominant_intervals compute_number_of_dominant_intervals.cpp )
+add_test(NAME Persistence_representation_utilities_compute_number_of_dominant_intervals
+ COMMAND $<TARGET_FILE:compute_number_of_dominant_intervals>
+ "${CMAKE_CURRENT_BINARY_DIR}/../first.pers" "-1" "2")
+
+install(TARGETS compute_number_of_dominant_intervals DESTINATION bin)
+
+
+if (NOT CGAL_WITH_EIGEN3_VERSION VERSION_LESS 4.11.0)
+ add_executable ( compute_bottleneck_distance compute_bottleneck_distance.cpp )
+ if (TBB_FOUND)
+ target_link_libraries(compute_bottleneck_distance ${TBB_LIBRARIES})
+ endif(TBB_FOUND)
+ add_test(NAME Persistence_representation_utilities_compute_bottleneck_distance
+ COMMAND $<TARGET_FILE:compute_bottleneck_distance>
+ "-1"
+ "${CMAKE_CURRENT_BINARY_DIR}/../first.pers"
+ "${CMAKE_CURRENT_BINARY_DIR}/../second.pers")
+
+ install(TARGETS compute_bottleneck_distance DESTINATION bin)
+endif (NOT CGAL_WITH_EIGEN3_VERSION VERSION_LESS 4.11.0)