summaryrefslogtreecommitdiff
path: root/src/Persistence_representations/utilities/persistence_vectors
diff options
context:
space:
mode:
authorvrouvrea <vrouvrea@636b058d-ea47-450e-bf9e-a15bfbe3eedb>2017-05-30 11:14:43 +0000
committervrouvrea <vrouvrea@636b058d-ea47-450e-bf9e-a15bfbe3eedb>2017-05-30 11:14:43 +0000
commit5de02a8e89ce7905281a0ef6d40f82ef04d426d6 (patch)
tree71fe2871fc6b73fb67c3fae0156ff4d470e0c8eb /src/Persistence_representations/utilities/persistence_vectors
parentf9b84f79232ec2fa5935327e38e2862d9c33ab2c (diff)
Typo
git-svn-id: svn+ssh://scm.gforge.inria.fr/svnroot/gudhi/branches/persistence_representation_integration@2472 636b058d-ea47-450e-bf9e-a15bfbe3eedb Former-commit-id: 457b970258b8a99519db664358c19d0dee80d879
Diffstat (limited to 'src/Persistence_representations/utilities/persistence_vectors')
-rw-r--r--src/Persistence_representations/utilities/persistence_vectors/CMakeLists.txt25
-rw-r--r--src/Persistence_representations/utilities/persistence_vectors/average_persistence_vectors.cpp73
-rw-r--r--src/Persistence_representations/utilities/persistence_vectors/compute_distance_of_persistence_vectors.cpp111
-rw-r--r--src/Persistence_representations/utilities/persistence_vectors/compute_scalar_product_of_persistence_vectors.cpp87
-rw-r--r--src/Persistence_representations/utilities/persistence_vectors/create_persistence_vectors.cpp65
-rw-r--r--src/Persistence_representations/utilities/persistence_vectors/plot_persistence_vectors.cpp48
-rw-r--r--src/Persistence_representations/utilities/persistence_vectors/simple_diagram.txt.vect1
7 files changed, 410 insertions, 0 deletions
diff --git a/src/Persistence_representations/utilities/persistence_vectors/CMakeLists.txt b/src/Persistence_representations/utilities/persistence_vectors/CMakeLists.txt
new file mode 100644
index 00000000..8033e27a
--- /dev/null
+++ b/src/Persistence_representations/utilities/persistence_vectors/CMakeLists.txt
@@ -0,0 +1,25 @@
+cmake_minimum_required(VERSION 2.6)
+project(GUDHI_STAT)
+
+#persitence vectors
+add_executable ( create_persistence_vectors create_persistence_vectors.cpp )
+target_link_libraries(create_persistence_vectors ${Boost_SYSTEM_LIBRARY})
+add_test ( create_persistence_vectors ${CMAKE_CURRENT_BINARY_DIR}/create_persistence_vectors -1 "${CMAKE_SOURCE_DIR}/data/persistence_diagram/simple_diagram.txt" )
+
+add_executable ( average_persistence_vectors average_persistence_vectors.cpp )
+target_link_libraries(average_persistence_vectors ${Boost_SYSTEM_LIBRARY})
+add_test ( average_persistence_vectors ${CMAKE_CURRENT_BINARY_DIR}/average_persistence_vectors "${CMAKE_SOURCE_DIR}/data/persistence_diagram/simple_diagram.txt.vect" "${CMAKE_SOURCE_DIR}/data/persistence_diagram/simple_diagram.txt.vect" )
+
+add_executable ( compute_distance_of_persistence_vectors compute_distance_of_persistence_vectors.cpp )
+target_link_libraries(compute_distance_of_persistence_vectors ${Boost_SYSTEM_LIBRARY})
+add_test ( compute_distance_of_persistence_vectors ${CMAKE_CURRENT_BINARY_DIR}/compute_distance_of_persistence_vectors -1 "${CMAKE_SOURCE_DIR}/data/persistence_diagram/simple_diagram.txt.vect" "${CMAKE_SOURCE_DIR}/data/persistence_diagram/simple_diagram.txt.vect" )
+
+add_executable ( compute_scalar_product_of_persistence_vectors compute_scalar_product_of_persistence_vectors.cpp )
+target_link_libraries(compute_scalar_product_of_persistence_vectors ${Boost_SYSTEM_LIBRARY})
+add_test ( compute_scalar_product_of_persistence_vectors ${CMAKE_CURRENT_BINARY_DIR}/compute_scalar_product_of_persistence_vectors "${CMAKE_SOURCE_DIR}/data/persistence_diagram/simple_diagram.txt.vect" "${CMAKE_SOURCE_DIR}/data/persistence_diagram/simple_diagram.txt.vect" )
+
+add_executable ( plot_persistence_vectors plot_persistence_vectors.cpp )
+target_link_libraries(plot_persistence_vectors ${Boost_SYSTEM_LIBRARY})
+add_test ( plot_persistence_vectors ${CMAKE_CURRENT_BINARY_DIR}/plot_persistence_vectors "${CMAKE_SOURCE_DIR}/data/persistence_diagram/simple_diagram.txt.vect" )
+
+
diff --git a/src/Persistence_representations/utilities/persistence_vectors/average_persistence_vectors.cpp b/src/Persistence_representations/utilities/persistence_vectors/average_persistence_vectors.cpp
new file mode 100644
index 00000000..320d1f63
--- /dev/null
+++ b/src/Persistence_representations/utilities/persistence_vectors/average_persistence_vectors.cpp
@@ -0,0 +1,73 @@
+/* This file is part of the Gudhi Library. The Gudhi library
+ * (Geometric Understanding in Higher Dimensions) is a generic C++
+ * library for computational topology.
+ *
+ * Author(s): Pawel Dlotko
+ *
+ * Copyright (C) 2015 INRIA (France)
+ *
+ * This program is free software: you can redistribute it and/or modify
+ * it under the terms of the GNU General Public License as published by
+ * the Free Software Foundation, either version 3 of the License, or
+ * (at your option) any later version.
+ *
+ * This program is distributed in the hope that it will be useful,
+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ * GNU General Public License for more details.
+ *
+ * You should have received a copy of the GNU General Public License
+ * along with this program. If not, see <http://www.gnu.org/licenses/>.
+ */
+
+
+#include <gudhi/Persistence_vectors.h>
+
+
+
+using namespace Gudhi;
+using namespace Gudhi::Persistence_representations;
+
+#include <iostream>
+
+
+int main( int argc , char** argv )
+{
+ std::cout << "This program computes average persistence vector of persistence vectors created based on persistence diagrams provided as an input. \n";
+ std::cout << "Please call this program with the names of files with persistence diagrams \n";
+ std::vector< const char* > filenames;
+
+ if ( argc == 1 )
+ {
+ std::cout << "No input files given, the program will now terminate \n";
+ return 1;
+ }
+
+ for ( int i = 1 ; i < argc ; ++i )
+ {
+ filenames.push_back( argv[i] );
+ }
+
+ std::cout << "Reading persistence vectors...\n";
+ std::vector< Vector_distances_in_diagram< Euclidean_distance >* > lands;
+ for ( size_t i = 0 ; i != filenames.size() ; ++i )
+ {
+ Vector_distances_in_diagram< Euclidean_distance >* l = new Vector_distances_in_diagram< Euclidean_distance >;
+ l->load_from_file( filenames[i] );
+ lands.push_back(l );
+ }
+
+ Vector_distances_in_diagram< Euclidean_distance > av;
+ av.compute_average( lands );
+
+ av.print_to_file( "average.vect" );
+
+ for ( size_t i = 0 ; i != filenames.size() ; ++i )
+ {
+ delete lands[i];
+ }
+
+ std::cout << "Done \n";
+
+ return 0;
+}
diff --git a/src/Persistence_representations/utilities/persistence_vectors/compute_distance_of_persistence_vectors.cpp b/src/Persistence_representations/utilities/persistence_vectors/compute_distance_of_persistence_vectors.cpp
new file mode 100644
index 00000000..39e24cd7
--- /dev/null
+++ b/src/Persistence_representations/utilities/persistence_vectors/compute_distance_of_persistence_vectors.cpp
@@ -0,0 +1,111 @@
+/* This file is part of the Gudhi Library. The Gudhi library
+ * (Geometric Understanding in Higher Dimensions) is a generic C++
+ * library for computational topology.
+ *
+ * Author(s): Pawel Dlotko
+ *
+ * Copyright (C) 2015 INRIA (France)
+ *
+ * This program is free software: you can redistribute it and/or modify
+ * it under the terms of the GNU General Public License as published by
+ * the Free Software Foundation, either version 3 of the License, or
+ * (at your option) any later version.
+ *
+ * This program is distributed in the hope that it will be useful,
+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ * GNU General Public License for more details.
+ *
+ * You should have received a copy of the GNU General Public License
+ * along with this program. If not, see <http://www.gnu.org/licenses/>.
+ */
+
+#include <gudhi/Persistence_vectors.h>
+
+
+
+using namespace Gudhi;
+using namespace Gudhi::Persistence_representations;
+
+#include <iostream>
+#include <sstream>
+
+
+int main( int argc , char** argv )
+{
+ std::cout << "This program compute distance of persistence vectors stored in a file (the file needs to be created beforehand). \n";
+ std::cout << "The first parameter of a program is an interger p. The program compute l^p distance of the vectors. For l^infty distance choose p = -1. \n";
+ std::cout << "The remaining parameters of this programs are names of files with persistence vectors.\n";
+
+ if ( argc < 3 )
+ {
+ std::cout << "Wrong number of parameters, the program will now terminate \n";
+ return 1;
+ }
+
+ int pp = atoi( argv[1] );
+ double p = std::numeric_limits<double>::max();
+ if ( pp != -1 )
+ {
+ p = pp;
+ }
+
+
+ std::vector< const char* > filenames;
+ for ( int i = 2 ; i < argc ; ++i )
+ {
+ filenames.push_back( argv[i] );
+ }
+ std::vector< Vector_distances_in_diagram< Euclidean_distance > > vectors;
+ vectors.reserve( filenames.size() );
+ for ( size_t file_no = 0 ; file_no != filenames.size() ; ++file_no )
+ {
+ //cerr << filenames[file_no] << endl;
+ Vector_distances_in_diagram< Euclidean_distance > l;
+ l.load_from_file( filenames[file_no] );
+ vectors.push_back( l );
+ }
+
+ //and now we will compute the scalar product of landscapes.
+
+ //first we prepare an array:
+ std::vector< std::vector< double > > distance( filenames.size() );
+ for ( size_t i = 0 ; i != filenames.size() ; ++i )
+ {
+ std::vector< double > v( filenames.size() , 0 );
+ distance[i] = v;
+ }
+
+ //and now we can compute the distances:
+ for ( size_t i = 0 ; i != vectors.size() ; ++i )
+ {
+ for ( size_t j = i+1 ; j != vectors.size() ; ++j )
+ {
+ distance[i][j] = distance[j][i] = vectors[i].distance( vectors[j] , p ) ;
+ }
+ }
+
+ //and now output the result to the screen and a file:
+ std::ofstream out;
+ out.open( "distance" );
+ for ( size_t i = 0 ; i != distance.size() ; ++i )
+ {
+ for ( size_t j = 0 ; j != distance.size() ; ++j )
+ {
+ std::cout << distance[i][j] << " ";
+ out << distance[i][j] << " ";
+ }
+ std::cout << std::endl;
+ out << std::endl;
+ }
+ out.close();
+
+ return 0;
+}
+
+
+
+
+
+
+
diff --git a/src/Persistence_representations/utilities/persistence_vectors/compute_scalar_product_of_persistence_vectors.cpp b/src/Persistence_representations/utilities/persistence_vectors/compute_scalar_product_of_persistence_vectors.cpp
new file mode 100644
index 00000000..7a1bbaf0
--- /dev/null
+++ b/src/Persistence_representations/utilities/persistence_vectors/compute_scalar_product_of_persistence_vectors.cpp
@@ -0,0 +1,87 @@
+/* This file is part of the Gudhi Library. The Gudhi library
+ * (Geometric Understanding in Higher Dimensions) is a generic C++
+ * library for computational topology.
+ *
+ * Author(s): Pawel Dlotko
+ *
+ * Copyright (C) 2015 INRIA (France)
+ *
+ * This program is free software: you can redistribute it and/or modify
+ * it under the terms of the GNU General Public License as published by
+ * the Free Software Foundation, either version 3 of the License, or
+ * (at your option) any later version.
+ *
+ * This program is distributed in the hope that it will be useful,
+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ * GNU General Public License for more details.
+ *
+ * You should have received a copy of the GNU General Public License
+ * along with this program. If not, see <http://www.gnu.org/licenses/>.
+ */
+
+#include <gudhi/Persistence_vectors.h>
+
+
+
+using namespace Gudhi;
+using namespace Gudhi::Persistence_representations;
+
+#include <iostream>
+#include <sstream>
+
+
+int main( int argc , char** argv )
+{
+ std::cout << "This program compute scalar product of persistence vectors stored in a file (the file needs to be created beforehand). \n";
+ std::cout << "The parameters of this programs are names of files with persistence vectors.\n";
+
+ std::vector< const char* > filenames;
+ for ( int i = 1 ; i < argc ; ++i )
+ {
+ filenames.push_back( argv[i] );
+ }
+ std::vector< Vector_distances_in_diagram< Euclidean_distance > > vectors;
+ vectors.reserve( filenames.size() );
+ for ( size_t file_no = 0 ; file_no != filenames.size() ; ++file_no )
+ {
+ Vector_distances_in_diagram< Euclidean_distance > l;
+ l.load_from_file( filenames[file_no] );
+ vectors.push_back( l );
+ }
+
+ //and now we will compute the scalar product of landscapes.
+
+ //first we prepare an array:
+ std::vector< std::vector< double > > scalar_product( filenames.size() );
+ for ( size_t i = 0 ; i != filenames.size() ; ++i )
+ {
+ std::vector< double > v( filenames.size() , 0 );
+ scalar_product[i] = v;
+ }
+
+ //and now we can compute the scalar product:
+ for ( size_t i = 0 ; i != vectors.size() ; ++i )
+ {
+ for ( size_t j = i ; j != vectors.size() ; ++j )
+ {
+ scalar_product[i][j] = scalar_product[j][i] = vectors[i].compute_scalar_product( vectors[j] ) ;
+ }
+ }
+
+ //and now output the result to the screen and a file:
+ std::ofstream out;
+ out.open( "scalar_product" );
+ for ( size_t i = 0 ; i != scalar_product.size() ; ++i )
+ {
+ for ( size_t j = 0 ; j != scalar_product.size() ; ++j )
+ {
+ std::cout << scalar_product[i][j] << " ";
+ out << scalar_product[i][j] << " ";
+ }
+ std::cout << std::endl;
+ out << std::endl;
+ }
+ out.close();
+ return 0;
+}
diff --git a/src/Persistence_representations/utilities/persistence_vectors/create_persistence_vectors.cpp b/src/Persistence_representations/utilities/persistence_vectors/create_persistence_vectors.cpp
new file mode 100644
index 00000000..634bcb13
--- /dev/null
+++ b/src/Persistence_representations/utilities/persistence_vectors/create_persistence_vectors.cpp
@@ -0,0 +1,65 @@
+/* This file is part of the Gudhi Library. The Gudhi library
+ * (Geometric Understanding in Higher Dimensions) is a generic C++
+ * library for computational topology.
+ *
+ * Author(s): Pawel Dlotko
+ *
+ * Copyright (C) 2015 INRIA (France)
+ *
+ * This program is free software: you can redistribute it and/or modify
+ * it under the terms of the GNU General Public License as published by
+ * the Free Software Foundation, either version 3 of the License, or
+ * (at your option) any later version.
+ *
+ * This program is distributed in the hope that it will be useful,
+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ * GNU General Public License for more details.
+ *
+ * You should have received a copy of the GNU General Public License
+ * along with this program. If not, see <http://www.gnu.org/licenses/>.
+ */
+
+#include <gudhi/Persistence_vectors.h>
+
+
+
+using namespace Gudhi;
+using namespace Gudhi::Persistence_representations;
+
+#include <iostream>
+#include <sstream>
+
+
+int main( int argc , char** argv )
+{
+ std::cout << "This program creates persistence vectors of diagrams provided as an input. The first parameter of this program is a dimension of persistence ";
+ std::cout << " that will be used in creation of the persistence vectors. If our input files contain persistence pairs of various dimension, as a second parameter of the ";
+ std::cout << " procedure please provide the dimension of persistence you want to use. If in your file there are only birth-death pairs of the same dimension, set the first parameter to -1." << std::endl;
+ std::cout << "The remaining parameters are the names of files with persistence diagrams. \n";
+ int dim = atoi( argv[1] );
+ unsigned dimension = std::numeric_limits<unsigned>::max();
+ if ( dim >= 0 )
+ {
+ dimension = (unsigned)dim;
+ }
+
+ std::vector< const char* > filenames;
+ for ( int i = 2 ; i < argc ; ++i )
+ {
+ filenames.push_back( argv[i] );
+ }
+
+ for ( size_t i = 0 ; i != filenames.size() ; ++i )
+ {
+ std::cerr << "Creatign persistence vectors based on a file : " << filenames[i] << std::endl;
+ //std::vector< std::pair< double , double > > persistence_pairs = read_gudhi_persistence_file_in_one_dimension( filenames[i] , size_t dimension = 0 )
+ Vector_distances_in_diagram< Euclidean_distance > l( filenames[i] , dimension );
+ std::stringstream ss;
+ ss << filenames[i] << ".vect";
+ l.print_to_file( ss.str().c_str() );
+ }
+ std::cout << "Done \n";
+ return 0;
+}
+
diff --git a/src/Persistence_representations/utilities/persistence_vectors/plot_persistence_vectors.cpp b/src/Persistence_representations/utilities/persistence_vectors/plot_persistence_vectors.cpp
new file mode 100644
index 00000000..c72fc1ee
--- /dev/null
+++ b/src/Persistence_representations/utilities/persistence_vectors/plot_persistence_vectors.cpp
@@ -0,0 +1,48 @@
+/* This file is part of the Gudhi Library. The Gudhi library
+ * (Geometric Understanding in Higher Dimensions) is a generic C++
+ * library for computational topology.
+ *
+ * Author(s): Pawel Dlotko
+ *
+ * Copyright (C) 2015 INRIA (France)
+ *
+ * This program is free software: you can redistribute it and/or modify
+ * it under the terms of the GNU General Public License as published by
+ * the Free Software Foundation, either version 3 of the License, or
+ * (at your option) any later version.
+ *
+ * This program is distributed in the hope that it will be useful,
+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ * GNU General Public License for more details.
+ *
+ * You should have received a copy of the GNU General Public License
+ * along with this program. If not, see <http://www.gnu.org/licenses/>.
+ */
+
+#include <gudhi/Persistence_vectors.h>
+
+
+
+using namespace Gudhi;
+using namespace Gudhi::Persistence_representations;
+
+#include <iostream>
+#include <sstream>
+
+
+int main( int argc , char** argv )
+{
+ std::cout << "This program create a Gnuplot script to plot persistence vector. Please call this program with the name of file with persistence vector. \n";
+ if ( argc != 2 )
+ {
+ std::cout << "Wrong number of parameters, the program will now terminate. \n";
+ return 1;
+ }
+ Vector_distances_in_diagram< Euclidean_distance > l;
+ l.load_from_file( argv[1] );
+ l.plot( argv[1] );
+
+ return 0;
+}
+
diff --git a/src/Persistence_representations/utilities/persistence_vectors/simple_diagram.txt.vect b/src/Persistence_representations/utilities/persistence_vectors/simple_diagram.txt.vect
new file mode 100644
index 00000000..1d4eeaaf
--- /dev/null
+++ b/src/Persistence_representations/utilities/persistence_vectors/simple_diagram.txt.vect
@@ -0,0 +1 @@
+0.707107 0.707107 0.707107 0.707107 0.707107 0.707107 0.707107 0.707107 0.707107 0.707107 \ No newline at end of file