summaryrefslogtreecommitdiff
path: root/src/Persistence_representations
diff options
context:
space:
mode:
authorROUVREAU Vincent <vincent.rouvreau@inria.fr>2019-06-14 14:45:22 +0200
committerROUVREAU Vincent <vincent.rouvreau@inria.fr>2019-06-14 14:45:22 +0200
commit64e6c96afa4d1a95b8d6ee74ea910c1cb80ebbd9 (patch)
treeac3bf9907b3a2b34fb92a5ef96f0eff6c933e0b3 /src/Persistence_representations
parenta1088d88479e6c18c5ade73ffc34bba2bf37bc1d (diff)
Remove gudhi_patches for CGAL and CGAL 4.11.0 is now the minimal CGAL version required. Modification of documentation accordingly
Diffstat (limited to 'src/Persistence_representations')
-rw-r--r--src/Persistence_representations/test/CMakeLists.txt16
-rw-r--r--src/Persistence_representations/utilities/persistence_intervals/CMakeLists.txt4
2 files changed, 10 insertions, 10 deletions
diff --git a/src/Persistence_representations/test/CMakeLists.txt b/src/Persistence_representations/test/CMakeLists.txt
index fb650485..a95880c9 100644
--- a/src/Persistence_representations/test/CMakeLists.txt
+++ b/src/Persistence_representations/test/CMakeLists.txt
@@ -39,14 +39,14 @@ target_link_libraries(kernels_unit ${Boost_UNIT_TEST_FRAMEWORK_LIBRARY})
gudhi_add_coverage_test(kernels_unit)
-if (NOT CGAL_WITH_EIGEN3_VERSION VERSION_LESS 4.8.1)
- add_executable (Persistence_intervals_with_distances_test_unit persistence_intervals_with_distances_test.cpp )
- target_link_libraries(Persistence_intervals_with_distances_test_unit ${Boost_UNIT_TEST_FRAMEWORK_LIBRARY})
- if (TBB_FOUND)
- target_link_libraries(Persistence_intervals_with_distances_test_unit ${TBB_LIBRARIES})
- endif(TBB_FOUND)
- gudhi_add_coverage_test(Persistence_intervals_with_distances_test_unit)
-endif (NOT CGAL_WITH_EIGEN3_VERSION VERSION_LESS 4.8.1)
+if (NOT CGAL_WITH_EIGEN3_VERSION VERSION_LESS 4.11.0)
+ add_executable (Persistence_intervals_with_distances_test_unit persistence_intervals_with_distances_test.cpp )
+ target_link_libraries(Persistence_intervals_with_distances_test_unit ${Boost_UNIT_TEST_FRAMEWORK_LIBRARY})
+ if (TBB_FOUND)
+ target_link_libraries(Persistence_intervals_with_distances_test_unit ${TBB_LIBRARIES})
+ endif(TBB_FOUND)
+ gudhi_add_coverage_test(Persistence_intervals_with_distances_test_unit)
+endif (NOT CGAL_WITH_EIGEN3_VERSION VERSION_LESS 4.11.0)
diff --git a/src/Persistence_representations/utilities/persistence_intervals/CMakeLists.txt b/src/Persistence_representations/utilities/persistence_intervals/CMakeLists.txt
index 649b72cb..a025183e 100644
--- a/src/Persistence_representations/utilities/persistence_intervals/CMakeLists.txt
+++ b/src/Persistence_representations/utilities/persistence_intervals/CMakeLists.txt
@@ -22,7 +22,7 @@ add_test(NAME Persistence_representation_utilities_compute_number_of_dominant_in
install(TARGETS compute_number_of_dominant_intervals DESTINATION bin)
-if (NOT CGAL_WITH_EIGEN3_VERSION VERSION_LESS 4.8.1)
+if (NOT CGAL_WITH_EIGEN3_VERSION VERSION_LESS 4.11.0)
add_executable ( compute_bottleneck_distance compute_bottleneck_distance.cpp )
if (TBB_FOUND)
target_link_libraries(compute_bottleneck_distance ${TBB_LIBRARIES})
@@ -34,4 +34,4 @@ if (NOT CGAL_WITH_EIGEN3_VERSION VERSION_LESS 4.8.1)
"${CMAKE_CURRENT_BINARY_DIR}/../second.pers")
install(TARGETS compute_bottleneck_distance DESTINATION bin)
-endif (NOT CGAL_WITH_EIGEN3_VERSION VERSION_LESS 4.8.1)
+endif (NOT CGAL_WITH_EIGEN3_VERSION VERSION_LESS 4.11.0)