summaryrefslogtreecommitdiff
path: root/src/Persistence_representations
diff options
context:
space:
mode:
authormcarrier <mcarrier@636b058d-ea47-450e-bf9e-a15bfbe3eedb>2018-04-20 15:56:06 +0000
committermcarrier <mcarrier@636b058d-ea47-450e-bf9e-a15bfbe3eedb>2018-04-20 15:56:06 +0000
commit7f9e8f11f70e8387ef29c3fa13016121dca79cbe (patch)
treeabd50b927970f7de1cb07f2041e093a22a446753 /src/Persistence_representations
parent905be209a0e62121c125c37e01f4d2eae5aa606d (diff)
git-svn-id: svn+ssh://scm.gforge.inria.fr/svnroot/gudhi/branches/kernels@3385 636b058d-ea47-450e-bf9e-a15bfbe3eedb
Former-commit-id: 2a83e62e132ce406986efa1456b5f1bca6b93691
Diffstat (limited to 'src/Persistence_representations')
-rw-r--r--src/Persistence_representations/example/CMakeLists.txt9
-rw-r--r--src/Persistence_representations/example/landscape.cpp51
-rw-r--r--src/Persistence_representations/example/persistence_image.cpp54
-rw-r--r--src/Persistence_representations/example/persistence_weighted_gaussian.cpp8
-rw-r--r--src/Persistence_representations/include/gudhi/Landscape.h103
-rw-r--r--src/Persistence_representations/include/gudhi/Persistence_image.h117
-rw-r--r--src/Persistence_representations/include/gudhi/Persistence_weighted_gaussian.h15
7 files changed, 344 insertions, 13 deletions
diff --git a/src/Persistence_representations/example/CMakeLists.txt b/src/Persistence_representations/example/CMakeLists.txt
index 79d39c4d..89284e38 100644
--- a/src/Persistence_representations/example/CMakeLists.txt
+++ b/src/Persistence_representations/example/CMakeLists.txt
@@ -37,3 +37,12 @@ add_test(NAME Persistence_weighted_gaussian
COMMAND $<TARGET_FILE:Persistence_weighted_gaussian>)
install(TARGETS Persistence_weighted_gaussian DESTINATION bin)
+add_executable ( Persistence_image persistence_image.cpp )
+add_test(NAME Persistence_image
+ COMMAND $<TARGET_FILE:Persistence_image>)
+install(TARGETS Persistence_image DESTINATION bin)
+
+add_executable ( Landscape landscape.cpp )
+add_test(NAME Landscape
+ COMMAND $<TARGET_FILE:Landscape>)
+install(TARGETS Landscape DESTINATION bin)
diff --git a/src/Persistence_representations/example/landscape.cpp b/src/Persistence_representations/example/landscape.cpp
new file mode 100644
index 00000000..5fa84a7c
--- /dev/null
+++ b/src/Persistence_representations/example/landscape.cpp
@@ -0,0 +1,51 @@
+/* This file is part of the Gudhi Library. The Gudhi library
+ * (Geometric Understanding in Higher Dimensions) is a generic C++
+ * library for computational topology.
+ *
+ * Author(s): Mathieu Carriere
+ *
+ * Copyright (C) 2018 INRIA (France)
+ *
+ * This program is free software: you can redistribute it and/or modify
+ * it under the terms of the GNU General Public License as published by
+ * the Free Software Foundation, either version 3 of the License, or
+ * (at your option) any later version.
+ *
+ * This program is distributed in the hope that it will be useful,
+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ * GNU General Public License for more details.
+ *
+ * You should have received a copy of the GNU General Public License
+ * along with this program. If not, see <http://www.gnu.org/licenses/>.
+ */
+
+#include <gudhi/Landscape.h>
+
+#include <iostream>
+#include <vector>
+#include <utility>
+
+using LS = Gudhi::Persistence_representations::Landscape;
+
+int main(int argc, char** argv) {
+
+ std::vector<std::pair<double, double> > persistence;
+
+ persistence.push_back(std::make_pair(1, 2));
+ persistence.push_back(std::make_pair(6, 8));
+ persistence.push_back(std::make_pair(0, 4));
+ persistence.push_back(std::make_pair(3, 8));
+
+ int nb_ls = 3; double min_x = 0.0; double max_x = 10.0; int res_x = 100;
+
+ LS ls(persistence, nb_ls, min_x, max_x, res_x);
+ std::vector<std::vector<double> > L = ls.vectorize();
+
+ for(int i = 0; i < nb_ls; i++){
+ for(int j = 0; j < res_x; j++) std::cout << L[i][j] << " ";
+ std::cout << std::endl;
+ }
+
+ return 0;
+}
diff --git a/src/Persistence_representations/example/persistence_image.cpp b/src/Persistence_representations/example/persistence_image.cpp
new file mode 100644
index 00000000..dfa469d4
--- /dev/null
+++ b/src/Persistence_representations/example/persistence_image.cpp
@@ -0,0 +1,54 @@
+/* This file is part of the Gudhi Library. The Gudhi library
+ * (Geometric Understanding in Higher Dimensions) is a generic C++
+ * library for computational topology.
+ *
+ * Author(s): Mathieu Carriere
+ *
+ * Copyright (C) 2018 INRIA (France)
+ *
+ * This program is free software: you can redistribute it and/or modify
+ * it under the terms of the GNU General Public License as published by
+ * the Free Software Foundation, either version 3 of the License, or
+ * (at your option) any later version.
+ *
+ * This program is distributed in the hope that it will be useful,
+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ * GNU General Public License for more details.
+ *
+ * You should have received a copy of the GNU General Public License
+ * along with this program. If not, see <http://www.gnu.org/licenses/>.
+ */
+
+#include <gudhi/Persistence_image.h>
+#include <gudhi/Persistence_weighted_gaussian.h>
+
+#include <iostream>
+#include <vector>
+#include <utility>
+#include <string>
+
+using PI = Gudhi::Persistence_representations::Persistence_image;
+using Weight = std::function<double (std::pair<double,double>) >;
+
+int main(int argc, char** argv) {
+
+ std::vector<std::pair<double, double> > persistence;
+
+ persistence.push_back(std::make_pair(1, 2));
+ persistence.push_back(std::make_pair(6, 8));
+ persistence.push_back(std::make_pair(0, 4));
+ persistence.push_back(std::make_pair(3, 8));
+
+ double min_x = 0.0; double max_x = 10.0; int res_x = 100; double min_y = 0.0; double max_y = 10.0; int res_y = 100; double sigma = 1.0; Weight weight = Gudhi::Persistence_representations::Persistence_weighted_gaussian::linear_weight;
+
+ PI pim(persistence, min_x, max_x, res_x, min_y, max_y, res_y, weight, sigma);
+ std::vector<std::vector<double> > P = pim.vectorize();
+
+ for(int i = 0; i < res_y; i++){
+ for(int j = 0; j < res_x; j++) std::cout << P[i][j] << " ";
+ std::cout << std::endl;
+ }
+
+ return 0;
+}
diff --git a/src/Persistence_representations/example/persistence_weighted_gaussian.cpp b/src/Persistence_representations/example/persistence_weighted_gaussian.cpp
index dea5dab6..234f6323 100644
--- a/src/Persistence_representations/example/persistence_weighted_gaussian.cpp
+++ b/src/Persistence_representations/example/persistence_weighted_gaussian.cpp
@@ -48,11 +48,11 @@ int main(int argc, char** argv) {
double tau = 1;
int m = 10000;
- PWG PWG1(persistence1, sigma, m, PWG::arctan_weight);
- PWG PWG2(persistence2, sigma, m, PWG::arctan_weight);
+ PWG PWG1(persistence1, sigma, m, PWG::arctan_weight(1,1));
+ PWG PWG2(persistence2, sigma, m, PWG::arctan_weight(1,1));
- PWG PWGex1(persistence1, sigma, -1, PWG::arctan_weight);
- PWG PWGex2(persistence2, sigma, -1, PWG::arctan_weight);
+ PWG PWGex1(persistence1, sigma, -1, PWG::arctan_weight(1,1));
+ PWG PWGex2(persistence2, sigma, -1, PWG::arctan_weight(1,1));
// Linear PWG
diff --git a/src/Persistence_representations/include/gudhi/Landscape.h b/src/Persistence_representations/include/gudhi/Landscape.h
new file mode 100644
index 00000000..d6608a57
--- /dev/null
+++ b/src/Persistence_representations/include/gudhi/Landscape.h
@@ -0,0 +1,103 @@
+/* This file is part of the Gudhi Library. The Gudhi library
+ * (Geometric Understanding in Higher Dimensions) is a generic C++
+ * library for computational topology.
+ *
+ * Author(s): Mathieu Carriere
+ *
+ * Copyright (C) 2018 INRIA (France)
+ *
+ * This program is free software: you can redistribute it and/or modify
+ * it under the terms of the GNU General Public License as published by
+ * the Free Software Foundation, either version 3 of the License, or
+ * (at your option) any later version.
+ *
+ * This program is distributed in the hope that it will be useful,
+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ * GNU General Public License for more details.
+ *
+ * You should have received a copy of the GNU General Public License
+ * along with this program. If not, see <http://www.gnu.org/licenses/>.
+ */
+
+#ifndef LANDSCAPE_H_
+#define LANDSCAPE_H_
+
+// gudhi include
+#include <gudhi/read_persistence_from_file.h>
+#include <gudhi/common_persistence_representations.h>
+#include <gudhi/Debug_utils.h>
+
+// standard include
+#include <cmath>
+#include <iostream>
+#include <vector>
+#include <limits>
+#include <fstream>
+#include <sstream>
+#include <algorithm>
+#include <string>
+#include <utility>
+#include <functional>
+
+using PD = std::vector<std::pair<double,double> >;
+
+namespace Gudhi {
+namespace Persistence_representations {
+
+/**
+ * \class Landscape gudhi/Landscape.h
+ * \brief A class implementing the Landscapes.
+ *
+ * \ingroup Persistence_representations
+ *
+ * \details
+ *
+**/
+
+class Landscape {
+
+ protected:
+ PD diagram;
+ int res_x, nb_ls;
+ double min_x, max_x;
+
+ public:
+
+ /** \brief Landscape constructor.
+ * \ingroup Landscape
+ *
+ */
+ Landscape(PD _diagram, int _nb_ls = 5, double _min_x = 0.0, double _max_x = 1.0, int _res_x = 10){diagram = _diagram; nb_ls = _nb_ls; min_x = _min_x; max_x = _max_x; res_x = _res_x;}
+
+ /** \brief Computes the landscape of a diagram.
+ * \ingroup Landscape
+ *
+ */
+ std::vector<std::vector<double> > vectorize() {
+ std::vector<std::vector<double> > ls; for(int i = 0; i < nb_ls; i++) ls.emplace_back();
+ int num_pts = diagram.size(); double step = (max_x - min_x)/res_x;
+
+ for(int i = 0; i < res_x; i++){
+ double x = min_x + i*step; double t = x / std::sqrt(2); std::vector<double> events;
+ for(int j = 0; j < num_pts; j++){
+ double px = diagram[j].first; double py = diagram[j].second;
+ if(t >= px && t <= py){ if(t >= (px+py)/2) events.push_back(std::sqrt(2)*(py-t)); else events.push_back(std::sqrt(2)*(t-px)); }
+ }
+
+ std::sort(events.begin(), events.end(), [](const double & a, const double & b){return a > b;}); int nb_events = events.size();
+ for (int j = 0; j < nb_ls; j++){ if(j < nb_events) ls[j].push_back(events[j]); else ls[j].push_back(0); }
+ }
+
+ return ls;
+ }
+
+
+
+
+};
+
+} // namespace Landscape
+} // namespace Gudhi
+
+#endif // LANDSCAPE_H_
diff --git a/src/Persistence_representations/include/gudhi/Persistence_image.h b/src/Persistence_representations/include/gudhi/Persistence_image.h
new file mode 100644
index 00000000..6c9f75b7
--- /dev/null
+++ b/src/Persistence_representations/include/gudhi/Persistence_image.h
@@ -0,0 +1,117 @@
+/* This file is part of the Gudhi Library. The Gudhi library
+ * (Geometric Understanding in Higher Dimensions) is a generic C++
+ * library for computational topology.
+ *
+ * Author(s): Mathieu Carriere
+ *
+ * Copyright (C) 2018 INRIA (France)
+ *
+ * This program is free software: you can redistribute it and/or modify
+ * it under the terms of the GNU General Public License as published by
+ * the Free Software Foundation, either version 3 of the License, or
+ * (at your option) any later version.
+ *
+ * This program is distributed in the hope that it will be useful,
+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ * GNU General Public License for more details.
+ *
+ * You should have received a copy of the GNU General Public License
+ * along with this program. If not, see <http://www.gnu.org/licenses/>.
+ */
+
+#ifndef PERSISTENCE_IMAGE_H_
+#define PERSISTENCE_IMAGE_H_
+
+// gudhi include
+#include <gudhi/read_persistence_from_file.h>
+#include <gudhi/common_persistence_representations.h>
+#include <gudhi/Debug_utils.h>
+#include <gudhi/Persistence_weighted_gaussian.h>
+
+// standard include
+#include <cmath>
+#include <iostream>
+#include <vector>
+#include <limits>
+#include <fstream>
+#include <sstream>
+#include <algorithm>
+#include <string>
+#include <utility>
+#include <functional>
+
+using PD = std::vector<std::pair<double,double> >;
+using Weight = std::function<double (std::pair<double,double>) >;
+
+namespace Gudhi {
+namespace Persistence_representations {
+
+/**
+ * \class Persistence_image gudhi/Persistence_image.h
+ * \brief A class implementing the Persistence Images.
+ *
+ * \ingroup Persistence_representations
+ *
+ * \details
+ *
+**/
+
+class Persistence_image {
+
+ protected:
+ PD diagram;
+ int res_x, res_y;
+ double min_x, max_x, min_y, max_y;
+ Weight weight;
+ double sigma;
+
+ public:
+
+ /** \brief Persistence Image constructor.
+ * \ingroup Persistence_image
+ *
+ */
+ Persistence_image(PD _diagram, double _min_x = 0.0, double _max_x = 1.0, int _res_x = 10, double _min_y = 0.0, double _max_y = 1.0, int _res_y = 10,
+ Weight _weight = Gudhi::Persistence_representations::Persistence_weighted_gaussian::arctan_weight(1,1), double _sigma = 1.0){
+ diagram = _diagram; min_x = _min_x; max_x = _max_x; res_x = _res_x; min_y = _min_y; max_y = _max_y; res_y = _res_y, weight = _weight; sigma = _sigma;
+ }
+
+ /** \brief Computes the persistence image of a diagram.
+ * \ingroup Persistence_image
+ *
+ */
+ std::vector<std::vector<double> > vectorize() {
+ std::vector<std::vector<double> > im; for(int i = 0; i < res_y; i++) im.emplace_back();
+ double step_x = (max_x - min_x)/res_x; double step_y = (max_y - min_y)/res_y;
+
+ int num_pts = diagram.size();
+
+ for(int i = 0; i < res_y; i++){
+ double y = min_y + i*step_y;
+ for(int j = 0; j < res_x; j++){
+ double x = min_x + j*step_x;
+
+ double pixel_value = 0;
+ for(int k = 0; k < num_pts; k++){
+ double px = diagram[k].first; double py = diagram[k].second;
+ pixel_value += weight(std::pair<double,double>(px,py)) * std::exp( -((x-px)*(x-px) + (y-(py-px))*(y-(py-px))) / (2*sigma*sigma) ) / (sigma*std::sqrt(2*pi));
+ }
+ im[i].push_back(pixel_value);
+
+ }
+ }
+
+ return im;
+
+ }
+
+
+
+
+};
+
+} // namespace Persistence_image
+} // namespace Gudhi
+
+#endif // PERSISTENCE_IMAGE_H_
diff --git a/src/Persistence_representations/include/gudhi/Persistence_weighted_gaussian.h b/src/Persistence_representations/include/gudhi/Persistence_weighted_gaussian.h
index b30e0273..9a63fccd 100644
--- a/src/Persistence_representations/include/gudhi/Persistence_weighted_gaussian.h
+++ b/src/Persistence_representations/include/gudhi/Persistence_weighted_gaussian.h
@@ -97,7 +97,7 @@ class Persistence_weighted_gaussian{
* @param[in] _weight weight function for the points in the diagrams.
*
*/
- Persistence_weighted_gaussian(PD _diagram, double _sigma = 1.0, int _approx = 1000, Weight _weight = arctan_weight){diagram = _diagram; sigma = _sigma; approx = _approx; weight = _weight;}
+ Persistence_weighted_gaussian(PD _diagram, double _sigma = 1.0, int _approx = 1000, Weight _weight = arctan_weight(1,1)){diagram = _diagram; sigma = _sigma; approx = _approx; weight = _weight;}
PD get_diagram() const {return this->diagram;}
double get_sigma() const {return this->sigma;}
@@ -115,16 +115,13 @@ class Persistence_weighted_gaussian{
* @param[in] p point in 2D.
*
*/
- static double pss_weight(std::pair<double,double> p){
- if(p.second > p.first) return 1;
- else return -1;
- }
+ static double pss_weight(std::pair<double,double> p) {if(p.second > p.first) return 1; else return -1;}
+ static double linear_weight(std::pair<double,double> p) {return std::abs(p.second - p.first);}
+ static double const_weight(std::pair<double,double> p) {return 1;}
+ static std::function<double (std::pair<double,double>) > arctan_weight(double C, double power) {return [=](std::pair<double,double> p){return C * atan(std::pow(std::abs(p.second - p.first), power));};}
- static double arctan_weight(std::pair<double,double> p){
- return atan(p.second - p.first);
- }
- std::vector<std::pair<double,double> > Fourier_feat(PD diag, std::vector<std::pair<double,double> > z, Weight weight = arctan_weight){
+ std::vector<std::pair<double,double> > Fourier_feat(PD diag, std::vector<std::pair<double,double> > z, Weight weight = arctan_weight(1,1)){
int md = diag.size(); std::vector<std::pair<double,double> > b; int mz = z.size();
for(int i = 0; i < mz; i++){
double d1 = 0; double d2 = 0; double zx = z[i].first; double zy = z[i].second;