summaryrefslogtreecommitdiff
path: root/src/Persistent_cohomology/example/CMakeLists.txt
diff options
context:
space:
mode:
authorvrouvrea <vrouvrea@636b058d-ea47-450e-bf9e-a15bfbe3eedb>2016-08-04 15:41:38 +0000
committervrouvrea <vrouvrea@636b058d-ea47-450e-bf9e-a15bfbe3eedb>2016-08-04 15:41:38 +0000
commitc4f7417b79dfe7610a9e7b5ffbf487abfe7fa3a0 (patch)
tree39ea60d6613c56dd81f5d05869ab2a630ae786f9 /src/Persistent_cohomology/example/CMakeLists.txt
parentd5c5c59161b724f93999c78d979c555b9a72d1ec (diff)
Make GUDHI Cmake less verbose on CGAL package finding
git-svn-id: svn+ssh://scm.gforge.inria.fr/svnroot/gudhi/trunk@1415 636b058d-ea47-450e-bf9e-a15bfbe3eedb Former-commit-id: 2eebce43b0f75ab1cef3a2fe6f2c1bd0b38672a9
Diffstat (limited to 'src/Persistent_cohomology/example/CMakeLists.txt')
-rw-r--r--src/Persistent_cohomology/example/CMakeLists.txt11
1 files changed, 1 insertions, 10 deletions
diff --git a/src/Persistent_cohomology/example/CMakeLists.txt b/src/Persistent_cohomology/example/CMakeLists.txt
index 94b9fbfa..d97d1b63 100644
--- a/src/Persistent_cohomology/example/CMakeLists.txt
+++ b/src/Persistent_cohomology/example/CMakeLists.txt
@@ -48,8 +48,6 @@ if(GMP_FOUND)
add_test(rips_multifield_persistence_2_71 ${CMAKE_CURRENT_BINARY_DIR}/rips_multifield_persistence ${CMAKE_SOURCE_DIR}/data/points/Kl.txt -r 0.2 -d 3 -p 2 -q 71 -m 100)
endif(GMPXX_FOUND)
-else()
- # message(WARNING "GMP not found.")
endif(GMP_FOUND)
if(CGAL_FOUND)
@@ -81,13 +79,6 @@ if(CGAL_FOUND)
add_test(alpha_complex_persistence_2_0_45 ${CMAKE_CURRENT_BINARY_DIR}/alpha_complex_persistence ${CMAKE_SOURCE_DIR}/data/points/tore3D_300.off -m 0.45 -p 2)
add_test(periodic_alpha_complex_3d_persistence_2_0 ${CMAKE_CURRENT_BINARY_DIR}/periodic_alpha_complex_3d_persistence ${CMAKE_SOURCE_DIR}/data/points/grid_10_10_10_in_0_1.off ${CMAKE_SOURCE_DIR}/data/points/iso_cuboid_3_in_0_1.txt 2 0)
add_test(custom_persistence_sort ${CMAKE_CURRENT_BINARY_DIR}/custom_persistence_sort)
-
- else()
- message(WARNING "Eigen3 not found. Version 3.1.0 is required for Alpha complex persistence examples.")
endif(EIGEN3_FOUND)
- else()
- message(WARNING "CGAL version: ${CGAL_VERSION} is too old to compile Alpha complex persistence examples. Version 4.7.0 is required.")
- endif ()
-else()
- # message(WARNING "CGAL not found.")
+ endif (NOT CGAL_VERSION VERSION_LESS 4.7.0)
endif(CGAL_FOUND)