summaryrefslogtreecommitdiff
path: root/src/Simplex_tree/example/CMakeLists.txt
diff options
context:
space:
mode:
authorsalinasd <salinasd@636b058d-ea47-450e-bf9e-a15bfbe3eedb>2014-12-18 10:27:19 +0000
committersalinasd <salinasd@636b058d-ea47-450e-bf9e-a15bfbe3eedb>2014-12-18 10:27:19 +0000
commitc685b05b2ed30d96554ec3271bbbb68f874c54e1 (patch)
tree3282e6fa24eed38a8b8599e547cf584e135960bd /src/Simplex_tree/example/CMakeLists.txt
parent9f5ec92820b6efab1fbde5971c569ca6ab3d73f8 (diff)
build vs12
git-svn-id: svn+ssh://scm.gforge.inria.fr/svnroot/gudhi/trunk@381 636b058d-ea47-450e-bf9e-a15bfbe3eedb Former-commit-id: 595d6b2aa6f0c865bacca4e957824e1b113cf921
Diffstat (limited to 'src/Simplex_tree/example/CMakeLists.txt')
-rw-r--r--src/Simplex_tree/example/CMakeLists.txt6
1 files changed, 4 insertions, 2 deletions
diff --git a/src/Simplex_tree/example/CMakeLists.txt b/src/Simplex_tree/example/CMakeLists.txt
index 65c213c7..14f51bfe 100644
--- a/src/Simplex_tree/example/CMakeLists.txt
+++ b/src/Simplex_tree/example/CMakeLists.txt
@@ -10,11 +10,13 @@ add_executable ( simple_simplex_tree simple_simplex_tree.cpp )
target_link_libraries(simple_simplex_tree ${Boost_SYSTEM_LIBRARY})
add_test(simple_simplex_tree ${CMAKE_CURRENT_BINARY_DIR}/simple_simplex_tree)
+
# An example with Simplex-tree using CGAL alpha_shapes_3
if(GMP_FOUND AND CGAL_FOUND)
message("CGAL_lib = ${CGAL_LIBRARIES_DIR}")
- message("GMP_LIBRARIES = ${GMP_LIBRARIES}")
- include(${CGAL_USE_FILE})
+ message("GMP_LIBRARIES = ${GMP_LIBRARIES}")
+ INCLUDE_DIRECTORIES(${GMP_INCLUDE_DIR})
+ INCLUDE_DIRECTORIES(${CGAL_INCLUDE_DIRS})
add_executable ( simplex_tree_from_alpha_shapes_3 simplex_tree_from_alpha_shapes_3.cpp )
target_link_libraries(simplex_tree_from_alpha_shapes_3 ${Boost_SYSTEM_LIBRARY} ${GMP_LIBRARIES} ${CGAL_LIBRARY})
add_test(simplex_tree_from_alpha_shapes_3 ${CMAKE_CURRENT_BINARY_DIR}/simplex_tree_from_alpha_shapes_3 ${CMAKE_SOURCE_DIR}/data/points/bunny_5000)