summaryrefslogtreecommitdiff
path: root/src/Simplex_tree/example
diff options
context:
space:
mode:
authorvrouvrea <vrouvrea@636b058d-ea47-450e-bf9e-a15bfbe3eedb>2017-06-20 14:46:29 +0000
committervrouvrea <vrouvrea@636b058d-ea47-450e-bf9e-a15bfbe3eedb>2017-06-20 14:46:29 +0000
commite30578ad5b334a613babba4f4383ae9666e3e78f (patch)
tree783b967cc0471895e6e38518a0825b388819bf3a /src/Simplex_tree/example
parentdbef7b9f8c523cc54db4ae69f6b9e2903e63b3ca (diff)
parentd53ad3e2b527ec2df82b801a4026ffb77b97427d (diff)
Merge last trunk modifications : Spatial searching-Add radius search
git-svn-id: svn+ssh://scm.gforge.inria.fr/svnroot/gudhi/branches/graph_expansion_with_blocker_oracle@2558 636b058d-ea47-450e-bf9e-a15bfbe3eedb Former-commit-id: a53322aad14b0850382c53d1faf053d6d62a5d00
Diffstat (limited to 'src/Simplex_tree/example')
-rw-r--r--src/Simplex_tree/example/CMakeLists.txt24
1 files changed, 24 insertions, 0 deletions
diff --git a/src/Simplex_tree/example/CMakeLists.txt b/src/Simplex_tree/example/CMakeLists.txt
index d05bb187..cfac0da6 100644
--- a/src/Simplex_tree/example/CMakeLists.txt
+++ b/src/Simplex_tree/example/CMakeLists.txt
@@ -36,3 +36,27 @@ if(GMP_FOUND AND CGAL_FOUND)
install(TARGETS Simplex_tree_example_alpha_shapes_3_from_off DESTINATION bin)
endif()
+
+
+add_executable(rips_step_by_step rips_step_by_step.cpp)
+target_link_libraries(rips_step_by_step ${Boost_SYSTEM_LIBRARY} ${Boost_PROGRAM_OPTIONS_LIBRARY})
+if (TBB_FOUND)
+ target_link_libraries(rips_step_by_step ${TBB_LIBRARIES})
+endif()
+
+add_executable(cgal_rips_step_by_step cgal_rips_step_by_step.cpp)
+target_link_libraries(cgal_rips_step_by_step ${Boost_SYSTEM_LIBRARY} ${Boost_PROGRAM_OPTIONS_LIBRARY})
+if (TBB_FOUND)
+ target_link_libraries(cgal_rips_step_by_step ${TBB_LIBRARIES})
+endif()
+
+add_executable(cgal_euclidean_distance cgal_euclidean_distance.cpp)
+if (TBB_FOUND)
+ target_link_libraries(cgal_euclidean_distance ${TBB_LIBRARIES})
+endif()
+
+add_executable(subsamp_rips_step_by_step subsamp_rips_step_by_step.cpp)
+target_link_libraries(subsamp_rips_step_by_step ${Boost_SYSTEM_LIBRARY} ${Boost_PROGRAM_OPTIONS_LIBRARY})
+if (TBB_FOUND)
+ target_link_libraries(subsamp_rips_step_by_step ${TBB_LIBRARIES})
+endif()