summaryrefslogtreecommitdiff
path: root/src/Simplex_tree/include/gudhi/Simplex_tree
diff options
context:
space:
mode:
authorvrouvrea <vrouvrea@636b058d-ea47-450e-bf9e-a15bfbe3eedb>2014-12-15 16:56:31 +0000
committervrouvrea <vrouvrea@636b058d-ea47-450e-bf9e-a15bfbe3eedb>2014-12-15 16:56:31 +0000
commit8e83a86b147987cc256812aff78335ac8a26c36e (patch)
tree1a00edc509e882a68dc78feea1e7222b672d8519 /src/Simplex_tree/include/gudhi/Simplex_tree
parentbc09913a3a69da8cc3cbeb3eb796f166ef1025e2 (diff)
CMakeLists.txt uniformization. check_google_style bug fix. generate_version copy Doxyfile
git-svn-id: svn+ssh://scm.gforge.inria.fr/svnroot/gudhi/branches/cpplint_test@352 636b058d-ea47-450e-bf9e-a15bfbe3eedb Former-commit-id: a64f89b97ff3acbcf562070cc59b6065013d4aa1
Diffstat (limited to 'src/Simplex_tree/include/gudhi/Simplex_tree')
-rw-r--r--src/Simplex_tree/include/gudhi/Simplex_tree/Simplex_tree_siblings.h16
1 files changed, 9 insertions, 7 deletions
diff --git a/src/Simplex_tree/include/gudhi/Simplex_tree/Simplex_tree_siblings.h b/src/Simplex_tree/include/gudhi/Simplex_tree/Simplex_tree_siblings.h
index 9ad2b751..977fafa1 100644
--- a/src/Simplex_tree/include/gudhi/Simplex_tree/Simplex_tree_siblings.h
+++ b/src/Simplex_tree/include/gudhi/Simplex_tree/Simplex_tree_siblings.h
@@ -20,12 +20,15 @@
* along with this program. If not, see <http://www.gnu.org/licenses/>.
*/
-#ifndef GUDHI_SIMPLEX_TREE_SIBLINGS
-#define GUDHI_SIMPLEX_TREE_SIBLINGS
+#ifndef SRC_SIMPLEX_TREE_INCLUDE_GUDHI_SIMPLEX_TREE_SIMPLEX_TREE_SIBLINGS_H_
+#define SRC_SIMPLEX_TREE_INCLUDE_GUDHI_SIMPLEX_TREE_SIMPLEX_TREE_SIBLINGS_H_
#include "boost/container/flat_map.hpp"
#include "Simplex_tree_node_explicit_storage.h"
+#include <utility>
+#include <vector>
+
namespace Gudhi {
/* \addtogroup simplex_tree
@@ -69,7 +72,7 @@ class Simplex_tree_siblings {
*
* 'members' must be sorted and unique.*/
Simplex_tree_siblings(Simplex_tree_siblings * oncles, Vertex_handle parent,
- std::vector<std::pair<Vertex_handle, Node> > & members)
+ const std::vector<std::pair<Vertex_handle, Node> > & members)
: oncles_(oncles),
parent_(parent),
members_(boost::container::ordered_unique_range, members.begin(),
@@ -122,10 +125,9 @@ class Simplex_tree_siblings {
Simplex_tree_siblings * oncles_;
Vertex_handle parent_;
Dictionary members_;
-
};
-/* @} */ //end addtogroup simplex_tree
-}// namespace Gudhi
+/* @} */ // end addtogroup simplex_tree
+} // namespace Gudhi
-#endif // GUDHI_SIMPLEX_TREE_SIBLINGS
+#endif // SRC_SIMPLEX_TREE_INCLUDE_GUDHI_SIMPLEX_TREE_SIMPLEX_TREE_SIBLINGS_H_