summaryrefslogtreecommitdiff
path: root/src/Simplex_tree/test/CMakeLists.txt
diff options
context:
space:
mode:
authorROUVREAU Vincent <vincent.rouvreau@inria.fr>2020-03-05 10:03:26 +0100
committerROUVREAU Vincent <vincent.rouvreau@inria.fr>2020-03-05 10:03:26 +0100
commit5b5e9fce6a80151f29f98dde67f5e4150edb9a5b (patch)
tree9c6802c0b62078dc56e1f474048d92009f94bbb1 /src/Simplex_tree/test/CMakeLists.txt
parent73194242e1c8012c1320a7581a382a3b2b59eb09 (diff)
Add some tests and documentation for NaN management in make_filtration_non_decreasing Simplex tree method
Diffstat (limited to 'src/Simplex_tree/test/CMakeLists.txt')
-rw-r--r--src/Simplex_tree/test/CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/src/Simplex_tree/test/CMakeLists.txt b/src/Simplex_tree/test/CMakeLists.txt
index 8b9163f5..cf2b0153 100644
--- a/src/Simplex_tree/test/CMakeLists.txt
+++ b/src/Simplex_tree/test/CMakeLists.txt
@@ -28,3 +28,9 @@ if (TBB_FOUND)
target_link_libraries(Simplex_tree_ctor_and_move_test_unit ${TBB_LIBRARIES})
endif()
gudhi_add_boost_test(Simplex_tree_ctor_and_move_test_unit)
+
+add_executable ( Simplex_tree_make_filtration_non_decreasing_test_unit simplex_tree_make_filtration_non_decreasing_unit_test.cpp )
+if (TBB_FOUND)
+ target_link_libraries(Simplex_tree_make_filtration_non_decreasing_test_unit ${TBB_LIBRARIES})
+endif()
+gudhi_add_boost_test(Simplex_tree_make_filtration_non_decreasing_test_unit)