summaryrefslogtreecommitdiff
path: root/src/Simplex_tree
diff options
context:
space:
mode:
authorROUVREAU Vincent <vincent.rouvreau@inria.fr>2020-02-04 18:05:42 +0100
committerROUVREAU Vincent <vincent.rouvreau@inria.fr>2020-02-04 18:05:42 +0100
commit08596f907e5b4fb99a5c9d51799f54f1b0535071 (patch)
treeabbe8a7d93958de791ded05eb575b8bf983656b4 /src/Simplex_tree
parent06e719e06390da8e34c8e2d380496e8e5023408d (diff)
Fix #186 - Link with TBB for all simplex tree user
Diffstat (limited to 'src/Simplex_tree')
-rw-r--r--src/Simplex_tree/example/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/src/Simplex_tree/example/CMakeLists.txt b/src/Simplex_tree/example/CMakeLists.txt
index f99b164c..8a8cac58 100644
--- a/src/Simplex_tree/example/CMakeLists.txt
+++ b/src/Simplex_tree/example/CMakeLists.txt
@@ -16,6 +16,9 @@ endif()
add_test(NAME Simplex_tree_example_simple_simplex_tree COMMAND $<TARGET_FILE:Simplex_tree_example_simple_simplex_tree>)
add_executable ( Simplex_tree_example_mini_simplex_tree mini_simplex_tree.cpp )
+if (TBB_FOUND)
+ target_link_libraries(Simplex_tree_example_mini_simplex_tree ${TBB_LIBRARIES})
+endif()
add_test(NAME Simplex_tree_example_mini_simplex_tree COMMAND $<TARGET_FILE:Simplex_tree_example_mini_simplex_tree>)
# An example with Simplex-tree using CGAL alpha_shapes_3