summaryrefslogtreecommitdiff
path: root/src/Simplex_tree
diff options
context:
space:
mode:
authorROUVREAU Vincent <vincent.rouvreau@inria.fr>2019-06-19 08:56:56 +0200
committerROUVREAU Vincent <vincent.rouvreau@inria.fr>2019-06-19 08:56:56 +0200
commit9d4e6f28ceeb362c9d751cbac730a13d1b5d61c7 (patch)
tree69c79c54efd7d3b62022f92ce73d091d22a2b0b0 /src/Simplex_tree
parentf9f6288c4815c08d561fc8b2a26fa0f0be1404f2 (diff)
CGAL 4.11 as minimal version
Diffstat (limited to 'src/Simplex_tree')
-rw-r--r--src/Simplex_tree/example/CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/src/Simplex_tree/example/CMakeLists.txt b/src/Simplex_tree/example/CMakeLists.txt
index 1a6de60a..f99b164c 100644
--- a/src/Simplex_tree/example/CMakeLists.txt
+++ b/src/Simplex_tree/example/CMakeLists.txt
@@ -19,7 +19,7 @@ add_executable ( Simplex_tree_example_mini_simplex_tree mini_simplex_tree.cpp )
add_test(NAME Simplex_tree_example_mini_simplex_tree COMMAND $<TARGET_FILE:Simplex_tree_example_mini_simplex_tree>)
# An example with Simplex-tree using CGAL alpha_shapes_3
-if(GMP_FOUND AND CGAL_FOUND)
+if(GMP_FOUND AND NOT CGAL_VERSION VERSION_LESS 4.11.0)
add_executable ( Simplex_tree_example_alpha_shapes_3_from_off example_alpha_shapes_3_simplex_tree_from_off_file.cpp )
target_link_libraries(Simplex_tree_example_alpha_shapes_3_from_off ${GMP_LIBRARIES} ${CGAL_LIBRARY})
if (TBB_FOUND)
@@ -38,7 +38,7 @@ if (NOT CGAL_WITH_EIGEN3_VERSION VERSION_LESS 4.11.0)
endif()
add_test(NAME Simplex_tree_example_cech_complex_cgal_mini_sphere_3d COMMAND $<TARGET_FILE:Simplex_tree_example_cech_complex_cgal_mini_sphere_3d>
"${CMAKE_SOURCE_DIR}/data/points/tore3D_300.off" -r 0.3 -d 3)
-endif (NOT CGAL_WITH_EIGEN3_VERSION VERSION_LESS 4.11.0)
+endif ()
add_executable ( Simplex_tree_example_graph_expansion_with_blocker graph_expansion_with_blocker.cpp )
if (TBB_FOUND)