summaryrefslogtreecommitdiff
path: root/src/Skeleton_blocker/example
diff options
context:
space:
mode:
authorsalinasd <salinasd@636b058d-ea47-450e-bf9e-a15bfbe3eedb>2015-02-10 17:03:43 +0000
committersalinasd <salinasd@636b058d-ea47-450e-bf9e-a15bfbe3eedb>2015-02-10 17:03:43 +0000
commitdef05e2da637a43c02e439af8faaf789214395cd (patch)
treeb2839ae762693a2a09c4876c976772332fc1342a /src/Skeleton_blocker/example
parente50f918673baf48d35c2e2ffa7bfc0e23206612f (diff)
skbl correction bug constructor + contraction add garland heckbert example
git-svn-id: svn+ssh://scm.gforge.inria.fr/svnroot/gudhi/trunk@466 636b058d-ea47-450e-bf9e-a15bfbe3eedb Former-commit-id: 1789e903625df3c4e7c689fa4888bebd86e616eb
Diffstat (limited to 'src/Skeleton_blocker/example')
-rw-r--r--src/Skeleton_blocker/example/CMakeLists.txt4
-rw-r--r--src/Skeleton_blocker/example/Skeleton_blocker_iteration.cpp4
-rw-r--r--src/Skeleton_blocker/example/Skeleton_blocker_link.cpp71
3 files changed, 76 insertions, 3 deletions
diff --git a/src/Skeleton_blocker/example/CMakeLists.txt b/src/Skeleton_blocker/example/CMakeLists.txt
index d9eab4e1..d1228526 100644
--- a/src/Skeleton_blocker/example/CMakeLists.txt
+++ b/src/Skeleton_blocker/example/CMakeLists.txt
@@ -3,6 +3,8 @@ project(GUDHIskbl)
add_executable(SkeletonBlockerFromSimplices Skeleton_blocker_from_simplices.cpp)
-
add_executable(SkeletonBlockerIteration Skeleton_blocker_iteration.cpp)
+add_executable(SkeletonBlockerLink Skeleton_blocker_link.cpp)
+
+
target_link_libraries(SkeletonBlockerIteration ${Boost_TIMER_LIBRARY} ${Boost_SYSTEM_LIBRARY})
diff --git a/src/Skeleton_blocker/example/Skeleton_blocker_iteration.cpp b/src/Skeleton_blocker/example/Skeleton_blocker_iteration.cpp
index 221c7881..92fa17f3 100644
--- a/src/Skeleton_blocker/example/Skeleton_blocker_iteration.cpp
+++ b/src/Skeleton_blocker/example/Skeleton_blocker_iteration.cpp
@@ -41,7 +41,7 @@ typedef Complex::Simplex_handle Simplex;
Complex build_complete_complex(int n){
- // build a full complex with 10 vertices and 2^n-1 simplices
+ // build a full complex with n vertices and 2^n-1 simplices
Complex complex;
for(int i=0;i<n;i++)
complex.add_vertex();
@@ -57,7 +57,7 @@ int main (int argc, char *argv[]){
const int n = 15;
- // build a full complex with 10 vertices and 2^n-1 simplices
+ // build a full complex with n vertices and 2^n-1 simplices
Complex complex(build_complete_complex(n));
// this is just to illustrate iterators, to count number of vertices
diff --git a/src/Skeleton_blocker/example/Skeleton_blocker_link.cpp b/src/Skeleton_blocker/example/Skeleton_blocker_link.cpp
new file mode 100644
index 00000000..0987cc89
--- /dev/null
+++ b/src/Skeleton_blocker/example/Skeleton_blocker_link.cpp
@@ -0,0 +1,71 @@
+ /* This file is part of the Gudhi Library. The Gudhi library
+ * (Geometric Understanding in Higher Dimensions) is a generic C++
+ * library for computational topology.
+ *
+ * Author(s): David Salinas
+ *
+ * Copyright (C) 2014 INRIA Sophia Antipolis-Mediterranee (France)
+ *
+ * This program is free software: you can redistribute it and/or modify
+ * it under the terms of the GNU General Public License as published by
+ * the Free Software Foundation, either version 3 of the License, or
+ * (at your option) any later version.
+ *
+ * This program is distributed in the hope that it will be useful,
+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ * GNU General Public License for more details.
+ *
+ * You should have received a copy of the GNU General Public License
+ * along with this program. If not, see <http://www.gnu.org/licenses/>.
+ */
+
+
+#include <stdio.h>
+#include <stdlib.h>
+#include <string>
+#include <fstream>
+#include <sstream>
+
+
+#include "gudhi/Skeleton_blocker.h"
+
+using namespace std;
+using namespace Gudhi;
+using namespace skbl;
+
+typedef Skeleton_blocker_complex<Skeleton_blocker_simple_traits> Complex;
+typedef Complex::Vertex_handle Vertex_handle;
+typedef Complex::Root_vertex_handle Root_vertex_handle;
+typedef Complex::Simplex_handle Simplex;
+
+
+int main (int argc, char *argv[]){
+ // build a full complex with 4 vertices and 2^4-1 simplices
+ // Initial vertices are (0,1,2,3,4)
+ Simplex tetrahedron(Vertex_handle(0),Vertex_handle(1),Vertex_handle(2),Vertex_handle(3));
+ Complex complex;
+ complex.add_simplex(tetrahedron);
+
+ cout<<"complex:"<<complex.to_string()<<endl;
+
+ //build the link of vertex 1, eg a triangle {0,2,3}
+ auto link = complex.link(Vertex_handle(1));
+ cout<<"link:"<<link.to_string()<<endl;
+
+ //Internally link is a subcomplex of 'complex' and its vertices are stored in a vector.
+ //They can be accessed via Vertex_handle(x) where x is an index of the vector.
+ //In that example, link has three vertices and thus it contains only
+ // Vertex_handle(0),Vertex_handle(1) and Vertex_handle(2) are).
+ for(int i = 0; i<5; ++i)
+ cout << "link.contains_vertex(Vertex_handle("<<i<<")):"<<link.contains_vertex(Vertex_handle(i))<<endl;
+ cout<<endl;
+
+ //To access to the initial vertices eg (0,1,2,3,4), Root_vertex_handle must be used.
+ //For instance, to test if the link contains the vertex that was labeled i:
+ for(int i = 0; i<5; ++i)
+ cout << "link.contains_vertex(Root_vertex_handle("<<i<<")):"<<link.contains_vertex(Root_vertex_handle(i))<<endl;
+
+ return EXIT_SUCCESS;
+}
+