summaryrefslogtreecommitdiff
path: root/src/Spatial_searching
diff options
context:
space:
mode:
authorcjamin <cjamin@636b058d-ea47-450e-bf9e-a15bfbe3eedb>2016-09-22 11:53:21 +0000
committercjamin <cjamin@636b058d-ea47-450e-bf9e-a15bfbe3eedb>2016-09-22 11:53:21 +0000
commit0d9312c183e5f50ed1c71724fd77990fabb085b4 (patch)
tree12f16c4b5bab2b22b717a0f096527e44c4003ee9 /src/Spatial_searching
parent731ebae307759cb1fa05254c7ba8cd922e9eda25 (diff)
Require CGAL 4.8.1 (furthest neighbor is bugged before)
See https://github.com/CGAL/cgal/pull/1105 git-svn-id: svn+ssh://scm.gforge.inria.fr/svnroot/gudhi/branches/subsampling_and_spatialsearching@1535 636b058d-ea47-450e-bf9e-a15bfbe3eedb Former-commit-id: da97775398bd24c7c1bd431686abd66cdf24005b
Diffstat (limited to 'src/Spatial_searching')
-rw-r--r--src/Spatial_searching/example/CMakeLists.txt4
-rw-r--r--src/Spatial_searching/test/CMakeLists.txt4
2 files changed, 4 insertions, 4 deletions
diff --git a/src/Spatial_searching/example/CMakeLists.txt b/src/Spatial_searching/example/CMakeLists.txt
index 0885c24c..0c41d56c 100644
--- a/src/Spatial_searching/example/CMakeLists.txt
+++ b/src/Spatial_searching/example/CMakeLists.txt
@@ -2,7 +2,7 @@ cmake_minimum_required(VERSION 2.6)
project(Spatial_searching_examples)
if(CGAL_FOUND)
- if (NOT CGAL_VERSION VERSION_LESS 4.8.0)
+ if (NOT CGAL_VERSION VERSION_LESS 4.8.1)
message(STATUS "CGAL version: ${CGAL_VERSION}.")
find_package(Eigen3 3.1.0)
@@ -17,7 +17,7 @@ if(CGAL_FOUND)
message(WARNING "Eigen3 not found. Version 3.1.0 is required for the Tangential_complex examples.")
endif()
else()
- message(WARNING "CGAL version: ${CGAL_VERSION} is too old to compile Spatial_searching examples. Version 4.8.0 is required.")
+ message(WARNING "CGAL version: ${CGAL_VERSION} is too old to compile Spatial_searching examples. Version 4.8.1 is required.")
endif ()
else()
message(WARNING "CGAL not found. It is required for the Spatial_searching examples.")
diff --git a/src/Spatial_searching/test/CMakeLists.txt b/src/Spatial_searching/test/CMakeLists.txt
index 571c730a..82c38ca5 100644
--- a/src/Spatial_searching/test/CMakeLists.txt
+++ b/src/Spatial_searching/test/CMakeLists.txt
@@ -11,7 +11,7 @@ if (GPROF_PATH)
endif()
if(CGAL_FOUND)
- if (NOT CGAL_VERSION VERSION_LESS 4.8.0)
+ if (NOT CGAL_VERSION VERSION_LESS 4.8.1)
message(STATUS "CGAL version: ${CGAL_VERSION}.")
find_package(Eigen3 3.1.0)
@@ -27,7 +27,7 @@ if(CGAL_FOUND)
message(WARNING "Eigen3 not found. Version 3.1.0 is required for the Spatial_searching tests.")
endif()
else()
- message(WARNING "CGAL version: ${CGAL_VERSION} is too old to compile Subsampling tests. Version 4.8.0 is required.")
+ message(WARNING "CGAL version: ${CGAL_VERSION} is too old to compile Subsampling tests. Version 4.8.1 is required.")
endif ()
else()
message(WARNING "CGAL not found. It is required for the Spatial_searching tests.")